Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Computer wont let me use USB headset as Default Audio device

01 Dec 2017   #11
Barman58

Windows 10 Pro x64 x3, Ubuntu
 
 

Manual does not mention Drivers

https://images-eu.ssl-images-amazon....1DYOejiPMS.pdf

looks like it could just be a standard convertor using software assumed to be present in PC, does this headset support Windows 7?
There have been some advances in USB technology since the release of Windows 7 - which may be a cause of your issue - Not likely but possible

PDF Manual linked to appears to show Windows 7 dialogue boxes so should be OK

Are your USB ports working Correctly? - plug in other devices to test

Have you tried plugging into the green speaker out socket? - Is this active and working? - If you use this method you should not need to change the output from standard but will not get the fancy artificial sound modes


My System SpecsSystem Spec
.
01 Dec 2017   #12
Humerus

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Yes, they do support windows 7. My ports are working normally, I have plugged my keyboard and mouse plugged in via usb.
the green socket does work; It gives my monitor its sound
My System SpecsSystem Spec
01 Dec 2017   #13
Barman58

Windows 10 Pro x64 x3, Ubuntu
 
 

Try disconnecting the monitor connector from the Green socket and plug in the headset directly, (this will probably not be 100% compatible PCs have separate MIC & Headphone Jacks Your Headset has a dual purpose Jack for Mic and Sound so will be longer than standard but should give some sound out in one or the other speakers - If you get something that it could be a fault with the adaptor (could also plug headset into a smartphone to test as these have the correct socket)

If you do not see an additional option in the control panel sound applet when you plug in the box to the USB then you could have a faulty box

Check the exact instructions in the PDF in the Link I provided or direct one below

91DYOejiPMS.pdf


My System SpecsSystem Spec
.

01 Dec 2017   #14
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok mate now to find that Realtek device please read this and follow
Using HW Info
PART A:
You can test the volts on the PSU with HW Info https://www.hwinfo.com/download.php < download the right bit version and close the right hand window select Sensors and scroll down to the power section where you will see what the volts are doing see my pic. In my pic the section (Nuvoton) with VBATT as a dead give away you are in the section for the rail voltages. There are other section titles and one that pops up often is ITE (sometimes the usual one for Gigabyte boards)
Now the voltage on the different rails have to be within 5% =+/- of what is required or the machine will not work properly if at all.
Limits +/- (minimum - correct - maximum)
12v1 = 11.4 - 12 - 12.6v
12v2 = 11.4 - 12- 12.6v
5v = 4.75 5 - 5.25v
3.3v = 3.135 3 3.465v
-12v = -10.80 - -12 - -13.20v
+5VSB = 4.75 5 - 5.25v
The Power good signal voltage at pin 8 on the 24 pin plug (grey cable) should be the same as the 5v rail reading/s
See this for the rail voltage info
http://www.tomshardware.com/reviews/power-supply-specifications-atx-reference,3061.html (Section 2.)
The original right hand window shows the machine running and is handy for that but for looking at the components in some detail close it and use the main left hand side panel
FOR OTHER COMPONENTS
PART B:
Open each small square with + in it on the section the components are in and then click on the individual component/s (it will highlight in blue) - in the right hand side will appear all sorts of details including brands speeds and other essential info that particular device. See pic for example.



Sorry about the font something has not gone quite right but follow PART B: and open up see my pic for what you are looking for

In my pic is the device in this machine we need to get the details of the device in yours


Attached Thumbnails
Computer wont let me use USB headset as Default Audio device-hwx.png  
My System SpecsSystem Spec
01 Dec 2017   #15
Layback Bear

Windows 10 Pro. 64/ version 1709
 
 

Folks, this might be helpful. Basic specs of the motherboard.

Dell 0GY6Y8 Specs

Jack
My System SpecsSystem Spec
01 Dec 2017   #16
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Good find j=Jck I just want to see the Realtek model to move on that driver and the HW Info should show that up as in my pic.
My System SpecsSystem Spec
05 Dec 2017   #17
Humerus

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Okay Barman, the green socket works just fine. Plugged my headset in and the audio came in clear, mic didn't work (obviously)

Australia I have no idea how to do part A, but I did find the screen you pointed out here:Computer wont let me use USB headset as Default Audio device-audio.jpg


My System SpecsSystem Spec
06 Dec 2017   #18
townsbg

Windows 7 pro 64-bit
 
 

USB headphones create their own "card" and therefore require their own drivers. It is completely different from an onboard card. It literally adds another device to the system. To the OP have you tried the headphones in another computer? What is the name and model number of the headphones?
My System SpecsSystem Spec
14 Dec 2017   #19
looked

Windows 7 Ultimate x64
 
 

Yes OP you most probably need to download dedicated drivers, what is the headphones brand and model?
My System SpecsSystem Spec
15 Dec 2017   #20
rvcjew

7 Pro x64, 10 Pro x64
 
 

OP already stated they have a Cloud 2 and it uses an on-board dac. This firmware update is for PS4 compatibility but perhaps update it anyway to make sure you have not missed another crucial one.

HSCP Firmware update | HyperX (Make sure you do really have a Cloud 2 before installing that, KHX-HSCP-xx)
My System SpecsSystem Spec
Reply

 Computer wont let me use USB headset as Default Audio device




Thread Tools




Similar help and support threads
Thread Forum
Headset microphone not recording when headset is default audio device
Hello So three days ago I wiped all of my drives and installed Windows 10. I have a Corsair Vengenace 2100 headset. I installed the realtek drivers from ASUS download section for my motherboard and then I installed the headset drivers. The problem is that my headset does not record anything...
Sound & Audio
my usb device wont detect headset
so the problem is that my usb device is not detecting my headset and i dont have any headset setup , disc or something that will help me so i appeal to all who can help me I will be grateful if you know the problems fix i can give you an picture if you need it of something just help me fix my...
Hardware & Devices
audio device isn't set as default, can't make it default
Hi all, Windows 7 Home Premium x64 on HP-DM1-4050us laptop, disabled a couple of unneeded services, now headphones not working, no idea which service caused this but I didn't touch either of the two required audio services (Windows Audio, Windows Audio Endpoint Builder). Audio now plays fine...
Sound & Audio
Audio Playback (Default Device Realtek) Knocks Out SRS Audio Sandbox
Hi, I finally upgraded from Windows XP to Windows 7 and almost went back shortly after finding out I could no longer organize or manually arrange my own personal files and/or folders but luckily I discovered an application called 'Folder Options X' which has re-enabled that feature for me so I'm...
Sound & Audio
Unable to set bluetooth headset as (default) playback device
I have a bluetooth headset, and I've paired/added it to my laptop. I check all its services and the drivers installed fine. But for some reason, the sound still goes through the speakers. I went to Control Panel->Hardware and Sounds->Sounds and it only showed 2 entries- Digital Audio (HDMI) and...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App