Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Explorer Malfunctions when Eject CD/DVD

30 Dec 2017   #1
BobT36

Windows 7 Ultimate x64
 
 
Windows Explorer Malfunctions when Eject CD/DVD

I've just done a clean install of Windows 7, installed all my drivers, devices & programs. Now I find whenever I put in a CD/DVD, eject it, then put it back in again (or sometimes just after ejecting & closing an empty drive), it doesn't load and then my Windows Explorer malfunctions.

This means most of my processes stop working correctly, (IE still stays open in the background, I have to manually refresh folders to see changes, file handles staying open, most other things don't work), the PC also gets stuck at the logoff screen and never transitions to "shutting down". Attempting to kill explorer.exe doesn't work either.

Attached pic of what it looks like when reinserting the same disk, on the second time it just doesn't load. Seems to do it with nearly any disk. It's not the drive either as it's doing it with both drives.

I did a clean install on a separate partition (completely fresh, with literally no drivers or anything installed) and I couldn't reproduce the behaviour, so it's definitely not anything hardware / BIOS related. It must be a software / driver issue.

I know the Intel Rapid Storage drivers, and the Marvel SATA controller ones tinker with CD drive stuff. Tried uninstalling and reinstalling these but still the same, I don't think it completely uninstalls the iRST ones though anyway. I also tried switching the controller back to the standard Windows AHCI one but no joy. SFC /Scannow and even a Repair Reinstall didn't change anything either.

Using a Gigabyte X79-UD3 mobo with Intel I7 3960x processor, have Windows on an SSD in AHCI mode. Let me know if need any more info.

I'm thinking of backing up my current instance and then doing another fresh install and testing it after each batch and trying to narrow it down. Takes a long time getting everything reinstalled again though, bah. Anyone ever seen anything like this?


SOLUTION:
Hello visitors from the future. If you're having this problem and have Trusteer Rapport installed, run the Safe Uninstall Tool from here: http://www.trusteer.com/en/support/uninstall-troubleshooting




Attached Images
Explorer Malfunctions when Eject CD/DVD-untitled.png 
My System SpecsSystem Spec
.
30 Dec 2017   #2
Megahertz07

Windows 7 HP 64
 
 

Is there any yellow alerts on Device manager?
Did you check the ODD cables to see if they are well attached?

Run a system file check. Open a CMD window and type:
sfc /scannow
My System SpecsSystem Spec
30 Dec 2017   #3
BobT36

Windows 7 Ultimate x64
 
 

Done all those unfortunately, no problems there.

I even moved my optical drives from the Marvel SATA ports back to the standard SATA ones, and that was a no go either.

Like said whenever I close the disc drive the 2nd time, Explorer doesn't exactly freeze, but stops auto refreshing and then it won't log off. Really weird.
My System SpecsSystem Spec
.

30 Dec 2017   #4
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Explorer freezes may be due to defective cdrom drive. Replacing it with a new one has solved similar problems for me in the past.
My System SpecsSystem Spec
30 Dec 2017   #5
BobT36

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by SIW2 View Post
Explorer freezes may be due to defective cdrom drive. Replacing it with a new one has solved similar problems for me in the past.
Unfortunately it doesn't freeze, it just doesn't refresh itself properly (such as if I make a or delete a folder or something, I have to manually hit F5 to see the change), and then doesn't log off (gets stuck on Logging off screen, and never transitions to shutting down). Other apps and services stop working properly too or don't close successfully.

Also this happens with both drives so it definitely isn't hardware, I'm sure it has to be a driver or software issue, something like the intel management engine or iRST or Marvel controller drivers. The hard part will be working out which.
My System SpecsSystem Spec
30 Dec 2017   #6
Megahertz07

Windows 7 HP 64
 
 

The fist time you put a disk on the ODD it works normally. The problem is only on the second time, right?
Is your AVirus working properly?
My System SpecsSystem Spec
30 Dec 2017   #7
BobT36

Windows 7 Ultimate x64
 
 

I think so, I'll try uninstalling it in a bit.

I'm testing installations from a fresh win install now on a different drive. So far most basic drivers haven't affected it.. Doing updates now, then the last of the drivers, then AV and DVD burning software. If I still can't reproduce it I'll clone my current install to that drive and start uninstalling things instead, tear down rather than build up.

If I STILL can't reproduce it then I'll have to start over from scratch on my standard drive (argh), and be VERY vigilant as I go, testing it after each batch of installs.

On my standard install it does it quite easily. Put disk in, take disk out, put it back in and bam, it ballses up.

I wonder if it is something to do with autoplay, as the standard functionality is after you put a disc in and it loads, Windows very quickly transitions through the icon you see in the OP attachment and then loads the correct icon / disk type and pops up autoplay. The first time autoplay box pops up fine, but the second it seems to get stuck before it gets to that point

Any idea how to reset / fix autoplay? I ran the standard CD/DVD fix it, but no joy there.
My System SpecsSystem Spec
30 Dec 2017   #8
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Bob,

if memory serves when you eject an attached device you get a notification - safe to eject .
im inclining towards this being the culprit.

Try running the System repair tool, SURT
KB947821, could take a while let it run

Roy
My System SpecsSystem Spec
31 Dec 2017   #9
BobT36

Windows 7 Ultimate x64
 
 


SURT didn't help anything unfortunately, the log said no errors.

I also tried unplugging one drive, uninstalling them from device manager etc
but no joy.

HOWEVER I think I may have fixed it, I got frustrated and uninstalled a bunch
of stuff, and it SEEMS to be working now.

Now I'm going to restore from backup and compare what I removed, then test
one by one. It's obviously some software causing a problem. I'll report back
once I've worked out what it is.


EDIT:
Nevermind, spoke too soon.

Weird that I could take it out and back in again on both drives a few times. Now just left it a few minutes, put it back in and it did it again, argh. Hadn't even rebooted or anything.

Hmm back to the research...

Really wondering if it's something to do with autoplay failing only intermittently. I have yet to reproduce it on the new install, but have only installed basic stuff so far, still getting the windows updates on.
My System SpecsSystem Spec
31 Dec 2017   #10
Megahertz07

Windows 7 HP 64
 
 

I asked about the AV because most of them blocks auto play in USB devices and some in CD/DVDs.
My System SpecsSystem Spec
Reply

 Explorer Malfunctions when Eject CD/DVD




Thread Tools




Similar help and support threads
Thread Forum
USB3 malfunctions with AsRock mobo
Hey! I bought this computer a few years back for photo editing. One of the primary features that I wanted was USB3 support because I often have to unload my camera's huge memory cards on my PC. I bought a cheap AsRock motherboard with USB3 support and a Transcend USB3 card reader. The problem...
Hardware & Devices
Screen turns blue and black (malfunctions for 10-30 seconds)
Hello out there. I recently bought a brand new computer as well as a new Monitor (Asus VN247H) Yesterday while playing CS:GO, my screen suddenly turned gray for 2 seconds, then blue for about 5 seconds, then it turned black/looked like the screen was turned off for about 5 seconds as well....
Hardware & Devices
NP504 Weird malfunctions, unable to connect to powerlines
I know that on might not know about this, if anyone knows anyone or anywhere i could get better advice, could they please tell me? I would really appreciate it. My NetComm NP504 which is an powerline Ethernet Adapter recently started not working, the light signifying that it is connected to the...
Hardware & Devices
How to disable auto eject when no CD found in explorer?
In explorer, if you click your DVD drive and there's no cd in it, it gives you some "insert a disc" message and auto ejects. I find that extremely annoying because I will sometimes misclick the DVD drive and it pops up when I don't want it to. I'm not dumb enough to willingly click on an empty...
Hardware & Devices
Browser malfunctions on fresh install
Just finished installing Win 7 I installed Firefox and it worked for a while then it started crashing. Doesnt seem to manner what version never even opens it just crashes. Here is the Message Add-ons: {972ce4c6-7e08-4474-a285-3208198ce6fd}:3.6b1 BuildID: 20091029171059 CrashTime: 1257710118...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App