Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: FlashDrives not Recognized in certain ports ???

04 Jan 2018   #1

Windows 7 Pro x64
FlashDrives not Recognized in certain ports ???

I have already followed this article with no success:

Cruzer flash drive NOT detected by Windows PC

The Problem:
We have two identical 16GB USB-3.0 SanDisk Cruzer Glide flash-drives.

The wife's machine, DELL Optiplex 780m tower, Windows 7 Pro, with a 5-port 3.0-USB card AND a 4-port 3.0-USB panel in the floppy-disk opening.

Until now, everything we have plugged into the 4-port front panel has always worked; flash-drives, ext. HDDs, card-readers, all have always worked in this front panel.

However, the front panel does not acknowledge the presence of either of the new 3.0 SanDisk flash-drives; no device-inserted/removed noise, nothing.
The LED lights do light up though.

I can plug these into any of the front or rear 2.0 ports and they instantly show up; likewise the five 3.0 ports on the rear (on the card).

When I try them in the front 4-port 3.0 panel, they do not appear in disk management, nor do they show up anywhere in device management; other than the lights working, it is if they did not exist.

I have some 2.0 USB SanDisk flash-drives and they work without fail in the front 3.0 ports.

I have the exact same 3.0-USB set-up on my identical machine and these drives work fine in my front panel.

How can I fix this ?

Thanks for reading.

My System SpecsSystem Spec
04 Jan 2018   #2

Windows 7 Professional x64

  • Double-check the BIOS to make sure the front ports set to accept USB 3.0, and make sure you disable selective suspend.
  • What happens if you try other USB 3.0 devices in the front ports? Are they not detected either?
  • It's an OEM Dell so chances of any overclocking are slim to none, but it doesn't hurt to mention removing the OC.
  • Can you post a screenshot of Device Manager with your USB hubs expanded?
My System SpecsSystem Spec
04 Jan 2018   #3

Windows 7 Pro x64

This is the front USB 3.0 panel:

Other 3.0 drives work fine in these ports.

I will get a picture of Device Manager shortly.
My System SpecsSystem Spec

05 Jan 2018   #4

Windows 7 Pro x64

I don't know just what I did, or even if I did anything; but, the problem has went away as mysteriously as it appeared.

I have had these drives in and out of those front panel ports dozens of times during my trouble-shooting efforts without any acknowledgement whatsoever from the computer.

Then, I plugged them both in so that I could get the screen-capture of Device Management; as always before, the first one I plugged in did nothing; then, when I plugged in the second one, I heard the "device plugged in" noise and the autoplay box appeared.

I un-plugged and re-plugged the other drive a couple times and it then connected.

I have since tried several cycles of plug-in/unplug and nine of ten times they are now working.

Anything else I plug in these ports works first-time every-time.

In my research regarding this situation, it seems like I am not alone in this experience, as I found several similar scenarios with the same drives and 3.0 front panels.

Thanks and I appreciate the help.
My System SpecsSystem Spec
06 Jan 2018   #5

Windows 7 Professional x64

Thanks for the update.

I was researching the issue and it seemed like the flash drive itself was the issue, many users online were suggesting that sometimes the flash drive itself was faulty and the connector tips weren't long enough. But with your specific set of circumstances I was baffled as to what the problem was.

Thanks for the update
My System SpecsSystem Spec
06 Jan 2018   #6

Windows 7 Pro x64

Quote   Quote: Originally Posted by aakkam22 View Post
many users online were suggesting that sometimes the flash drive itself was faulty and the connector tips weren't long enough.
Thanks for the info.

It makes sense that possibly the contacts are either not hardly as long, or maybe not hardly as thick, as they should be; thus, they have to be inserted just so or contact is not made.
What also puzzles me is that the LEDs will light even when they aren't being recognized, which leads me to think that maybe the power contacts are sufficient to the task, whereas the data contacts are not.

Now that I have managed to get these to recognize, they do not 100% of the time.

Although I haven't yet actually written anything to them other than a few short test writes, I am now wondering that, if it is a contact issue that is fault of the drives, they might possibly "drop out" in the middle of reading/writing.
My System SpecsSystem Spec

 FlashDrives not Recognized in certain ports ???

Thread Tools

Similar help and support threads
Thread Forum
Thumb drive not recognized in two of three ports
Hello, I have an Acer 5230E-2177 which has a usb port in back that if I plug in my thumb drive I can get all my files. But if I plug into either of the usb ports on left side nothing happens. Went to Device Management by way of Computer:Manage, and only three drives show up usually which...
Hardware & Devices
ASUS A78M-A, front USB 3 ports, not recognized
Hi, ive just bought in a batch of ASUS A78M-A motherboards for some customers, fully installed with the latest chipset drivers from AMD, thought I should check the front USB 3 ports to find it comes up with anything plugged in (USB3 WD external drive + 16Gb Sandisk dongle) as "Not Recognized". ...
Hardware & Devices
All USB ports don't recognized usb drives but do see other devices
I can't remember exactly how this happened because it's been a cascading disaster. It started with my efforts to uninstall Crashplan. In the course of this I unplugged one usb drive (I have 6) from a hub while it was on. At the time everything seemed ok, but it was not the case once I shut down...
Hardware & Devices
USB device not recognized, only at 4/12 ports
Hello I have Kingston 2GB DataTraveler (DT) and windows 7 RTM 64bit does not recognize it when pluged into 2 front usb ports or 2 top back usb ports. Other 6 lower back ports work. I have Gigabyte GA-EP35-DS3 mobo. This mobo has 8 usb on the back and 2 usb headers. One header is used for Codegen...
Nothing is recognized thru USB Ports Win7rc 7100
Can anyone help me i'm running win7rc build 7100 and none of my usb ports are properly working.external drive lights up but will not show up in flash drives not even PCMCIA card with usb ports.PCMCIA card drivers install but usb ports don't work (WTF MS).In device mng. there is no...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:36.
Twitter Facebook Google+