Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't load Devices and Printer Options Anymore

31 Jan 2018   #1

Windows Home Premium 64 bit
Can't load Devices and Printer Options Anymore

From my control panel:
Control Panel\All Control Panel Items\Devices and Printers
I can no longer load my printers (and presumably devices).

When I try to open it, I get a slow green bar at the top, that never finishes.

I have seen many posts saying that you need to go into Services, and switch to automatic and/or start the service.

When I go into services, my only Bluetooth option is Bluetooth Support Service (which is disabled)

Service status (Start, Stop, Pause, Resume, Restart) is greyed out, and I can't make any changes

When I change Bluetooth Support Service to Automatic, and hit OK or Apply, I get a message that says "The system cannot find the path specified."

I suspect there is something I am going to need to do in the registry, but I don't know what.

My System SpecsSystem Spec
31 Jan 2018   #2

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, Kali, VMWare Workstation Player, OpenVPN

Hi DPCristm,

Take a look at these websites regarding your issue.
Have a few questions for you.
When did your problem start?
Did you recently add or change any peripherals, programs, etc., just prior to your issue?
Do you have any restore points prior to your issue?
Do you have a recent backup/image of your system prior to your issue?
My System SpecsSystem Spec
01 Feb 2018   #3

Windows Home Premium 64 bit


Tried the steps listed in those articles with no luck.
Not sure exactly when because it is not a feature I go into often.
I haven't added any peripherals. just one printer/scanner combo that I have had for about 5 years.
I can't say about the restore points, since I don't know when the issue started.
However, I have already tried a restore to the earliest point available with no luck.
Since then, I accidentally deleted my restore points with a disk cleanup.
I did create backup disks when I first got the computer, and would have to find them. However, I don't want to reset things that far back if I can avoid it.
My System SpecsSystem Spec

14 Feb 2018   #4

Windows Home Premium 64 bit

Anyone have any ideas on this. Very frustrating, getting no where with all the regular steps.
My System SpecsSystem Spec
14 Feb 2018   #5

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, Kali, VMWare Workstation Player, OpenVPN

Repair install/in-place upgrade will correct your problem, reinstalls windows, leaves your programs, files, folder, pictures, etc. Hyperlink is to Shawn's tutorial on it.

Do you have a Windows 7 x64 installation disk or have you downloaded the ISO (file) from Microsoft or If your Windows 7 is OEM (original equipment manufacturer) you won't be able to do either. from Microsoft you'll need your 25-character product key when they as for it. If that's not and option, you may be able to locate a friend who has one and borrow it (I'd make a copy of it while you have it)!
My System SpecsSystem Spec

 Can't load Devices and Printer Options Anymore

Thread Tools

Similar help and support threads
Thread Forum
A USB2.0 Port Doesn't Recognize Devices Plugged In Anymore
A few days ago, a friend of mine rammed his office chair to the side of my USB stick breaking it and additionally caused a physical trauma the USB port it was plugged in (on the front panel). Left port is not recognizing devices EDIT: Gallery of assembly: ...
Hardware & Devices
Asrock H67M / Etron USB: Can't access USB Mass Storage Devices anymore
Hi, it's driving me mad :devil: My system: Asrock H67M Mainboard with Etron USB 2.0/3.0 chipset Windows 7 Ultimate with all current fixes applied The problem: I just discovered by accident that no matter what USB Mass Storage device (USB-MSD) I plug into my PC (and also no matter if I...
Windows 7 64-bit suddenly doesn't load anymore!!
Hi all! I had my laptop running last night and I woke up this morning and my computer was frozen. It wasn't the "blue screen of death" as many mention as it was simply frozen but when I turned it back on (and continue to turn it back on) it gets stuck on "Starting Windows" without even proceeding...
General Discussion
Printer name in Devices and printer keeps changing every few seconds
Hi, I have an MX850 and an MX870 printer both connected to my LAN. I also use an application called CD Label Print. When I started that program I noticed that there were 3 MX850 printers listed, the original and a (Copy 1) and (Copy 2). So I went to devices and printers and saw there...
Windows 7 won't load anymore
Hello all. not sure I'm in the right forum but whatever. I'm running a dual boot system with Slackware Linux and Windows 7 Ultimate 64-bit. Using the LILO boot manager to switch between things. Everything was working fine, just did a fresh install of both OS's. I was fiddling around under...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App