Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problem with RAM

07 Feb 2018   #1

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
Problem with RAM

Have an Asus P8Z77-V board and just installed 16GB RAM being 4x4GB sticks all same brand and speeds Timings etc

The RAM is G Skill ARES 2133MHz and I have set the speed in the BIOS to 2133MHz in both manual and XMP modes but it is showing up in Speccy and HW Info as running at 1067MHz. The machine is booting and running slower than when I just had two 4GB sticks of 2400MHz RAM in so can anyone suggest what I do as I am not that familiar with setting the voltages etc and obviously why is the stated stick speed not functioning??

Any advice greatly appreciated.

Attached Thumbnails
Problem with RAM-ram.png  
Attached Images
Problem with RAM-ram2.png 
My System SpecsSystem Spec
07 Feb 2018   #2

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Oops missed that one went right past me I was a bit blinded by the extremely slow boot but after a couple of reboots the speed is back.

So problem solved
My System SpecsSystem Spec

 Problem with RAM

Thread Tools

Similar help and support threads
Thread Forum
Problem with BSOD arising randomly. Problem more frequent. NTSF.SYS
Having an issue with a computer going into BSOD with no warning. The computer's information is attached. There really isn't any more information to give. It started relatively recently. Nothing different was downloaded to the computer. AVAST is not installed. Not utilizing Daemon tools. Any...
BSOD Help and Support
Intel Rapid Storage Technology problem : Empty port problem
Windows 7 Home Premium, 64 bit Gateway Laptop NV55C (I would upgrade ut currently not working so a major hardware upgrade is gonna have to wait :( I've got the latest SATA AHCI Driver for my system according to Gateway. As for the latest Intel RST software/drivers, I have version on...
Hardware & Devices
Blurry Text problem, EDID and registry editing problem on an AMD card.
EDIT:I have found a solution, using a DVI to HDMI cable on an amd card will fix this problem, this thread can now die, hopefully someone else will find it if they have this problem. Basically, i know what the problem is, but not how to rectify it. My tv (Sceptre X235BV-FHD, a rebranded sony...
Graphic Cards
problem event name startup repair offline - slightly different problem
Hi, Hoping somebody can help with this problem which despite trawling through these very helpful forums & tutorials, I have been unable to resolve. I have tried to include all the information possible although I am relatively new to this field so my terminology is probably not completely...
General Discussion
"A problem occurred while trying to open this message. A problem occur
HI, I'm new to the forum. When I receive mail in WLM, if I open it right away. problem. If I leave a message unopened then shut down and reboot I can't open the message. I get the error message... "A problem occurred while trying to open this message. A problem occurred. Please try...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:06.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App