Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sata II Host Controller wont detect Hard Drives.

29 Mar 2018   #1
Terrek

Windows 7 Home Premium 64bit
 
 
Sata II Host Controller wont detect Hard Drives.

Hello everyone, my windows 7 pc was running fine yesterday. I shut down last night and upon turning it on today it will not boot up.

1. I first get a message saying: PCI Express to SATAII HOST Controller-
"Detecting Drives; Done; No drives are detected"

2. After several minutes on this screen it goes black with just a flashing cursor in the corner.

3. Then after several minutes it shows the BIOS Version Initialing screen.

4. After several more minutes it shows a list of my SATA drives, including their name, size and speed.
At the bottom of this screen it says "Press Space to Continue"....doing so does nothing.

I left the pc on the screen in #4 while typing this, it then went to the Windows Loading screen, after a few minutes it showed the screen in #1, and the proceeded to display screens 2-4 again over several minutes

5. Windows Error Recovery Screen then came up, and I told i to "Launch Startup Repair". The screen changed very slowly, from top to bottom, to the screen saying "Windows is loading files..." with progress bar, It has been on this screen for at least 10 minutes.

6. I am now having Startup Repair attempt a System Restore.

I have not changed any hardware or programs in the last several months. The only other issue I have had recently is the sound cutting out while playing Star Wars Battlefront 2. However, closing the game and relaunching it fixed the issue both times it occurred. The sound worked fine with other programs (Internet Explorer playing YouTube video) at the same time sound wasn't working in the game, so I thought it was just related to that game.


Has my hard drive failed? It is relatively new, maybe about a year. Or could it be a bad cable?
I tried disconnecting the hard drive and plugging in an older one. (The new one is a clone of the old one), but it was not detected either.




Attached Thumbnails
Sata II Host Controller wont detect Hard Drives.-screen1-no-drives-detected.jpg  
My System SpecsSystem Spec
.
29 Mar 2018   #2
Terrek

Windows 7 Home Premium 64bit
 
 

Update #1:

Since first post, my computer seems to have completed a system restore. It prompted me to restart, and over the last 15 minutes it proceeded through all the screens I listed above. However, Windows finally started up and I was able to get on the pc.
I am running MalwareBytes just in case it was some kind of virus or something, but I'm guessing it's probably a hardware issue?
My motherboard and CPU are the only components that I did not replace around the beggining of 2017, so they are 6-7 years old now I believe.
My System SpecsSystem Spec
31 Mar 2018   #3
Terrek

Windows 7 Home Premium 64bit
 
 

Update #2:


Computer ran fine yesterday, let it install some Windows Updates before shutting down for the night.

Turned it on this morning and it wont boot up again. This time the Windows Boot Menu eventually came up and I hit F8 for advanced options. I told it to do a Startup repair, and am currently waiting on that to finish

Could it be the Windows Updates that at messing it up? I don't know if it automatically installed those updates before the first time this started occurring...

I don't know for sure which updates they are at the moment, I believe it was 6 total, with several security updates, and one optional update for my xbox360 controller.


Edit #1:

Windows Startup Repair said it could not detect a problem, but that I should disconnect any recently connected items and restart. I disconnected my xbox360 controller and my led headlamp and hit restart and the computer seems to have restarted normally.....

Hopefully I just need to make sure those things are unplugged before turning the computer on first thing and Ill be ok....

Could it be that the usb ports are going bad? Or is it one or both of the devices themselves that are somehow causing an issue?
My System SpecsSystem Spec
.

03 Apr 2018   #4
Megahertz07

Windows 7 HP 64
 
 

Is your BIOS up to date?
Did you check the boot priority on BIOS?
It may be trying to boot from USB.
I suspect you may have a disk problem.
When running windows, schedule a disk check.
Pay attention on the results, specially bad blocks and bad clusters.
My System SpecsSystem Spec
03 Apr 2018   #5
samuria

win 8 32 bit
 
 

Are the disk sata3 I have had problems when connected to sata2 ports and there should be a jumper settings on the drive to set it too sata2 it then works ok. If it can't find disk on boot press reset not power and see if it works as it can be the disk slow to spin up so the BIOS doesn't get a reply when it asks for disk
My System SpecsSystem Spec
Reply

 Sata II Host Controller wont detect Hard Drives.




Thread Tools




Similar help and support threads
Thread Forum
Drives will not connect to USB3 host controller
I just got a new Dell Precision T7810 at work. When I plug in USB3.0 external hard drives to the SS USB 3.0 ports, they connect as USB2, and get the balloon popup "This device can perform faster". I have tried everything - uninstalling and re-installing the latest USB3.0 controller drivers and...
Hardware & Devices
Possible bad MOBO/Sata Controller ? or 2 dead hard drives out of box?
Hi, I attempted to help save my grandfather in law some money when he told me he was going to have to have windows reinstalled on his computer. I told him I would do it for free, having formatted and re-installed windows a number of times. Here is as concise as I can be what happened - ...
Hardware & Devices
Installation won't detect my PCI adapter for IDE & SATA drives
Just built a moderate spec gaming PC from scratch, and all has went according to plan except when I try to install Windows 7, my hard drive won't show up. My new motherboard doesn't have any IDE slots, but I only have an IDE hard drive. I am using a 'Pluscom Serial ATA PCI Adapter' to connect my...
Hardware & Devices
HighPoint SATA III Host / RAID Controller Card Problems
So I have had a HighPoint 644 SATA III 6.0 GB host card in my system for some time now, and yes, it was a total pain to set up when I initially installed it. I recently picked up a new 3TB SATA III 6.0 GB drive (newegg had uhm on sale) and I had a spare HighPoint 620 SATA III Host / RAID...
Hardware & Devices
Windows 7 Wont Detect hard drives when installing over network
when i try installing windows 7 on my netbook over a network it wont detect my hard drives
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:51.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App