Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Print Spooler Not Working / Crashing / Spoolsv.exe Runtime Error)!!

24 Apr 2018   #1
LouieP9086

Windows 7 Home Premium 64-bit
 
 
Print Spooler Not Working / Crashing / Spoolsv.exe Runtime Error)!!

I recently deleted a Lexmark printer driver that I had previously downloaded (in order to use someone else's printer a while back). Now, I am getting a runtime error related to the Window 7 print spooler which slows down my boot time; and the error interrupts me with windows constantly. I also can't access the "devices and printers" section within windows

I've tried everything I could find, but this "Spoolsv.exe" runtime error keeps appearing. It's severely slowing down performance of my system.

The error that pops up with the title; Interactive Services Detection
Message: "A Program Running on this computer"
When I click "View Message" that's where it tells me that it's a Spoolsv.exe runtime error.


I've tried many things including these suggestions found on forums;

1. Removing the Spoolsv.exe file from the "windows/system32" folder; which I am unable to do due to permissions (it says Trusted Installer only has permission)
-I am also unable to to change the permissions of this file. A user "TrustedInstaller" has full control of it and I can't seem to change this.

2. Deleting the other printer drivers by deleting the files in the "system32/spool/drivers" & "system32/spool/PRINTERS" folders.
-Permission issues also seem to prevent me from deleting everything in the "/spool/drivers" folder.

3. Starting and restarting the "Print Spooler" service within "services.msc"

Please help! I am in desperate need of assistance.

Thanks in advance to anyone willing to help me.

This is a total nightmare.


My System SpecsSystem Spec
.
24 Apr 2018   #2
LouieP9086

Windows 7 Home Premium 64-bit
 
 

I was able to get past the the issues with the permissions; and was able to remove the spoolsv.exe file (and restart). I then replaced it again; and restarted. However, this did no resolve the issue.

The only option for me to keep my system running without interruption is to turn off the Print Spooler in services.msc. Otherwise, I keep getting the error from the "Interactive Services Detection" about the spooler failing.

Can anyone help me fix my print spooler?
My System SpecsSystem Spec
25 Apr 2018   #3
LouieP9086

Windows 7 Home Premium 64-bit
 
 

I resolved the issue...

For those who may be having this problem with "Interactive Services Detection" causing errors in your spoolsv.exe:

Note:
The issue for me was caused by me installing a Lexmark printer driver on my laptop (to print on friends printer). When I removed the driver, additional junk printer software was left on my system that the spoolsv.exe depended on.

Resolution:
Below are the steps to how I went about fixing the issue. In a nutshell, I turned off the print spooler, then removed any-and-all print drivers & startup entries from the registry.

1. Go to "Services.msc" (start->search)
2. Select Print Spooler: Set to Manual and Disable.
3. Download the software "Autoruns"
4. Identify any printer drivers and delete the registry keys (especially ones that are labeled "Interactive Services Detection")
5. Go back to "Services.msc" (start->search)
6. Select Print Spooler: Set to Automatic and Enable
7. Re install only the print drivers you need.

Other Notes:
"Interactive Services Detection" seems to be bloatware that Lexmark printer driver software will install on your system. Just deleting the Lexmark drivers doesn't seem to remove the "Interactive Services Detection" which marries itself to the Windows print spooler. The registry keys also need to be removed or your print spooler will keep looking for this ("Interactive Services Detection") Lexmark executable file (and the spooler will time-out and shut down if it's not found)

Hope this helps someone else who it having this problem. it took me several hours to resolve.

Even though I didn't get any help, I'm glad I could contribute to this (well SEO'd) help forum.
My System SpecsSystem Spec
.

Reply

 Print Spooler Not Working / Crashing / Spoolsv.exe Runtime Error)!!




Thread Tools




Similar help and support threads
Thread Forum
Print Spooler Service Is Not Working
Hi, both of my printers: HP 1022 Canon IP4300 Have stopped showing in any documents that I want to print from such as PDF Acrobat and Outlook 2010 and any other. They state that I don't have any installed but if I look in control panel then the HP is there but under unspecified and the...
General Discussion
Print Spooler Error
Hello, I'm having problems with my mother's Laptop with the spooler, for some reason this keeps popping up everytime I want to "Add a printer", but I have watched a few video clips and I was thinking then.. In the services, the word "Print Spooler" don't exist on her laptop, BUT there is another...
Hardware & Devices
Print Spooler error in Event Viewer
Hi, While checking out the Event Viewer a few days ago I saw this entry: The print spooler failed to load a plug-in module C:\Windows\system32\spool\DRIVERS\x64\3\UNIDRVUI.DLL, error code 0xc1. See the event user data for context information. The printer is a HP C-5580 Photosmart...
Performance & Maintenance
Print spooler not running /crashing
Hello, I am using a Windows 7 Home premium (x64) laptop and a Canon MP560 printer. Anytime I try to print from my laptop to my printer (through a wireless network), an error pops up which reads: "Windows cannot connect to the printer. The local print spooler service is not running. Please...
General Discussion
Print Spooler Constantly Crashing
We have several machines on our campus that are experiencing issues with the print spooler crashing constantly. As soon as we would start the spooler service, it would crash about 20 seconds later. I have removed all printers and drivers and then re-installed them. Our printers are installed via...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:02.
Twitter Facebook Google+