Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Alienware eject button not working

09 Jun 2018   #1
Ridgerunner

win 7 64bit
 
 
Alienware eject button not working

I was on an old thread where folks were describing the eject button not working on Alienware machines. I had the same problem. The eject buttons on both my Alienware laptop and desktop quit working around the same time and nothing I tried fixed it. I just looked at the old thread again where someone suggested installing a missing ODD driver. I tried that and it fixed it immediately on the desktop after a year of it not working. I can only imagine this was caused by some Windows update. Whatever it was downloading the driver and installing it fixed the issue. Now I have to try it on the laptop. When I tried to post this information on the old thread I got into an aggravating circular thing of not being able to log in, trying to change my password, which it just wouldn't let me do. What a mess. Now I have no clue what my password is on that Microsoft help forum, whatever it was.


My System SpecsSystem Spec
.
10 Jun 2018   #2
fireberd

Windows 10 64 bit
 
 

I don't know why the ODD driver worked. In modern OS' including Win 7 the only driver for optical (disc) drives is the built in Microsoft/Windows drivers. I do support on the Dell forums and have not seen this problem for a long time (last time was an Alienware built before Dell acquired the company so it was an old drive with a hardware problem).

I had a problem with a USB connected disc drive about a month ago. Manually ejecting it with a paper clip in the manual eject hole in the front of the drive fixed it. It now ejects with the eject button again. It had nothing to do with any Windows driver. The manual eject procedure is what we have used on the Dell forum since I started in 2002.
My System SpecsSystem Spec
Reply

 Alienware eject button not working




Thread Tools




Similar help and support threads
Thread Forum
Packard Bell Ixtreme dvd/cd eject button
hi everyone thought i would post this thread for anyone having problems with the eject button the norm is to use the button manager software(Gateway Photo Frame Software Version 4.2.3.10) that only runs when windows is running after you log in. well i made a discovery after having one of these...
Hardware & Devices
Dell Inspiron 1440 eject button on the keyboard is not working?
Hello I did a fresh install of windows 7 and I downloaded all the drivers but the eject button on the keyboard is not working does any body know what could be the issue?
General Discussion
Computer shuts off when I press Eject button on DVD Drive
Morning, Totally odd one here and the first time I have every seen it. Recently built a new studio (recording) rig...with the following parts: CPU: Intel Core™i7 3770K Motherboard: ASUS P8Z77-V Graphics: PNY Quadro FX380 Network: Intel 82579 Gigabit Ethernet
Hardware & Devices
Eject button fix, please help.
So I have a Dell studio, I use to run Ubuntu 10.04 on there and I re-installed Windows 7 on there. The problem is my disc drive has a button on the key board to eject the disc cause my I don't have the disc tray I have the slot on the side where you just slide the disc in, since I have re installed...
General Discussion
packard bell ixtreme eject button on pc case not working
Trying to find the driver for the cd/dvd button on the pc case? IXTREME X6620 UK http://social.answers.microsoft.com/Forums/en-US/vistawu/thread/5a404133-1ace-4e75-9d36-5f4ec025f818
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:17.
Twitter Facebook Google+