Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't delete certain files after installing HD in new media player

10 Nov 2018   #1

Windows 7 Proffessional 64-bit
Can't delete certain files after installing HD in new media player

Hello everyone,
I'm having a problem with an NAS hard drive where I cannot move and delete certain files from the drive via Windows Explorer on my Windows 7 PC. Up until a few weeks ago, the drive was set up as a NAS drive in my Popcorn Hour C-200 media player where I would store most of the movies and tunes I downloaded. That media player died back in August so I recently bought a Zidoo Z9 to replace it. I removed the Hard Drive from the Popcorn Hour and attached it to the Z9's SATA connector and everything seemed to be fine until I just noticed I'm unable to move and delete certain files, I get an error that reads
"file access denied,
you need permission to perform this action,
you require permission from Unix User\1001 to make changes to this file" then below that message is the file name/type/size and date modified.

I never had problems moving or deleting files on this hard drive when it was installed in the Popcorn Hour media player, the problem just started since I hooked the drive up to the Z9 media player. It's not affecting all files and folders, I was able to move some files but not others. For what it's worth, the first folder I tried to delete but got the error message, I was able to successfully delete that folder using the Z9s delete function. I've also been able to successfully add folders and files to the drive via Windows Explorer on my PC, I'm just not able to move and delete files. To fix the problem, I tried following the directions in the YouTube video below,
Fix File Access Denied-You need permission to perform this action in windows 10/8/7 - YouTube
but after I entered the name of my PC, I got an error that read in part "an object with the following name cannot be found" "XPC". XPC is my computer name.

I also tried the instructions listed at the following
Resolve 'Destination Folder Access Denied. Need Permissions to Perform this Action' - Windows 7
but got an error that read
"error applying security
an error occurred while supplying security information to
Access is denied." Then another pop-up window read "unable to set new owner on 20180813184131785
Access is denied."

So, I'm not sure what the problem is. Again, for what it's worth, my userid on this PC is set as administrator. Could this problem have anything to do with the openWRT function on the Z9? When I first set up the Z9, I noticed it had changed the name of the hard drive to a long string of numbers and the following characters: (\\OPENWRT). The drive itself is an old Seagate 500 GB 2.5" internal drive hooked up to the Z9's SATA port.

I hope I have provided enough info, thanks in advance for any info you can provide.

My System SpecsSystem Spec
11 Nov 2018   #2

Windows 7 HP 64

Can you move or delete files you add to the Z9 or you can't only on existing files created by C-200?

A NAS device has an OS. Normally they have Linux or Android (that is also based on Linux).
Probably files created by the OS on the C200 can't be changed by the Z9 as Z9 isn't the owner.

As this is a Windows Forum, my suggestion is that you post your issue on a Z9 forum.
My System SpecsSystem Spec

 Can't delete certain files after installing HD in new media player

Thread Tools

Similar help and support threads
Thread Forum
Windows media player won't let me delete music or albums.
Why won't windows media player let me delete music or albums from my library? How do I fix this?
Media Center
Files get pixelated in media player classic but not in vlc player
I have a very interesting issue. It's not an issue that bothers me excessively, and I could live with it, but I'd like to get to the bottom of it nevertheless. I've attached pictures to explain my particular problem. Basically, I have Media Player Classic (v1.6.5.6366) and VLC media player...
Music, Pictures & Video
Change default media player, icons on media files not changed
I have VLC Portable as the default program for opening some video files, like .mp4 and .avi. And I have Foobar (portable) as the default program for .mp3. Usually the icons on .mp4, .avi, .mp3 files get updated with the icons of the assigned media players. But on this PC it's not working....
Music, Pictures & Video
Delete Media Player Cached .tmp Files?
So, for a while I have been searching for the reason why my 150 gb drive is super crazy full...I just moved all my back up data onto an ext hdd and deleted the local files....much to my surprise i still had giant unbelievably huge amounts of gb taken up in my users/etc location. So I go through...
Music, Pictures & Video
Windows Media Player & Center, problems with .mkv files & .srt files
Hi All, I found this forum on the internet and I'm so proud to be registred on it :). Hope I could find answers to all my questions here and we could solved them together :) I will really appreciate! So, I have Windows 7 Ultimate x64 Beta Build 7000 running on my computer (very proud of it, 90%...
Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:45.
Twitter Facebook