Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: old HDD not detected when used as external drive

2 Weeks Ago   #1
JSmith2011

Win7 SP1
 
 
old HDD not detected when used as external drive

Good afternoon guys.


I have a Lenovo V570 laptop with a 1TB HDD which was on the blink and was throwing errors about once a week. A very nice person on this forum suggested I swap out the old HDD for a new one - which I did. Using the same laptop, I'm now using the new HDD and it's working great with everything transferred over.


Problem is, when I attach the OLD HDD to the computer (also tried on 2 others) to try and get some old files off, it's not showing up when connected via the USB port. It will say "searching for drivers.....drivers could not be found".


Any ideas what else I could try? It's strange why it would run just fine as the primary HDD but not as an external drive.



Would appreciate any insight everyone might have. Thanks in advance.


My System SpecsSystem Spec
.
2 Weeks Ago   #2
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Hello there,

What are you using to connect the HDD to a USB port? Are you using an external hard drive caddy or enclosure? If so, what make and model number is the enclosure?

Have you checked Disk Management to see if the HDD shows up there?

Had you checked Device Management. to see if there are any devices displaying exclamation marks within yellow triangles?
My System SpecsSystem Spec
2 Weeks Ago   #3
JSmith2011

Win7 SP1
 
 

Hi Iko - no, just a regular Apricorn file transfer cable. What's strange is that I can view the files on my home laptop the same way, but on this laptop I can't. (I'm on the computer using the old HDD right now)


Disk Management doesn't show it either.
My System SpecsSystem Spec
.

2 Weeks Ago   #4
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Did the cable come with cloning software on CD? Perhaps the device drivers are on the CD.
My System SpecsSystem Spec
2 Weeks Ago   #5
JSmith2011

Win7 SP1
 
 

Nope, it's just a regular cable. One side is the USB side and the other fits into the back of the HDD.
My System SpecsSystem Spec
2 Weeks Ago   #6
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Oh dear. Perhaps it would be worth comparing the two device manager windows from both laptops. If the device is recognised on one laptop, then should show in device management. If so, what is the device driver id?

Are you sure the connectors are firmly pushed into the computer USB and SATA connector?
My System SpecsSystem Spec
2 Weeks Ago   #7
JSmith2011

Win7 SP1
 
 




Cables are firmly in place and still nothing. Can't really feel it spin either which leads me to believe there isn't enough juice to power it. Do all HDD's require an external power source to power up or is the USB power enough?
My System SpecsSystem Spec
2 Weeks Ago   #8
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

That picture is of Disk Management. Do you have a picture of Device Manager, from the Home Laptop. Should look like this: old HDD not detected when used as external drive-device-manager.png

You want to open up the IDE ATA/ATAPI controller tree, and the Universal Serial Bus controllers tree. Try this witht he cable plugged into the home laptop.


Yes, most External enclosures require their own power supply. Apricorn SATA-wire does not require separate power supply - if that is what you have got. But Apricorn SATA-wire comes with CD. What happens if you plug cable back into home laptop? Can you feel the drive running?


My System SpecsSystem Spec
2 Weeks Ago   #9
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Apricorn SATA-wire only works on USB 3.0 connector - if that is the product that you have got.
My System SpecsSystem Spec
2 Weeks Ago   #10
JSmith2011

Win7 SP1
 
 

Here is the cable I'm using





I had to put the new HDD back in my machine to finish some work. Any idea why the old HDD won't come up in Disk Mgmt but will come up as the primary boot HDD?
My System SpecsSystem Spec
Reply

 old HDD not detected when used as external drive




Thread Tools




Similar help and support threads
Thread Forum
External Hard Drive not detected
External Hard drive (of 2 TB) was connected to my Laptop (Running Windows 7 Home Premium). System was shut down abruptly (I guess something was being read/write from the external HDD). I tried restarting (with the external HDD connected) and the system would not proceed from the "Windows is...
Hardware & Devices
External Hard Drive not Detected
I have a small 50gb HHD powered from USB It will connect to my laptop running windows 7 home premium but not my pc running windows 7 professional When plugged into my pc by usb the Disk does not power up and spin (the light does come on) There is no recognition of it in my computer, device...
Hardware & Devices
External hard drive not detected---again
I have an 1T external drive plugged into esata port. It used to work and now it doesn't? When I boot up bios correctly identifies the drive as a seagate sata drive. When I look at device manager is says its a seagate SCSI drive and therefore the system doesn't recognize it at all? In device manager...
Hardware & Devices
External hard drive not detected
Hi guys, My computer cannot detect my 250GB external hard drive and I'm having a hard time fixing this issue, and I've been searching for the problem to be fixed in the internet, unfortunately nothing was found. Before this issue happened, there was no problem, it was working fine until I did...
Hardware & Devices
External hard drive not being detected
Hi, I have been using my Iomega HDD for a while now and have never had any problems before today. It worked fine when connected to my Acer Netbook running windows 7 starter 32 bit. I connected to a friends laptop and it said to access it it must be formatted, so i bought it home and it said the...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:57.
Twitter Facebook Google+