Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 4 TERIBYTE USB DRIVE NTFS shows up as 3.69T

16 Feb 2019   #1

4 TERIBYTE USB DRIVE NTFS shows up as 3.69T

FOR WINDOWS 7 64 - 32 bit Operating Systems

I thought NTFS could only see 2 terabytes but it does see 3.69 T on my usb external ? WHAT ?

Is UEFI required for a GPT disk?
No. GPT disks are self-identifying. All the information needed to interpret the partitioning scheme of a GPT disk is completely contained in structures in specified locations on the physical media.

Will I need a UEFI computer Bios to format a GPT DISK or some special utilities ?

I have yet to see any documentation that tells me whether or not a 4 T internal hard drive can be installed in a windows 7 64 /32 bit OS it appears if I use GPT I can use any size a disk I want. ?

When I use NTFS can I split the drive up in 2 partitions ?
Thank you !

New Technology FILE SYSTEM
Globally Unique Partition table
Unified Extensible firmware interface
Master Boot Record

My System SpecsSystem Spec
16 Feb 2019   #2


the only size restrictions I'm aware of is 2 to the power of 64 clusters, which is about 2TB for 512bytes cluster, which are used by MBR partitions. However GPT partitions can have larger size clusters and for 4kB cluster limit would be 16TB and 64kB cluster limit is 256TB. Those limits are for Win 7 and up and for example Win xp had other size restrictions on top. I've been using 3TB drive for backup for many years and it works fine.
My System SpecsSystem Spec
16 Feb 2019   #3
Lady Fitzgerald

Win 7 Ultimate 64 bit

UEFI is needed with GPT disks only if installing an OS on them. I have 25 4TB disks all formatted GPT and all are working fine for data disks. All were formatted on machines using MBR drives for the OS and programs. Most likely, your 4TB external drive was formatted GPT.
My System SpecsSystem Spec

16 Feb 2019   #4

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

I thought NTFS could only see 2 terabytes
NTFS is a filesystem. MBR and GPT are partitioning styles.

MBR partitioned disks can only address up to 2tib.

If you have a larger disk, use GPT.
My System SpecsSystem Spec
16 Feb 2019   #5


OK so yes NTFS is a file system FAT is a file system FAT32 is a file system

I am safe believing I can buy a 6 T hd for my win 7 as long as partitioin the drive with a GTP
I am a bit confused because when I format A disk I have a Choice between ntsf and fat

At this point the only way I know of to format a disk GTP is to use acronis disk director 11 If I try to install windows on the drive and I dont have UEFI instead of A bios then it will split the 4T drive up because it has the missing info to run as a UEIF BUT if I has(have) a computer that does have UEFI interface then the windows setup disk is willing to format the drive GTP
But if I set the drive up to be a data drive a computer would format the drive GTP and in that case I could format it without the modern UEFI RIGHT ?

Can diskmgmt.msc be used to to partition the Disk as GTP ?
Or would I use DISKPART ?

I undestand UEFI is not needed to read a GTP but if an os is on the GTP it needs UEFI BUT the question I still have is CAN I format GTP with BIOS.

Thank you for this help

I setup many ssd disks but they are all small. A 4T ssd disk came along and it opened up a big can of worms for me and made me realize I am missing some knowledge. Thank you for your help in putting things right.
My System SpecsSystem Spec
16 Feb 2019   #6

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

Initialize the disk to a partition style.

Format a volume to a filesystem.

If it has already been initialized to a partitioning style, then it can be changed with 3rd party software - e.g. Aomei partition Assistant, Partition Guru, etc. some of them can do it without damaging any existing data on the diak.

Windows disk management/diskpart command line can only change the partition style destructively.

You can use MBR and/or GPT disks with BIOS firmware.

But, if you want to boot windows from a GPT disk - you need to use EFI firmware.

Disks are divided into partitions. Some people don't realize they have partitions - because they have only one. A disk has to be initialized to a partitioning system. Then partitions can be created and formatted to a filesystem. You can have partitions with different filesystems on the same disk.

The MBR partitioning style only allows for 4 partitions. Though one can be an "extended partition " with several volumes inside. The MBR partition style is only suitable for disk up to 2TB.

GPT allows far more partitions, and is theoretically usable for disks up to 2^64 logical blocks in length. However, Windows file systems currently are limited to 256 terabytes each.

BIOS and EFI (or uefi) are firmware

MBR and GPT are partitioning styles

NTFS and FAT32 are filesystems.

If you are using a GPT partitioned disk for booting Windows, the usual setup is a small EFI System partition formatted as FAT32. Other partitions on the disk are usually formatted NTFS.
My System SpecsSystem Spec
16 Feb 2019   #7


Thank you for these Clarifications. !
My System SpecsSystem Spec
17 Feb 2019   #8
wither 2

Windows 7 Pro SP1 64 bit

A 4 TB drive would read 3.73 TiB in Windows.
My System SpecsSystem Spec

 4 TERIBYTE USB DRIVE NTFS shows up as 3.69T

Thread Tools

Similar help and support threads
Thread Forum
1tb hard drive shows unallocated & shows error cyclic redundancy error
Hello, My toshiba extrnl 1tb hard disk changed to raw aftr abrupt power cut whn drive was cnnectd to pc. After sum research tried method of test disk on win 7. I followd the procedure and writed partion. But aftr rebootng nw disk changed to unallocated. I tried initializing disk to mbr but it...
Hardware & Devices
NTFS formated 1TB disk shows as RAW when connected via usb
I have purchased a new 1 TB WD HDD (internal) and have connected it internally in my PC to my motherboard using the spare power and SATA cables within my PC. (This is the second internal disk ) I booted on the PC (windows 7 (64 bit)) - the new HDD was detected and i continued to format the disk...
Hardware & Devices
2 TB drive went from NTFS to RAW
I had a pretty odd situation happen to me this morning. I had a 2 TB My Book Elite external HDD, which connected via USB. I noticed the USB cable that connected to the external was loose, so I powered off the computer and removed the cable from the drive, only to find the USB connector inside the...
Hardware & Devices
hard drive w/ usb adapter- drive shows in disk manager, not computer
I am trying to access files on a hard drive from a different computer which will no longer load the OS. I have connected the hard drive using a usb adapter. When I plug it in, I get a notice that the device is ready to use, but it does not show up in Computer. It is visible in the disk manager....
Hardware & Devices
NTFS Formatted HDD shows up as unallocated space after I/P shutdown
Ok...So the title speaks for itself, and I'm stuck. My PC recently locked up b/c of my video card. Something w/in the audio driver for the HDMI/DVI drivers do not completely agree with adobe flash 10.0 and on, but thats a different problem. What I am trying to do is recover my data from my brand...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:36.
Twitter Facebook