Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Installed new RAM, shows 8GB installed but still says (2.75GB)usable.

21 Feb 2019   #11
johnhoh

Win7 pro x64
 
 

some things to try:

to check current bios level do

start > run > cmd > enter > wmic bios get smbiosbiosversion > enter

the final bios level for your board is 3.3. Get it here

Support For Q35MDO | Motherboard - The world leader in motherboard design | MSI Global

note that memory that is not actually validated by MSI for the board can produce hardware reserved issues. Here are the dimms that msi tested for your board

Support For Q35MDO | Motherboard - The world leader in motherboard design | MSI Global

here is a video by msi telling you how to update your bios

MSI-How to flash Motherboard BIOS - YouTube

you may just need to enable memory remapping in bios. Look under advanced>chipset


My System SpecsSystem Spec
.
22 Feb 2019   #12
dijon6444

Windows 7 Ultimate 64bit
 
 

Oh ok but by flashing the BIOS will it then update? Also is 8GB on a USB plenty for it? And last question, will my data be wiped if I flash it, and will this method work 100% and my RAM to 7GB instead of "2.75GB usable"?
Sorry for so many questions I just wanna be sure.
My System SpecsSystem Spec
22 Feb 2019   #13
samuria

win 8 32 bit
 
 

If you flash the bios once done you need to clear the CMOS by removing the battery or by jumper you will need to then reset the BIOS and you could find extra settings. It doesn't wipe anything from the hd its a very small update size wise
My System SpecsSystem Spec
.

22 Feb 2019   #14
dijon6444

Windows 7 Ultimate 64bit
 
 

Ahh ok, this might sound stupid but CMOS? I have no cluse what it is and the battery I have never taken out in my life, do you have to do it to make it work?
My System SpecsSystem Spec
22 Feb 2019   #15
johnhoh

Win7 pro x64
 
 

when you flash the bios the cmos resets. Cmos is just the physical location of your bios. I see no reason to remove the battery. Just follow the video from earlier
My System SpecsSystem Spec
22 Feb 2019   #16
johnhoh

Win7 pro x64
 
 

Quote   Quote: Originally Posted by dijon6444 View Post
Oh ok but by flashing the BIOS will it then update?
flashing the bios is updating the bios

Quote   Quote: Originally Posted by dijon6444 View Post
Also is 8GB on a USB plenty for it?
way more than enough
Quote   Quote: Originally Posted by dijon6444 View Post
And last question, will my data be wiped if I flash it, and will this method work 100% and my RAM to 7GB instead of "2.75GB usable"?
there is no way to know if flashing the bios will fix the problem. Based on the fact that you have gotten 2.75GB with two different sets of memory dimms, first thing I would check is

start > run > msconfig > boot > advanced > make sure maximum memory is UNchecked
My System SpecsSystem Spec
22 Feb 2019   #17
johnhoh

Win7 pro x64
 
 

what bios level are you on now? Post #11 tells how to know
My System SpecsSystem Spec
22 Feb 2019   #18
dijon6444

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by johnhoh View Post
what bios level are you on now? Post #11 tells how to know
Ok thanks for all the help, my current BIOS level (I just check using the Post11# for help), it is "6.00PG".
My System SpecsSystem Spec
22 Feb 2019   #19
johnhoh

Win7 pro x64
 
 

one more thing. You said your motherboard is an MS-7358. A search of the MSI website shows that this can be one of two different motherboards, so you need to be sure which one you have. The best way to know is to get a flashlight and physically inspect the board. Here's a pic of a version 2 of Q35MDO board. Its better to refer to your board as an MSI Q35MDO V1 or an MSI Q35MDO V2 than as an MS-7358, since MS-7358 is not as specific.


Digging into this a little further, you should really be looking at the Medion website for your bios. I can't figure out what model you have though since the MT7 does not appear in a search of the Medion link below. I recommend you look up your product number and see where it takes you...

Medion Site
MEDION UK - Driver


Attached Thumbnails
Installed new RAM, shows 8GB installed but still says (2.75GB)usable.-2.jpg  
My System SpecsSystem Spec
22 Feb 2019   #20
samuria

win 8 32 bit
 
 

The cmos battery in the photo above is just bove the botom green frame round black holder some bios upadatesmay work but with a lot you have to clear the cmos
My System SpecsSystem Spec
Reply

 Installed new RAM, shows 8GB installed but still says (2.75GB)usable.




Thread Tools




Similar help and support threads
Thread Forum
Only 2,75GB RAM Usable, regardless of installed amount.
Hey there! I am having some real trouble with my PC at work right now an i am at a total loss. I slaughtered some old systems and tried to make one that isn't as abysmally bad as they all were for themselves. So, what i ended up with is this: ...
Hardware & Devices
4GB installed RAM, 2.75GB usable =[
Okay, I had this problem with Vista and now again with 7. And before you ask, yes I have searched the forums but there have always been caveats which make me think that there might be something else. Now, onto the problem. I have a custom built machine with 4GB of RAM installed. The system is...
Hardware & Devices
4GB RAM Installed - 1.75GB Usable
Hey everyone. So, I finally decided, after weeks and weeks of searching for help and a solution to my problem, to join up a forum as ask. My problem is the following; I have 4GB of RAM installed in my computer (the stock RAM; I have changed no hardware since receiving the laptop), but Windows...
Performance & Maintenance
Windows 7 64bit shows 3.73GB usable memory with 8GB installed
I have two sticks of 4gb PNY RAM (8gb total) installed in an Asrock A75M motherboard, which supports 16GB of RAM. I've already flashed my BIOS, thinking that may be it, but it didn't work. Windows 7 as well as my BIOS show that 8GB of RAM is installed, but only 3.73 is usable. I have an...
Performance & Maintenance
Laptop 4Gb Memory Installed, 3.75GB usable
I decided to give my laptop (Acer 5535) an upgrade in RAM so I got a 2GB stick to bring the total amount of RAM to 4Gb. But now it seems that there only seems to be 3.75GB of the RAM usable. I know that the integrated graphics takes some of the RAM, but this laptop has the ATI HD 3200 graphics,...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:37.
Twitter Facebook