Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External WD 2 tb Hard drive bacame unallocated, help needed please

01 Mar 2019   #1
manoo

windows 7 Ultimate 32 bit
 
 
External WD 2 tb Hard drive bacame unallocated, help needed please

hello,
I have been using my WD 2tb for over 4 years now as second drive, 2 days ago due to a usb port of my laptop being little loose, when I move my laptop a little, I noticed the usb cable disconnected/connected from my external usb hard drive, ( heard ding/dang as the result of something connected/disconnected) after that the Drive did not show in my computer, looked at Disk management tool it shows, it needs to be initialized and the disk is unallocated.
I am running Win 7 ultimate, 32 bit on Toshiba M300, having intel core duo cpu p8600 2.4GHz, 2 GB ram
and WD 2tb Drive is as my second drive, ( P/N: WDBU6Y0020BBK-05)

here is pics from Disk management tool when I check the disk:

External WD 2 tb Hard drive bacame unallocated, help needed please-disk-1.png

External WD 2 tb Hard drive bacame unallocated, help needed please-disk-2.png

since the beginning of using this hard dive, I have not reformat it, and it is formatted as 32 bit, as much as I remember ,it has only one partition.
it is being used as storage of my files, different kind of files, MS doc, excel, pp, pdf, family pictures, videos, backups, and more., unfortunately I do not have any backup of them, it is all my life in it, I did have a plan to move most important files into anther external 500 GB empty hd I have, but I just keep delaying it, stupid of me.
I believe that 1.2 to 1.4 tb is been used.

before doing anything I kept reading forums, and see what other people did with the same problem,

I have not initialize nor repartition the drive, I have used some software to see if I can repair the damaged partition, but I have not written anything on the drive yet.

these are the software I have tried:

Free edition of MiniTool Partition Wizard-pw11-, testDisk, EaseUs Data Recovery Wizard, AOMEI Partition Assistant,GetDataback simple.

all of them taking so much time for search the drive, that is little odd about time consuming, when it shows how much sectors have searched out of the total number sectors (about 3,906,963,456 sectors), a little of calculation, it shows that it takes more than one year to finish the searching, so after running them for hours, or over night and seeing the process not reaching 1%, I canceled the action.

couple of hours ago I installed GetDataback simple and let it run,
immediately shows error, this is the first picture of it.

External WD 2 tb Hard drive bacame unallocated, help needed please-error-1-getdataback-.png

I click ignore for couple errors but errors kept coming, then I clicked ignore all,
some of the errors show on the screen as you see there are lots of errors with the given LBA address.

this picture of it one hour and 30 min later,

External WD 2 tb Hard drive bacame unallocated, help needed please-error-1-getdataback-2.png

so now desperate to see what else I can do, it seems that boot sectors and/or other sectors are damaged.

I know the partition recovery or file/folder recover could take hours, that is completely fine with couple of days, but what is time frame that I should expect for 2tb drive?
couple of days , months or years, it is little odd to me that it takes more than a year to go through all sectors of drive, that is why I canceled searching.

appreciate any help to get my data back,




My System SpecsSystem Spec
.
01 Mar 2019   #2
samuria

win 8 32 bit
 
 

Welcome to the forum. From what I can see the disk may be dead. You could try in another pc see if that reads it sometimes this happens. The other options are the USB port cable or interface is faulty. You could try in a PC which eliminates cable interface faults. A recovery firm may get your data back but it would cost you
My System SpecsSystem Spec
01 Mar 2019   #3
manoo

windows 7 Ultimate 32 bit
 
 

thank you for your response,
I have tried it on another computer ( another Toshiba laptop, faster than mine, higher RAM, and using another usb cable, ( the original cable that was included when I bought it), but still not much luck with it,
My System SpecsSystem Spec
.

05 Mar 2019   #4
manoo

windows 7 Ultimate 32 bit
 
 

OK, I gave my HD to a company to take a look at it and see how much they are going to charge me for retrieving my data from HD.
after 2 days the called me and said they tested the HD, and there are 3 damaged heads, they can turn off the three damaged heads and take image of HD with the good heads, and may not possible to take image of everything. so I was not sure how much data I could have, and the price was too much for me, so I took my HD back.
I went to another company to try, they connected HD to their computer and they said everything is up, they can see the folders and files, they asked me if I want to repair bad sectors it it better to take a back up first then give back HD to repair the bad sectors.

obviously when the first company connected my HD to their equipment, partition table was corrected,

anyhow, I came home and I connected the HD to the computer, the HD was recognized with the same Letter name, visually I see every folder and sub folders, and some files

some folders are empty, folders that suppose to have tons sub folders and files in it,
some other folders show sub folders and file in it, but I can not copy them, it gives me error
I was able to copy only few text files.

this is the error:
could not find this item, this is no longer located in K:

Is there a chance now to do something?
I don't want to do something stupid that I lose my chance now,
is it possible to take an image of those files that i see?
how about hose files that are visible?

appreciate your help.

this is two pictures of HD now:


External WD 2 tb Hard drive bacame unallocated, help needed please-hd-1.png
External WD 2 tb Hard drive bacame unallocated, help needed please-hd-2.png


My System SpecsSystem Spec
05 Mar 2019   #5
samuria

win 8 32 bit
 
 

You need a new big drive then copy everything over DO NOT make an image as it can copy bad sectors if you use built in robocopy its vert fast and just mirror the files to a new drive it may take many hours
My System SpecsSystem Spec
05 Mar 2019   #6
manoo

windows 7 Ultimate 32 bit
 
 

thanks for your response, great info, I did not know about robocopy, I am happy that I asked.
My System SpecsSystem Spec
06 Mar 2019   #7
Pete4

win7hp64
 
 

Years ago I was in similar situation and managed to manually repair disk myself with hex editor, but if Robocopy works, then you're good to go. But remember this: unless the sectors are damaged (and some probably are, when power was cutoff in middle of writting cycle), the data is lost forever, but it should be small amount. Everything else is there, but probably File Allocation Table is corrupted, but there should be back up FAT and that one should be fine and you should be able to recover most of the data, unless the disk is physically damaged. Basically don't give up, even if Robocopy doesn't work, there are other programs to try. I'm not sure why the first company said 3 heads are damaged: unless you dropped the disk on the floor, the heads should lift when the power was cutout, they shouldn't get damaged then and if they're failing before, you should have error messages, but I guess with disks anything is possible.
My System SpecsSystem Spec
Reply

 External WD 2 tb Hard drive bacame unallocated, help needed please




Thread Tools




Similar help and support threads
Thread Forum
one of the partition is unallocated in my 2TB EXTERNAL HARD DRIVE
hey, I were recovering my data from 2TB external HDD using remo recover. During which my system went off after that i were unable to see my HDD in my computer but it was there in Disk management where it was having four partition , don't know how because it was never parted. the structure was...
Hardware & Devices
How to handle the unallocated space on my external hard drive?
Hi, This is probably the silliest question ever, but I haven't done partitioning in a very long time and don't feel too confident, so here goes: I bought a 3 TB Seagate external hard drive a few years ago, created two partitions on it and left almost 1 TB unallocated. Can't remember why , and...
Hardware & Devices
Laptop's built in external hard drive suddenly disappears/unallocated.
Hello! Long story short, my external hard drive suddenly became unallocated. I've seen some youtube guides, posts on other forums, posts on sevenforums, but I can't figure it out -- the solutions for some of these forum posts don't work for me. And so I decided to make a new thread in the hope of...
Hardware & Devices
WD my passport External hard drive unallocated
disk 1 is not initialized, unallocated. I tried to initialize in disk management. But it showed disk is write protected then i opened command prompt but there disk 1 (WD external hard drive) not shown but when I wrote command select disk 1 then disk 1 is selected and Then wrote command...
Hardware & Devices
My external hard drive is unallocated
Hi guys, I was checking for errors on my WD HD the other day due to low speed and leave it alone but my mother unplug it inadvertently! Clearly it's unallocated now. I've read a lot of posts especially those sent by jumanji (Windows 7 Help Forums - View Profile: jumanji) and apply almost all...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:17.
Twitter Facebook