Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Controller Error under Other Devices

11 Mar 2019   #1

7 x64 | 7 x64
USB Controller Error under Other Devices

Greetings, trying to pin this one down. This is after a fresh rebuild, using existing W/7 install on ssd transferred to new build. New(er) components as follows;

MSI 990fxa motherboard & 16 gigs Balistix
AMD fx-9590 Vishera processor

Previous board was Gigabyte ddr2 system, usb2 only with AMD Phenom II processor.

MSI board has latest bios, all current drivers for it (w/7 x64) downloaded & installed except for raid jazz.
Under Management, Universal serial bus controllers - zero errors. However under Other Devices, Universal Serial Bus (USB) Controller error is listed. Details under General Tab:
Device Type: Other Devices
Manufacturer: Unknown
Location: PCI bus 5, device 0, function 0
The drivers for this device are not installed. (Code 28)
There is no driver selected for the device information set or element.
To find a driver for this device, click Update Driver.

My first thoughts were, some leftover nonsense from the prior build. Listed under USB controllers all drivers appear installed and are functioning correctly. Please see attached image. All USB ports tested. Hesitant to delete / remove this but the system seems fluid otherwise. Any advice would be appreciated.

Attached Thumbnails
USB Controller Error under Other Devices-3_11_build.jpg  
My System SpecsSystem Spec
11 Mar 2019   #2

Win7 pro x64

my input

use Device Cleanup Tool to remove all old drivers of currently non-present devices.
Tools for Windows

do start > run > msinfo32 > components > problem devices to find the PNP Device ID(s) that is/are not working right. Google those Device IDs to find exactly what is not working

If still no joy, try installing the MSI live update utility for your board
Support For 990FXA GAMING | Motherboard - The world leader in motherboard design | MSI USA
My System SpecsSystem Spec
17 Mar 2019   #3

7 x64 | 7 x64

The live update utility did indeed indicate the via usb drivers were not installed along side the asmedia 3.0/3.1 drivers. Once installed problem solved. I had interpreted the download listing as a choice.
My System SpecsSystem Spec


 USB Controller Error under Other Devices

Thread Tools

Similar help and support threads
Thread Forum
Device Manager - Other Devices - Universal Serial Bus (USB) Controller
There is a yellow triangle next to this device. When I ask Windows to install or update the driver, it reponds with "Windows could not find driver software for your device. ..." When I right click on the device and then click Properties / Hardware IDs this is what I see ...
PCI device, SM Bus Controller and two unknown devices not downloaded
Hello, whenever I go onto device manager and then into "other devices" there are 4 devices that havent had a driver downloaded. The PCI device, the SM bus Controller and two "unknown" devices. What should I do? Please tell me if you need more information about my computer, ill be happy to provide.
Device Manager - Other Devices USB Controller driver not installed
I have a 64 GB USB flash drive that is not recognized on the USB 3.0 ports but is on the USB 2.0. I have 2 USB 3.0 external drives that work fine on those ports. When it is plugged in the light flashes but doesn't install the drivers. Wondering if the thread title might be the problem? ...
Hardware & Devices
System Devices..High Definition Audio Controller. Code 10
Recently build new rig. Specs: i7 3930k Asus Rampage IV Extreme G Skill Ripjaws Z 32gb Samsung SSD PRO 256gb MSI 7970 Crossfire Corsair AX1200i Put build together all went well. After a couple of days downloading drivers began to test hardware. Started with GPU's. Installed amd 13.2...
High Definition Audio Controller devices - How many?
I updated to the latest Realtek driver. Everythimg runs fine as long as I don't plug the Quickcam Pro 9000 in (different story). But I was checking things out and noticed that I have 2 "High Definition Audio Controller" devices installed in Device Manager>System Devices. This is a Dell...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:38.
Twitter Facebook