Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB 3.0 ports working at USB 2.0 speeds

4 Weeks Ago   #1
darkhiruma21

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
USB 3.0 ports working at USB 2.0 speeds

I have 4 USB 3.0 ports and all of them work at 2.0 speeds. Whenever I plug in my device (Huawei Mate 10 Pro) I get the "This device can perform faster" notification.

My motherboard is the P8P67 DELUXE rev 1.03 (very old I know) and I'm using the latest BIOS (Version 3602) and USB 3.0 drivers (Version 2.0.32.0) from the ASUS support website. I also tried another driver (Version V2.0.4.0) and ended with the same speeds.


USB 3.0 ports working at USB 2.0 speeds-usb30controllers.jpg


I used the USB Device Tree Viewer and it shows the Device Bus Speed is high speed instead of super speed.

USB 3.0 ports working at USB 2.0 speeds-usbdevicetreeviewer.jpg

USB 3.0 ports working at USB 2.0 speeds-usbconnectioninfo.jpg


I've tried all 4 ports with different cables. I've also tried disabling the USB 3.0 power management functions and still no result.

USB 3.0 ports working at USB 2.0 speeds-usbhostcontroller.jpg


I have no idea what the problem is or what to do next. Any help would be appreciated. Thanks.




My System SpecsSystem Spec
.
4 Weeks Ago   #2
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, & Kali
 
 

Hi darkhiruma21,
Welcome to SevenForums!
If you would please How to auto post your system specs

Are all connectors blue USB 3.0?

USB 3.0 ports working at USB 2.0 speeds-usb-color.jpg


My System SpecsSystem Spec
4 Weeks Ago   #3
darkhiruma21

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I've updated my system specs.

One connector has a white colored pinout (which I realised would not work) and the other connector has a purple colored pinout. The purple one came with my device (Mate 10 Pro).
My System SpecsSystem Spec
.

4 Weeks Ago   #4
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, & Kali
 
 

Blue is USB 3.0
Purple is 1m USB Type-C 5A Super Charging Cable for Huawei Mate 9/Mate 10/Mate 10 Pro
Blue-Purple compatible for USB 3.0 speeds
USB 1.0, 2.0 not
My System SpecsSystem Spec
4 Weeks Ago   #5
darkhiruma21

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

So only blue pinout connectors are compatible?

USB 3.0 ports working at USB 2.0 speeds-bluepurpleconnector.jpg


My System SpecsSystem Spec
4 Weeks Ago   #6
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 



My System SpecsSystem Spec
4 Weeks Ago   #7
darkhiruma21

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I don't have the right connector to test but I think my problem has been solved. Thanks.
My System SpecsSystem Spec
4 Weeks Ago   #8
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, & Kali
 
 

Blue on Computer USB connector too!
My System SpecsSystem Spec
Reply

 USB 3.0 ports working at USB 2.0 speeds




Thread Tools




Similar help and support threads
Thread Forum
USB 3.0 Ports Not Working
I just bought a new Kingston Ultimate 32 GB USB 3.0 flash drive. It works fine in my 2.0 ports but will only light up in the 3.0 ports and Windows 7 64 bit does not see it. I have enabled the USB 3.0 ports in my BIOS and I have got the latest NEC USB 3.0 driver for my MSI P55-GD85 motherboard. ...
Hardware & Devices
Slow download speeds, Fast upload speeds. Other devices are fine.
My computer has extremely slow download speeds, upload speeds are fine. Ping is always at ~10-20ms. (to Google) The problem has nothing to do with, my ISP, my router, my type of connection. I know this for a fact. http://www.speedtest.net/result/3745496488.png I've tried multiple network...
Network & Sharing
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
Two USB ports not working
Hello! I have a bit of a problem. I have an Acer Aspire 5733Z-4633 and upon receiving it, I reinstalled Windows 7 to get rid of all the bloatware and useless things that were taking up space on the hard drive. Upon doing this, two out of three of my USB ports stopped working for some reason. When I...
Hardware & Devices
Not all USB ports are working
Hello guys, I have just got my motherboard replaced by a PC World Techguy and I got it back last week. Because the BIOS on the new motherboard has not be altered to the same has the old one. The front 2 usb ports are not being recongized, but the one that my usb hub is plugged into is working...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:22.
Twitter Facebook