Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Touchpad and USB does not work after fresh install

15 Jun 2019   #11
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Quote   Quote: Originally Posted by bbaker6212 View Post
The must be on the installation media since they are working during install - USB drive is read and the touchpad works.
Am I missing something?

Is there a bios setting?
Quote:
I went into the BIOS > Main, Touchpad and changed it from Advanced to Basic and then saved and closed. When booting into Windows I opened Device Manager and the driver was installed automatically, so now I have the touchscreen and the touchpad working.
Have no nvm driver for windows 7


My System SpecsSystem Spec
.
15 Jun 2019   #12
bbaker6212

Windows 7 Home Premium x64
 
 

thanks for the reply.

Quote   Quote: Originally Posted by SIW2 View Post
Is there a bios setting?
No. No bios settings for touchpad. Anyway, I am using the same bios settings after install as during install, so this would not explain why it's working during install. There's something on the install disk that's making it work - driver or setting.
I'm booting into the USB drive in legacy (mbr) during install, and booting up the HDD after install in legacy mode as well.


Quote   Quote: Originally Posted by SIW2 View Post
I'm installed onto the HDD at the moment. I did not want to complicate things by trying the NVMe drive yet.
My System SpecsSystem Spec
15 Jun 2019   #13
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

PE ( boot.wim) uses the standard vga.sys driver for graphics. How that might affect the touchpad on your machine, I don't know.

You didn't say what install media you used. If you think boot.wim has some drivers that are not present in install.wim, there is an easy way to find out.

You will find boot.wim in the sources folder of the installtion media.

1.Use dism++ to mount boot.wim image 2.
2.Make sure the mounted image is highlighted in Blue.
3.Click Open session.
4.Click Drivers in the left pane.
5.Any third party drivers will be displayed in the main window, and you can export them to a folder.
6.Then File>Unmount image

http://cdn.chuyu.me/Dism++10.1.1000....f4e00cac0b.zip


Screenshot instructions here:
Reinstall Win7 what updates to avoid for telemetry & winX preparation?

That will give you the general idea - after mounting the wim image, click Open Session as in the pics, then Click Drivers in the left pane.
My System SpecsSystem Spec
.

15 Jun 2019   #14
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

If there are no third party drivers, it could be that your bios behaves differently when running an Os ( pe ) in ram. Possibly there is some kind of PS2 emulation.

Oem's will often hide bios settings from the users. If that is the case, then as far as I know, a bios mod is one way to reveal the hidden settings. Outside the scope of this forum. You could ask at win-raid, somebody there might be willing to do it for you. They seem to enjoy that kind of thing.
My System SpecsSystem Spec
16 Jun 2019   #15
Megahertz07

Windows 7 HP 64
 
 

SIW2, i3-8130U is a Kaby Lake CPU so the Chipset should also be. Why not try a Kaby Lake USB driver?
Why not also try all other drivers for Kaby Lake?
My System SpecsSystem Spec
16 Jun 2019   #16
bbaker6212

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by Megahertz07 View Post
SIW2, i3-8130U is a Kaby Lake CPU so the Chipset should also be. Why not try a Kaby Lake USB driver?
Why not also try all other drivers for Kaby Lake?
Hi @Megahertz07 If you know the name of the drivers that would help me. Via directions given by @SIW2's above, I have a list of the drivers from Dism++ that is in the boot.wim on my USB install drive (where the touchpad and USB is working). Then I can hopefully install them.
My System SpecsSystem Spec
16 Jun 2019   #17
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

What third party drivers are in boot.wim?

Have you exported them to a folder using dism++ ?
My System SpecsSystem Spec
.
16 Jun 2019   #18
bbaker6212

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by SIW2 View Post
What third party drivers are in boot.wim?

Have you exported them to a folder using dism++ ?
The box shows a ton of stuff. I think it's all the drivers not just "third party" drivers.
My System SpecsSystem Spec
16 Jun 2019   #19
Megahertz07

Windows 7 HP 64
 
 

bbaker6212, you did not tell us where did your Win 7 installation disk came from.

I ask because you can integrate (slipstream) drivers into the Installation disk.
And you can add the drivers only to the boot.wim, ie, winPE that runs setup or also to install.wim that has the four versions of win 7 (H,HP, Pro and Ultimate).
If USB drivers where integrated only to the winPE will explain why you had mouse and touch pad during installation.
And the touch pad is probably connected to a USB, so once you install the USB drivers you will have it working.
My System SpecsSystem Spec
16 Jun 2019   #20
bbaker6212

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by bbaker6212 View Post
The box shows a ton of stuff. I think it's all the drivers not just "third party" drivers.
here is the full list - I exported everything, all the drivers listed.
List of drivers on Pastebin

Sorry, the Win10 box has Portuguese language installed.
Here's an English translation of that pastebin if it helps identify drivers.
My System SpecsSystem Spec
Reply

 Touchpad and USB does not work after fresh install




Thread Tools




Similar help and support threads
Thread Forum
Fresh install: Touchpad pointer lost after sleep. randomly.
Guys I've been using this little Thinkpad x120e for years: I can't find a replacement that does as much as well :geek:. I just did a fresh install of win7 x64 home premium on a new samsung 840 pro ssd. it all works swell. except today: doing absolutely nothing unusual, running on battery, I...
Hardware & Devices
Touchpad often doesn't work
Hello everyone. Recently, I did a clean install of Windows 7 Home Premium on my MSI GE600. At first, the touchpad behaved the way it should. But now, it is not even detected. I rebooted the laptop and it worked again. Most of the time it doesn´t work though. I have installed the Elantech...
Hardware & Devices
Why do not work my laptop touchpad?
Hello Every one, have a nice day! please help to provide a solution by the given the answer of the question- Why do not work my laptop touch pad? I have attached a file for your info. thanks
Hardware & Devices
Hp Envy 14 After a fresh re-install Internet doesnt work.
Hey guy's this has been bugging the heck out of me! I re-installed my copy of windows 7 Home Premium, went to HP's website and installed the drivers i thought were needed. My network controller still displays the little yellow triangle. Wireless doesnt work at all, and wired just says "internet...
Drivers
Touchpad doesn't work!?
Hello. I've got a VAIO VGN FE11M. My touchpad doesn't work since yesterday. It's really weird because I checked it in my device manager and it says that everything is okay. Now I've reinstalled my whole computer because I thought that it doesn't work because of the drivers. It still doesn't...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:07.
Twitter Facebook