Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't eject drive, solutions aren't working or are not applicable :/

4 Weeks Ago   #1
hasefo

Windows 7 Professional 64-bit
 
 
Can't eject drive, solutions aren't working or are not applicable :/

Right-clicked the drive (just a normal USB drive that normally behaves normally), no Eject option, clicked on the USB drive icon in the notification bar at the bottom left, selected to eject the drive safely, a pop-up says Generic volume can't be ejected because a program is using it :/

Tried this solution: Can Windows tell me what is using my USB drive? - Super User

Typing in the drive letter ("w" without quotes) shows a bazillion results, obviously that's not the solution, typed in w: instead, found nothing, typed W:\ found nothing... I can't leave a comment on the answer stating it doesn't work or isn't clear enough because I don't "have 50 reputation" *angry at internet face*

What's the actual solution here?


My System SpecsSystem Spec
.
4 Weeks Ago   #2
RolandJS

Windows 7 Professional 64-bit
 
 

Not an easy solution, years ago I tried a few 3rd party utilities that appeared promising, released one or two items easier, however, not all USB devices were released, even with these 3rd party utilities. Let's see what others have to say.
My System SpecsSystem Spec
4 Weeks Ago   #3
billmcct

Windows 7 Home Premium
 
 

Check the drive properties and see if the drive is set to be indexed. If so uncheck it. Click on the "hardware tab". Select your usb drive and hit the "Properties button" below. When the new dialog pops up select the "Policies tab" and make sure the drive is set for "Quick removal (default)". Your antivirus/antimalware or indexing or even a defrag program could be monitoring the drive. If the drive has an LED indicating read/write activities and it is not flashing then you can simply just unplug the drive with no fear of losing data because Windows Does NOT use Delayed write on external drives if the "Quick removal" is set. I personally have the "Eject hardware" icon hidden and never use it.
My System SpecsSystem Spec
.

3 Weeks Ago   #4
Bree

Windows 7 Home Premium x64
 
 

In addition, I've seen Task Manager prevent the removal of usb drives (though usually only HDDs). So close Task Manager if you have it open.


Signing out then back in again can also help, as it closes any processes you may have had running.
My System SpecsSystem Spec
Reply

 Can't eject drive, solutions aren't working or are not applicable :/




Thread Tools




Similar help and support threads
Thread Forum
the colors aren't working
example: please help!:( R513HCOS3s4
General Discussion
Themes aren't working?
So someone in my family just got a new computer, and all of the installed themes change the window borders/task bar, but mine doesn't. If I click on any theme other than and Aero theme then it reverts to the classic window border/task bar. Any help is appreciated. Thanks. EDIT: I don't think I...
Themes and Styles
some themes aren't working
I've downloaded several themes onto my laptop, running windows 7 x64, but some work and some don't. I've gotten killiki and elegant glass to work, as well as a couple others, but i can't get counter elements and a few others to work. Anyone know what the problem could be?
Themes and Styles
F2 F3 F4..... Keys aren't working
I recently got given a Microsoft Wireless MultiMedia Keyboard 1.1 Model: 1014 I plugged it in and went to windows update, it installed the keyboard and all working. Now i have a program that i want to configure the F1 keys to make them do something in the program, I've done this before on my...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:56.
Twitter Facebook