Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "Devices and Printers" displays correctly in one Profile but not in an

3 Weeks Ago   #11
DHLipman

Win7 Professional/32
 
 

Specifically in the corrupted Display...
The CA-200 ( TEAC multi-memory card reader ) and USB 2.0 Storage Device show as just "device".
The same happens when I turn on an eSATA Western Digital MyBook external hard disk it too shows as just "device".

The two Epson AIO don't show in the Printers and Faxes list. They have the same "Device" moniker with their associated Epson AIO Model Number. ( Epson Artisan 835 and Epson Small-in-One XP-850, both connected over IP )


My System SpecsSystem Spec
.
3 Weeks Ago   #12
RolandJS

Windows 7 Professional 64-bit
 
 

Each Windows computer can have a few or several admin-level accounts. There is one built-in admin acct, and there is a Trusted Installer admin acct. Now, what is causing the duplicate icons, I do not know, so I will be watching and learning...
My System SpecsSystem Spec
3 Weeks Ago   #13
wither 2

Windows 7 Pro SP1 64 bit
 
 

Quote   Quote: Originally Posted by RolandJS View Post
Each Windows computer can have few or several admin-level accounts. There is one built-in admin acct, and there is a Trusted Installer admin acct. Now, what is causing the duplicate icons, I do not know, so I will be watching and learning...
I hate to say it but- Me Too!

The frustrating thing is that everything that is listed is accessible from either account. As a result, I don't see a need to check for Windows corrupt files or other checks. My understanding has always been that providing administrative rights to a standard user doesn't provide the same permissions as an administrator account.

I'm wondering if refreshing the thumbnail cache while using the primary account would help. Go to Accessories, System Tools and run Disk Cleanup on the C: drive. When it indicates how much space it can recover, check the box for Thumbnails (I also check the box for temporary files and recycle bin). Let it run. When done, reboot.
My System SpecsSystem Spec
.

3 Weeks Ago   #14
DHLipman

Win7 Professional/32
 
 

Quote   Quote: Originally Posted by wither 2 View Post
I hate to say it but- Me Too!

I'm wondering if refreshing the thumbnail cache while using the primary account would help. Go to Accessories, System Tools and run Disk Cleanup on the C: drive. When it indicates how much space it can recover, check the box for Thumbnails (I also check the box for temporary files and recycle bin). Let it run. When done, reboot.

Done that including executing...

"%WINDIR%\system32\ie4uinit.exe" -ClearIconCache
My System SpecsSystem Spec
3 Weeks Ago   #15
wither 2

Windows 7 Pro SP1 64 bit
 
 

I've never used that and don't know if it will regenerate the icons on reboot. If you want to use that, proceed at your own risk. Maybe set a system restore point before doing it.
My System SpecsSystem Spec
3 Weeks Ago   #16
RolandJS

Windows 7 Professional 64-bit
 
 

I thought either PaulB or Snick has an icon regenerator in a toolbox somewhere.
My System SpecsSystem Spec
3 Weeks Ago   #17
wither 2

Windows 7 Pro SP1 64 bit
 
 

I'm glad DHLipman mentioned the icons. After I responded, I shut down but got thinking about it and realized that I should have been pursuing icons, not thumbnails. Big Duh!

The icons are in this file- C:\Windows\System32\imageres.dll which can be accessed to change icons for the desktop, folders and files. However,

The thing that bothers me is that all the icons he needs are available but Windows is choosing to use different ones, depending on the user. However, I think that a particular device uses a .icm file that is provided in it's software so I'm not sure why they would be different user to user. Now I'm second guessing myself in regards to regenerating either thumbnails or icons.
My System SpecsSystem Spec
.
3 Weeks Ago   #18
DHLipman

Win7 Professional/32
 
 

I think it goes further than merely choosing a different Icon.


Take the two Epson AIO. They should be classed as Printers and Faxes and listed with the Brother printers as well as the Adobe, PDFCreator and other Print-2-File services. Yet they are no longer where they were and moved into a generic device type category.


Since we are on Page 2, to make it easier to reference the appearance,
Here is the wrongly displayed ScreenCapture...



Here is the correctly displayed ScreenCapture...





The second view is how it used to appear in the Day2-Day Profile but for unknown reason, now shows as the first graphic.
My System SpecsSystem Spec
3 Weeks Ago   #19
wither 2

Windows 7 Pro SP1 64 bit
 
 

I think we've been on the same page throughout this and we tried to address the Epsom devices earlier. You said the Epsom are connected by IP. Do you mean by Wi-Fi. If not, please explain the connection in more detail.
My System SpecsSystem Spec
3 Weeks Ago   #20
DHLipman

Win7 Professional/32
 
 

One is Wired, the other is on WiFi.
However their connectivity is a moot point since they both; scan, fax and print over IP with no sequelae.
My System SpecsSystem Spec
Reply

 "Devices and Printers" displays correctly in one Profile but not in an




Thread Tools




Similar help and support threads
Thread Forum
"Devices & Printers" Completely Hangs - Nothing Appears
Good morning. I've read an older thread that a particular installed printer does not appear in Devices & Printers. And I tried all the recommendations there. However, as the thread title states. we suddenly lost the ability to have Devices & Printers run to completion. In our case, the green line...
Hardware & Devices
A ghost printer in "Devices and Printers" that I can not remove
my brother HL-2030 printer is working fine (i have only one). nevertheless a second icon of the same printer is showing up in "Devices and Printers", marked as an issue. i'm not able to remove, uninstall or disable it. please help me to get rid of this item
Drivers
change start menu icons "devices and printers" and "recorded tv"
Hello Ive managed to change all the icons on my system to custom ones apart from devices and printers and recorded tv on the right of the start menu.(the ones that appear over your user picture when you hover over them) Ive searched everywhere for their location in the registry but cant find them...
Customization
Please help, "Devices & Printers" not loading
Hello folks, new to the forum and fairly new to Windows7 so please be patient with me http://cdn.sevenforums.com/images/smilies/biggrin.gif I have this very problem on my Dell XPS8100 with Windows 7 Home Premium, but ONLY on one of the user accounts. The admin, guest and another user...
Hardware & Devices
Printer does not show in "Devices & Printers"
Recently I tried to install an OKI C5250 Laser Printer on my Windows 7 x64 system. This printer is connected by USB. As instructed by OKI I used the Vista x64 drivers. These however would not install. However I notice that when I select Print in Word or another app, one of the listed printers...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:45.
Twitter Facebook