Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "Devices and Printers" displays correctly in one Profile but not in an

3 Weeks Ago   #1
DHLipman

Win7 Professional/32
 
 
"Devices and Printers" displays correctly in one Profile but not in an

In my Day-2-Day Profile the "Devices and Printers" display is corrupted and appears as...





In an alternate Profile, the "Devices and Printers" is displayed correctly as...





Specifically in the corrupted Display. the CA-200 ( TEAC multi-memory card reader ) and USB 2.0 Storage Device show as just "device". The same happens as when I turn on an eSATA Western Digital MyBook external hard disk.

As well as the two Epson AIO don't show in the Printers and Faxes list. They have the same "Device" label with their associated Epson AIO Model.



I can't figure out what in my Profile is causing these devices to be improperly displayed but not when I login as another user.






My System SpecsSystem Spec
.
3 Weeks Ago   #2
wither 2

Windows 7 Pro SP1 64 bit
 
 

What type of user (administrator, guest, etc.) account is your "day to day" account?
My System SpecsSystem Spec
3 Weeks Ago   #3
DHLipman

Win7 Professional/32
 
 

Danke


Both examples are demonstrated via an Administrator account.
My System SpecsSystem Spec
.

3 Weeks Ago   #4
wither 2

Windows 7 Pro SP1 64 bit
 
 

I'm not at a point tonight for doing additional investigation but I didn't know you could have more than one administrator account. I guess you can under different names. I asked because, if you have a guest account, you would have to identify which devices are associated with it. I'll have more time tomorrow.
My System SpecsSystem Spec
3 Weeks Ago   #5
DHLipman

Win7 Professional/32
 
 

Primary Account: Day-2-Day use and operation.
Secondary Account: System Maintenance and Backup System acct as well as Account for Data and Print Shares
My System SpecsSystem Spec
3 Weeks Ago   #6
wither 2

Windows 7 Pro SP1 64 bit
 
 

If you right click on any of the devices not available in your primary account, does it provide an option to connect or disable it?

In the account type for each account, is each shown as an administrator account? Not sure what you meant by "demonstrated."
My System SpecsSystem Spec
3 Weeks Ago   #7
DHLipman

Win7 Professional/32
 
 

When I captured the ScreenShot I "demonstrated" the Display of "Devices and Printers" in the two Windows Profiles and "demonstrated" two different displays where the two accounts should display relatively the same.

Both of the accounts are Administrators. That is if you go into the Control Panel applet "User Accounts" both accounts are made to have Administrative rights over the system and are indicated to be "Administrator".

All the same hardware is available and working correctly in both Profiles. What is different is how some Devices are displayed.



Right-Click ScreenShot


Attached Images
"Devices and Printers" displays correctly in one Profile but not in an-image1.jpg 
My System SpecsSystem Spec
.
3 Weeks Ago   #8
wither 2

Windows 7 Pro SP1 64 bit
 
 

Thanks for the clarification. I didn't think that all devices were available and working in both profiles.

I don't why it's doing this but, I would right click on the "Devices" to determine what each one is and remove one that is either incorrect or is a duplicate. I would also remove the Epsom Artisan unless it's really installed. In that case, there's another issue since it doesn't show up in the secondary account.
My System SpecsSystem Spec
3 Weeks Ago   #9
DHLipman

Win7 Professional/32
 
 

I have already removed the External USB Hard disk from the Device Manager and it made no difference when it was allowed ti Plug 'n Play back into the system when subsequently connected to another USB Port.


There are no duplicates.


We have perfectly working hardware in all respects. It is only the Display in "Devices and Printers" in one Profile that it askew.


The question is what in the User Profile is causing the Display ( of properly installed and working hardware ) in that profile to be incorrect ?
My System SpecsSystem Spec
3 Weeks Ago   #10
wither 2

Windows 7 Pro SP1 64 bit
 
 

What I was getting at is that, for some reason, the primary sees 12 devices and the secondary only sees 10. I thought that maybe one of the two devices labeled as "Device" might be duplicates and removing one would help. Also, it's seeing the Artisan for some reason and I thought removing that along with one of the others would reconcile the display problem. Is the Artisan really installed?

What are the "Devices" shown in the primary account?

Note that I'm just grasping at straws at this point.
My System SpecsSystem Spec
Reply

 "Devices and Printers" displays correctly in one Profile but not in an




Thread Tools




Similar help and support threads
Thread Forum
"Devices & Printers" Completely Hangs - Nothing Appears
Good morning. I've read an older thread that a particular installed printer does not appear in Devices & Printers. And I tried all the recommendations there. However, as the thread title states. we suddenly lost the ability to have Devices & Printers run to completion. In our case, the green line...
Hardware & Devices
A ghost printer in "Devices and Printers" that I can not remove
my brother HL-2030 printer is working fine (i have only one). nevertheless a second icon of the same printer is showing up in "Devices and Printers", marked as an issue. i'm not able to remove, uninstall or disable it. please help me to get rid of this item
Drivers
change start menu icons "devices and printers" and "recorded tv"
Hello Ive managed to change all the icons on my system to custom ones apart from devices and printers and recorded tv on the right of the start menu.(the ones that appear over your user picture when you hover over them) Ive searched everywhere for their location in the registry but cant find them...
Customization
Please help, "Devices & Printers" not loading
Hello folks, new to the forum and fairly new to Windows7 so please be patient with me http://cdn.sevenforums.com/images/smilies/biggrin.gif I have this very problem on my Dell XPS8100 with Windows 7 Home Premium, but ONLY on one of the user accounts. The admin, guest and another user...
Hardware & Devices
Printer does not show in "Devices & Printers"
Recently I tried to install an OKI C5250 Laser Printer on my Windows 7 x64 system. This printer is connected by USB. As instructed by OKI I used the Vista x64 drivers. These however would not install. However I notice that when I select Print in Word or another app, one of the listed printers...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:55.
Twitter Facebook