Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Speed Issues?

16 Dec 2019   #1
TDKMate

Win 7 Pro 64 SP1
 
 
USB Speed Issues?

I just did 490 GB worth of file transfers (move) from one USB 3.0 external drive to another USB 3.0 external drive. Ill call the source drive A, the other B.

Im using TeraCopy for the first time (and Im impressed so far for speed and ease of use). Total time was 40-45 minutes (I didnt look at the clock right away) and seemed to average of 150-155 MB/s (the progress bar would dip into the 140s and peak in the 170s).

I was impressed.

Now that drive A has the needed room to put the files I want on it, I disconnected drive B and began to Copy files from an internal HDD (WD Black) to drive A.

Gasp

Its been running for 1-1/2 hours now and has only 350 GB (out of almost 1 TB) of files copied over!? The progress bar was showing only high 60s MB/s for the long time but bounces into the 70s from time to time. And hours to go still

It was taking so long that early on I stopped the process and moved drive A from the back plate USB type A socket to the front panel USB 3.0: no difference in speed.

Kudos to TeraCopy for remembering the destination folder even after being closed down and after the drive was in another port.

So any ideas of whats going on? The only thing I can think of is drive A has good read speeds but terrible write speeds.
.


My System SpecsSystem Spec
.
16 Dec 2019   #2
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, & Kali
 
 

Write-Caching - Enable or Disable - Windows 7 Help Forums
Big difference backup and copying external HDD Seagate Backup +

USB Speed Issues?-capture.jpg


My System SpecsSystem Spec
21 Dec 2019   #3
TDKMate

Win 7 Pro 64 SP1
 
 

Thank for the info and link. I havent had much time to play with it. I did plug in the original source drive A and it is set to Quick Removal. When I plugged in the original destination drive B I expected it to be set to Performance since transfer speeds to it were great; it wasnt, it was also set to Quick Removal.

The only thing Ive had time to test out is simulate the internal HDD file copy to drive B and see if it went any faster than copy to A, and it did. I copied 126 GB of files from HDD to B and it took about 23 minutes. Not quite as fast as A to B but a lot faster.

Makes me wonder if drive A is a 5400 RPM drive and B is a 7200 RPM unit.

Ill have to wait for time to play with it more
.
My System SpecsSystem Spec
.

Reply

 USB Speed Issues?




Thread Tools




Similar help and support threads
Thread Forum
Need For Speed Performance issues
Hello I got a new computer and it a gaming card in it I know it is PCI not PCIE but It is more than the recommended card for Need for speed shift 2 unleashed and need for speed undercover which I have problems running, but need for speed most wanted (2012) works great, any help would be appreciated.
Gaming
Strange speed issues with all browsers.
For the last few days every time that I try to load a webpage/site it has become painfully slow to actually display the webpage and sometimes it is enough to cause a timeout. I am currently on a 20Mbit line, But numerous test with speedtest.net are only showing me at 1.9 Mb/sec at best which is...
Network & Sharing
Download speed issues with some files.
Hey everyone, I am trying to download an add on for WoW but the download I work on is like 1.4mb and when I start the download the speed looks fine and shows me ETA 21 seconds and few seconds later it suddenly plummets to 23 minutes, cause the download speed decreases steadily. What is going on and...
Network & Sharing
RAM and speed issues
Hi! I just bought a laptop with 6 gig RAM and it is saying only 1.74 is usable. The computer is also very slow at loading any programs or doing anything at all. is this because of the usable RAM or some other problem? How do I fix it if possible?
Performance & Maintenance
Download speed issues
Hi When I'm connected to my router by cable I get download speeds advertised (+15 megabits) by the ISD provider. When I disconnect the cable and connect the same computer wirelessly to the router, download speeds drop to below 4 megabits. Nothing else changes, connected by wire = high speed...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:55.
Twitter Facebook