Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: H310M question.

3 Weeks Ago   #1
Garock

Windows 7 64-bit
 
 
H310M question.

Hello, I'm new here so I hope I won't be breakin' any rules. (I hope my english is not so broken too then you guys can understand me)
I used the search bar hoping to find some help, got some results but I think I couldn't see anyone with same problem, so I created a thread.

Note: Please, don't hate me I don't need to use any usb3.0 device so this is where my problem differs from others that I saw over here I think.

Well, let's begin:

I'm downgrading from w10 to w7 in my h310m. I just can't stand w10, last update just f***ed up boot and no win 10 fix tools could fix it. I tried so many things even in cmd but didn't work so I tried to do what I should have done from the beginning.

I installed w7 via ethernet (legacy pxe work like a charm). During setup I used a ps2 keyboard.
Now the system is installed and upgraded. Drivers were installed too (via DriverPack Solution).
However I can't use any USB port. And I'm not talking about the 2 x usb3.0 ports that my mobo have.
I need to enable the common usb2.0 since I just don't use the usb3.0 and sincerely I don't mind if the 3.0 don't work. I only need the usb2.0 working so I can use my common key/mouse and audio interface.

In Control Panel > Device Manager. USB and PCI Device appears with "/!" and I can only use w7 it with ps2 keyboard using ctrl+shift+numlock to control the mouse arrow with numpad keys.

As a bonus w7 couldn't recognize my nvme but that's a problem I don't mind at the moment. Maybe later I would, so w7 is installed on ssd.

I'm posting this in my 2nd pc which is a old workstation with w7 properly installed. (I just love w7).

I don't know if I'm messing up the bios, I tried every single combination of USB options in Peripherals tab, or if i won't be able to use w7 on that machine
I really want to use it as a system not vm or emulations. If it's possible.

The specs of the 310 of my nightmares:

Mobo: Gigabyte H310M S2P
proc: i7 8700
ram: 32GB ddr4
vga: GTX1050Ti
storage: nvme 240GB x1; ssd 128GB x1; HD 1TB x2;
My System SpecsSystem Spec
.
3 Weeks Ago   #2
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, & Kali
 
 

Hi Garock,

Welcome to Sevenforums!

SIW2 is our resident guru in this area and is online regularly/daily.
Megahertz07 may be able to assist your as well.

Blue text will notify them.
My System SpecsSystem Spec
3 Weeks Ago   #3
Garock

Windows 7 64-bit
 
 

Quote   Quote: Originally Posted by Snick View Post
Hi Garock,

Welcome to Sevenforums!

SIW2 is our resident guru in this area and is online regularly/daily.
Megahertz07 may be able to assist your as well.

Blue text will notify them.
So it's better to send 'em PM? if so no problem I'll try it!

[EDIT]

I hope that SIW2 or Megahertz07 can help me, I didn't found the PM button in his profile.
My System SpecsSystem Spec
.

3 Weeks Ago   #4
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, & Kali
 
 

Not necessarily better to send PM
SIW2 is online most every day, megahertz07 not so
by my use of the username it appears in blue text,
they will know that this post has their username
Actually right now SIW2 is reading your thread.
When you go to a member's profile you click send message, in dropdown menu it is listed with other choices if enabled by the user in preferences.
Hope this helps.
My System SpecsSystem Spec
3 Weeks Ago   #5
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Haven't heard of that before. I would install the mobo usb3 win7 drivers and see if the ports are backward compatible with usb2devices.
My System SpecsSystem Spec
3 Weeks Ago   #6
Garock

Windows 7 64-bit
 
 

Quote   Quote: Originally Posted by SIW2 View Post
Haven't heard of that before. I would install the mobo usb3 win7 drivers and see if the ports are backward compatible with usb2devices.
Okay, but this mobo doesn't have usb3.0 drivers for win7, at least in their official website (gigabyte). So If you have 'em or know where I can get these drivers I'll try this method. I also think that if it's possible to get the usb3.0 drivers I should include them on my pxe instalation drivers directory and maybe the 2.0 can work too. But I have to find the drivers first :/ Sadly the drivers are w10 only in gigabyte website.

Quote   Quote: Originally Posted by Snick View Post
Not necessarily better to send PM
SIW2 is online most every day, megahertz07 not so
by my use of the username it appears in blue text,
they will know that this post has their username
Actually right now SIW2 is reading your thread.
When you go to a member's profile you click send message, in dropdown menu it is listed with other choices if enabled by the user in preferences.
Hope this helps.
I didn't know how this forum work and thank you very much for your help and support!
My System SpecsSystem Spec
3 Weeks Ago   #7
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

My System SpecsSystem Spec
.
3 Weeks Ago   #8
Garock

Windows 7 64-bit
 
 

Quote   Quote: Originally Posted by SIW2 View Post
Thanks I'll try 'em after my dinner xD I hope they work! I should try to install them in my actual "no usb working w7" if it doesn't work I should include them in the drivers folder and install a new w7 via PXE with these drivers. Crossing fingers
My System SpecsSystem Spec
3 Weeks Ago   #9
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, & Kali
 
 

Quote   Quote: Originally Posted by Garock View Post
I didn't know how this forum work and thank you very much for your help and support!
You're Welcome!
That's why we're here, to help!
Snick
My System SpecsSystem Spec
3 Weeks Ago   #10
Garock

Windows 7 64-bit
 
 

SIW2 You deserve THE BEST BEER IN THE WORLD MAN!
YOU SAVED MY LIFE! GODDAMN! I HAVE NO WORDS!
Thank you Snick for helping me too!

Sorry for the emotional writing I'm freaking happy that it works! I installed the drivers SIW2 sent me in my actual w7 'no-usb' and VOILA! It's working! I'll never miss these driver files again! I'll backup it in all of my 6 Storage Drivers and cloud! Thank you very much for your help and support! You are a true hero! I'm gonna fix all the problems with this instalation (the nvme now is the only problem remaining!). My nvme is a chinese "Reeinno" never found drivers of it. But I hope some nvme drivers you have can help me.

AGAIN! THANK YOU VERY MUCH!
My System SpecsSystem Spec
Reply

Thread Tools




Similar help and support threads
Thread Forum
Software RAID question, and NAS box software question
The more I try and learn about backups and safe storage the more questions I have. Here's my latest. I have two identical SATA III 1 Gb hard drives, designated "D Drive" under Win 7 64 bit Pro. They are under an Intel software RAID 1 on a Gigabyte GA-Z97X-Gaming 3 motherboard. All appears...
Hardware & Devices
Thermal Paste Question..(Noobish Question)
Hey guys, I recently purchased Corsair H40 that came with pre applied thermal paste. Before I placed the H40 sink on my processor, I applied a thin layer on the on the processor with Cooler Master thermal paste. So essentially I mixed the H40 pre applied thermal paste with the Cooler Master thermal...
PC Custom Builds and Overclocking
Answer Question, Ask Question.
First (hope you get the reference): In a world where a piano is a weapon, not a musical instrument, on what does Scott Joplin play "The Maple Leaf Rag"?
Chillout Room
Logitech 5.1 surround question and soundcard question IDT and Realtek
So my situation is unique lol i have a Dell inspiron n5010 laptop running Windows 7 ultimate 64 bit the soundcard for this is either IDT 92HD79B1, v.6.10.0.6267, A01 or A03 i dont know what the default one mine came with is. Documentation i hope that helps ^ and the attatchment i...
Sound & Audio
Odd Question
Hey all, possibly the wrong place for this but I just cant find what im after. Figured customization is about the best place on these forums. I want an aquarium program, dont mind paying, but i need it to run as a program rather than a screen saver! I have dream aquarium which is very cool...
Customization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:04.
Twitter Facebook