Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Belkin F5D8053 N Wireless USB Adapter Problem

28 Nov 2009   #1

Windows 7 64-bit
Belkin F5D8053 N Wireless USB Adapter Problem SOLVED

I just upgraded a computer with a fresh install of windows 7. Everything went pretty smooth. got all the hardware and peripherals working NP, untill it came to the Belkin F5D8053 n.
Win7 didnt recognize it straight off, so downloaded the latest Vista drivers from belkin website as there was no win7 support . After about 3 attempts i got it working by doing the install with troubleshoot compatibility and setting it Vista SP2. Was working ok all night even after a few reboots. Then got up the next day and booted up, and it just seemed to have died for no reason. I've been trying for 2 days to get it working again since, and i'm out of ideas.
I've tried re installing the drivers in various different ways, using all the different OS compat settings for XP and Vista. tried older drivers, even tried generic ones, and the ones that win7 installs automatically, tried different USB ports, Tried doing a System Restore to the point when it worked. After searching through forums i found a guy who said he got it working by installing a particular Ralink driver, tried that no luck. The little blue LED comes on when you boot up and win7 tries to connect with the wireless, then the light goes off straight away and the wireless icon in the tasktray turns into the network symbol with a red cross on it and says there's no network present. The driver appears to be installed ok if you look in devices. I not long discovered If you go to the adapter settings on the left in Network and Sharing window, it shows up there but its greyed out and says it's disabled. if you enable it, it tries for about 2 seconds then does nothing and stays grey. Tried Letting windows troubleshoot it from there but ends up saying there's a problem with the driver and it cant fix it.
Sorry for the 5 page essay lol but it's just frustrating because i actually had it working at one point so i know its possible. Worked fine with previous install of XP. Only thing i havnt tried is to format and fresh install again. dont wanna do that unless i have to.
If anybody has any idea's i'd be gratefull, otherwise might as well thow it in the bin and attempt to buy an alternative that works.

My System SpecsSystem Spec
29 Nov 2009   #2

XP, Vista, W7 64bit Home Premium

Here is a similar problem resolved by the person when QNA was running, but unfortunately it may be of no use to you, as it sounds as though you have already tried everything :

belkin F5D8053 wireless usb adapter disconnects in windows 7
here's the Answer (since I can't answer my own question, nor can I answer anyone else who asked this exact same question, as their questions are closed)
Here's what I did, it may or may not work for you.
Download the older Belkin Driver from their website here article
Uninstall whatever driver you have installed now from Add/Remove Programs
Once that is done, find the file you downloaded, right click on it and go to Properties.
Put a check mark in 'Run as Administrator' and change it to run in compatibility mode for Vista. (If Vista does work, retry all this with XP Svc Pack 2) Vista worked for me.
Now run the file.It should install and let you use your adapter.
Mine used to disconnect me about every 5-10 minutes and give an error that no drivers were installed. I would have to unplug and reinsert the usb adapter and it'd work again.
After doing this procedure, it's been up and running for about 2 days now with no disconnects!
My System SpecsSystem Spec
29 Nov 2009   #3

Windows 7 64-bit

Ok thankyou, i'll try what he says for the hell of it. worth another shot
My System SpecsSystem Spec

01 Dec 2009   #4

Windows 7 64-bit

Ok, I finally got it working with the help of a post from another forum i found. Just wanna say ty very much to this guy for his effort in figuring out something that belkin should have clearly sorted by now. Here is the post for all of you who are having the same issues..
This worked for me and I'm using Belkin F5D8053 N Wirless usb dongle v3:

After various testing configurations, I would like to confirm that the Belkin F5D8053 (a Draft-N adapter) works with the Ralink RT2870 chipset. It does not require any modified INF files or custom driver packs, but still requires some configuration adjustments and drivers directly from Ralink. My configuration has this running correctly under Windows 7 (64-bit). The following steps are required to get this operational:

0) Make sure you have uninstalled any existing drivers or software you have installed for this specific Belkin adapter. As there is no Windows 7 driver from Belkin yet at the time of writing, this shouldn't be a problem.

1) Visit the Ralink website:

Ralink corp. | Home

Head to the "Software" page, and on the Windows page download the "USB (RT2870 /RT2770 /RT307X /RT2070 /RT3572)" driver (currently dated 09/25/2009, the filename is "IS_AP_STA_RT2870_D-"). This driver package includes drivers for Windows 2000, XP 32 & 64-bit, Vista 32 & 64-bit and Windows 7 32 & 64-bit.

2) Right-click the installation file and set the Compatibility Mode to "Windows XP SP2". This step is required, as the Windows 7 drivers do not contain the "PSP Xlink Mode" option in the Advanced settings of your network adapter. The drivers installed when the installer is in compatibility mode still function properly under Windows 7 64-bit.

3) Run the installer (now set for XP SP2 compatibility).

- Click the "I accept the terms of the license agreement" radio button and click Next.
- When asked "Choose to install...", select the "Install driver only" radio button and click Next.
- Click Install.
- Wait for the "InstallShield Wizard Complete" dialogue box to appear.
- Click Finish.

4) Insert your Belkin F5D8053 N wireless USB adapter into a powered USB port on your computer. Given the size of its casing potentially obstructing other nearby USB ports, you may want to use the stand that comes with it.

You should get a notification from Windows 7 saying drivers were NOT successfully installed.

5) Go the Windows "Control Panel" and open up "Device Manager". Under the category "Other devices" will be "F5D8053 N Wireless USB Adapter" with a yellow triangle and black exclamation point (warning symbol) next to it. Right click the F5D8053 adapter and select "Update Driver Software..."

6) When asked "How do you want to search for driver software?", select "Browse my computer for driver software. On the following screen, select "Let me pick from a list of device drivers on my computer".

From the "Select your device's type from the list below" listing, select "Network adapters" and click Next.

From the "Manufacturer", select "Ralink Technology, Corp." [DO NOT SELECT "Ralink Technology Corp." Make sure to select the one WITH the 'comma' in the manufacturer name.] From the "Network Adapter" list, select "802.11n USB Wireless LAN Card (Ralink Technology, Corp.)". Click Next.

You will receive a dialogue box titled "Update Driver Warning" stating "Installing this device driver is not recommmended because Windows cannot verify that it is compatible with your hardware. If the driver is no compatible, your hardware will not work correctly and your computer might become unstable or stop working completely. Do you want to continue installing this driver?" Click Yes.

Windows will beep a few times and the blue light on the Belkin adapter should flash. You will receive a dialogue stating "Windows has successfully updated your driver software" for the device "802.11n USB Wireless LAN Card". Click Close.

"802.11n USB Wireles LAN Card" will now appear under "Network adapters" in the "Device Manager". (It is possible that the device may have a number after it depending on how often you've installed/uninstalled the drivers and didn't take the time to clear out any leftover registry entries afterward. This is not harmful.)

Thats it
My System SpecsSystem Spec
01 Dec 2009   #5

XP, Vista, W7 64bit Home Premium

THKS for posting back, hope others will benefit :).
My System SpecsSystem Spec
03 Dec 2009   #6

Windows XP sp3 and Windows 7 64 bit

Busker991 - Thank you very much for showing the way on the pesky Belkin F5D8053 Windows 7 install. Like you, mine worked for a few days after a fresh install then just stopped. I don't usually sign up to these forums, but how else could I have thanked you?

And who's going to kick Belkin's a**e? They should be ashamed of themselves...

Thanks again!
My System SpecsSystem Spec
03 Dec 2009   #7

win7, vista

got the belkin working, but is it possible to use the ralink utility?

im using ralink utility on other machines and like it very much
My System SpecsSystem Spec
04 Dec 2009   #8

Windows 7 64-bit

Zebbie you're welcome :)
Cixoos, from the post i found, the guy said not to install the ralink utility. But i haven't actually tried it. But now mine is working dont really wanna try install it incase something goes wrong lol. But i guess if you tried, you could always uninstall it again if it didn't work or just do a system restore
My System SpecsSystem Spec
04 Dec 2009   #9

win7, vista

the ralink utility doesn't work. driver version says 1.3 something. windows says connection is 135mbps something.

thinking of replacing the old belkin because its very sensitive. Just putting a book in front of it and the router decreases the speed to 13,5
My System SpecsSystem Spec
29 Dec 2009   #10

Windows 7 Home Premium

After installing the Belkin driver in compatibility mode (and I tried XP sp2, Vista, and Vista sp2) the adapter would work for a while and then disappear from the system. The Ralink driver worked but I discovered another problem (and solution). I noticed that when the Belkin adapter disapeared, so did my Pocket Media drive. When I took up that issue with HP tech support they told me to update the NVIDIA USB EHC1 Chipset. The URL for the update is for those who have HP Pavilion desktops. Both the wireless and the drive are working fine now. Kudos to the HP guys for a quick response and a working solution.
My System SpecsSystem Spec

 Belkin F5D8053 N Wireless USB Adapter Problem

Thread Tools

Similar help and support threads
Thread Forum
Belkin F5D8053 N Wireless USB adaptor Windows 7
Hi ive got windows 7 ultimate. Ive been trying to install my wireless drivers, when you run them form CD everything seems fine and says installed, but when it says connect your usb device it starts to instal the intantly stops and says driver not installed..
BELKIN Wireless G Adapter Problem
Recently, i bought a new BELKIN wireless g adapter. The adapter keeps on dropping connection and i can't even download a 200mb file without it dropping. My friend has that adapter and somehow he made it work but he says it was like 2 years ago, he can't remember how he did it. Can anyone PLEASE say...
Network & Sharing
Belkin wireless adapter problem
Hi, I have recently purchased a belkin F6D4050 N150 Enhanced Wireless USB Network Adapter and installed the driver from belkins site. The adapter stays disabled regardless of me trying to enable it. I have been trying to solve this for days!! I have followed your instructions and the ones on the...
Network & Sharing
Temporamental DiNovo Keyb/mouse and Belkin F5D8053
Hi all, New to the forum so, nice to meet you... I have recently been experiencing timeouts on my mouse/keyboard combination (Logitech DiNovo - bluetooth) and my Belkin F5D8053 Wireless 802.11n USB. When I say timeouts I mean the devices just stop working every now and again. The...
Hardware & Devices
BELKIN Wireless G USB adapter Problem- again
Hi all members. I read alot topics on this forum to try solve my problem. I found in here 2 topics about Belkin Wireless G USB adapter , but still i have a problem I describe whats the problem . I try to instal on my Windows 7 x64 b.7000 drivers for belkin w g usb adapter f5d7050 I...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:05.
Twitter Facebook Google+