Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Making SMCWUSBT-G wireless adapter work with Windows 7

09 Dec 2009   #1

Windows 7
Making SMCWUSBT-G wireless adapter work with Windows 7

In case you have SMCWUSBT-G, this post may help in making it work with Windows 7.

I had major problems getting this work with Windows 7 (the manufacturer is not helpful despite requests for windows 7 drivers). But you can get it work with the drivers meant for previous windows versions.

1. Download the software/driver (SMCWUSBT-G_V1.11.000.ZIP) from

2. Unzip & Install the software. We are only interested in two files from this installation.

Of course it may never work - You may be prompted to insert the adpater, but it may not recognise it & entire installation may even get cancelled. If you have problems, try the vista or xp compatibility option (Right click -> Properties -> Compatibility).

As a last resort, if you have an XP machine/partition, install there (you can make use of the working SMCWUSBT-G installation if you have one on that machine/partition).

3. Copy the two files ar5523.sys & ar5523.bin (from C:\Program Files\SMCWUSBT-G*) to a temp. directory, let us say, C:\Temp

4. Go to Device Manager & update the driver for AR5523 letting windows search for the drivers in C:\Temp (overriding any warnings). Windows 7 will install the drivers & it may be able to connect to the wireless networks. If not see 5.

You may uninstall the software installed in 2, if you managed to do so. It is not required.

5. I had varying success with the windows 7 bits - Beta/RC/RTM. While the above steps worked on Beta/RC bits, it did not work on the RTM bits. It turned out that I had to make a change on my SMCWBR14T-G router as well for the RTM bits to work - I had Super G-Static Turbo mode (proprietory I guess) enabled on the wireless router earlier - turned this off & enabled 802.11g. It started working & hopefully stays that way!

Overall, it was a very painful exercise.


I am not a windows person, so I may not be giving the exact procedure here, but you get the idea.
My System SpecsSystem Spec
27 May 2013   #2

Windows 7 Professional x64

I finally got this to work on my Windows 7 Professional x64 system... although like previous posters have said, this was a painful exercise.

First, the SMCWUSBT-G does not officially have support for x64 based systems. I tried various different drivers from the SMC site and none of them worked. After doing research though, this wireless adapter is just leverages an Atheros AR5523 device. I found a NETGEAR WPN111 adapter that uses the same device and they've updated the driver to support x64 based systems.

So, here are the steps:

1) download the Netgear wpn111 adapter drivers and software for Windows 7.
2) Run the installer to completion.
3) Go to the installation directory and navigate to the drivers directory and copy out these 3 files to some temporary directory: athrxusb.sys,, WPN111vx.inf
4) Uninstall the NETGEAR software (its not needed).
5) In the temporary directory, open up the .inf file with a text editor.
6) Find this line: "%ATHR.DeviceDesc.5523% = ATHR_DEV_5523.ndi, USB\VID_1385&PID_5F01"
7) Copy that line to a new one below it.
8**) Edit the copied line and change USB\VID_1385&PID_5F01 to USB\VID_1690&PID_0711 - save the file
8) Plug in your wireless adapter if it not already plugged in. Go to the device manager and find the AR5523 device that should not be working.
9) Right-click and select "Update driver software...", browse for the location of the driver and point it at the temporary directory containing the modified .inf file.
10) The driver should install and everything should work now... have fun!!

**NOTE: This step is where you fool the driver software into thinking you installed a NETGEAR adapter rather than the SMC adapter. The section I changed is basically the Hardware Id of my SMC adapter. If you don't have the exact model I have, you may need to use a different Hardware Id. To find it, just go to the device manager, find the unused AR5523 device, right-click and select properties, go to the details tab and select "Hardware Ids" from the pick list. This is the Hardware Id you want to replace for step 8.
My System SpecsSystem Spec
29 May 2013   #3

Windows 7

Thanks gman7103. I tried to figure out a way to pm you, but I can't figure out how to do it on this site. I really hope you get to read this. The original post date for this topic was in '09 and you posted this 2 days ago (today is 5/29/13). How cool is that? This is exactly the information I needed to get my network adapter working on Windows 7. Thanks!
My System SpecsSystem Spec

29 May 2013   #4

Windows 7 Professional x64

No problem scotty562. Glad to see it working for someone else.
My System SpecsSystem Spec
21 May 2014   #5

Win 7 Professional 64bit

And one more! I'm also happy that I found the solution of gman7103 - worked for me, too!
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Wireless Adapter won't work on windows 7 but will work on windows 10.
Hello. I have an Asus M52 precision Desktop Computer. I have a USB Wireless Adapter called Belkin N300. Here's a photo of the USB Adapter: The computer originally came with windows 8...
Network & Sharing
D-Link wireless adapter won't work at logon
I have and HP Compaq with a D-Link DWA-130 wireless adapter. Lately, when I boot the computer the D-Link connection manager opens and I have to reconnect the adapter before I can get online. I have to reenter the SSID and the password. Then it works fine until I boot the computer again and...
Network & Sharing
Wireless Network Adapter will not work
I just finished building a new PC and installed Windows 7 Home Premium 64 bit today. I have an ASUS Wireless PCI Express Adapter (PCE-N13 802.11 b/g/n). DSL, with a Linksys rounter. Theres just a red X mark on the taskbar and it won't show any open connections =/. I have several wireless...
Network & Sharing
Can't get USB wireless adapter to work in Windows 7
Hi everyone. This is my first post at the SevenForums. I have had a windows 7 machine for about a year and I recently wanted to get a wireless adapter working on the machine. My machine is a Dell Studio XPS 8000 running Windows 7 Home Premium 64 bit. The adapter I am using is a SMCWUSB-G...
Network & Sharing
PCI-E intel 5300 wireless doesn't work. Then the USB wireless adapter
Dear all, I thought I have met this problem before before my two wireless adapters both stopped working. PCI-E INTEL 5300 TP-LINK WN821N My case is a little different from those I found on this forum. 1. When I upgraded my thinkpad x200 to win7 64bit, I don't have "Wireless Network...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:45.
Twitter Facebook