Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Motherboard sata ports won't work

25 Dec 2009   #11
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

Try just connecting the HD to the first numbered SATA port on the MB & see if it recognizes it.


" Doc "


My System SpecsSystem Spec
.
25 Dec 2009   #12
farbods0

windows 7
 
 

wait if i can put in a cd into my computer and it can read it that means my sata ports do work because i put my windows 7 cd in and it read it but my hdd isnt detected
My System SpecsSystem Spec
25 Dec 2009   #13
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

Quote   Quote: Originally Posted by farbods0 View Post
wait if i can put in a cd into my computer and it can read it that means my sata ports do work because i put my windows 7 cd in and it read it but my hdd isnt detected

If your HD is SATA make sure it is in the first SATA port on the MB!


" Doc "
My System SpecsSystem Spec
.

25 Dec 2009   #14
lamboss

Windows 7 64 bit Ultimate
 
 

did u try updating the bios ?
My System SpecsSystem Spec
25 Dec 2009   #15
farbods0

windows 7
 
 

which one is the first sata port =(
My System SpecsSystem Spec
25 Dec 2009   #16
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

Are they labeled on th MB SATA0, Sata1, etc ?
My System SpecsSystem Spec
25 Dec 2009   #17
farbods0

windows 7
 
 

it is now but it still wont work.
My System SpecsSystem Spec
25 Dec 2009   #18
DocBrown

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)
 
 

Quote   Quote: Originally Posted by farbods0 View Post
it is now but it still wont work.

Does it show in the bios as being recognized? Has the HD been formatted already or is it a new raw HD ?


" Doc "
My System SpecsSystem Spec
25 Dec 2009   #19
Adrian

 

Quote   Quote: Originally Posted by farbods0 View Post
Yes i connected it to another computer and they worked
Welcome Farbods, if I may, this is a custom build?
The initial spool up and post has not completed because the SATA ports are not working?
I suggest the following:
  1. Shut down your system and take it to a stable work area.
  2. Remove the side of the case tutn your pc on its side.
  3. Visually inspect your SATA connections and power connections.
  4. With your fingers check the connections, SATT has a L shape connection and sometimes especially with a new connection it maybe stiff and resist pressure. You will hear it snap in when you make a connection.
  5. The connection to the hard drive must match precisely, sometimes the connection is set at right angle or a reverse L to the periperal. Same thing you will hear it snap in.
See if that works for you.

Happy holidays from your friends here at Windows 7 Support.
Adrian
P.S.
Attached are some pix of connections to refer to.


Attached Images
Motherboard sata ports won't work-a455-2422-call03-re.jpg Motherboard sata ports won't work-sata-20cable-thumb-600x514-49949.jpg Motherboard sata ports won't work-sata-power-cable-extension-8-inch.jpg Motherboard sata ports won't work-sata_hard_drive_connectors_jumpers.jpg 
My System SpecsSystem Spec
25 Dec 2009   #20
ccatlett1984

 

If you have a spare sata data cable, try swapping that out. Its a simple thing, and sometimes you do end up with a bad cable.
My System SpecsSystem Spec
Reply

 Motherboard sata ports won't work




Thread Tools




Similar help and support threads
Thread Forum
Problem with SATA ports
I have an Asus P8Z77-V board and my front dock has just stopped working. Thinking it was a problem with the PCB of the dock I slipped the 500GB drive into an internal slot and still it did not show up in Computer using the ports indicated in the pic with the red arrow. Hooked up the SATA lead to...
Hardware & Devices
A board with 22 SATA ports.
Here's a board with 22 SATA ports. :what: Asrock Z87 Extreme11/ac Review: The Making of a Unique Motherboard - TechSpot
Chillout Room
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
USB 3.0 ports refuse to work as USB 3.0 ports
A few days ago I installed a USB 3.0 card (to be precise, this one: 2-Port USB 3.0 SuperSpeed PCI-E Controller Card - Free Shipping - DealExtreme). It uses the very common NEC µPD720200 USB 3.0 controller. I installed the required drivers for Windows 7, and the card worked fine for the first...
Hardware & Devices
SATA 3 not working on Asus P6X58D-E motherboard with SATA III support
Yesterday I had a PC technician around to see why my PC was not booting-up properly and also to change my SSD to a larger SSD. As I am visually challenged I cannot do hardware upgrades etc, so I got a Techie guy in. We used Zinstall HDD by-the-way and I would highly recommend this application...
Hardware & Devices
Sata Hdd / cable / motherboard sata / problem?
Relatively new hdd disappears after some time. (1Tb WD black sata3 jumpered to sata2) All cables are sata click. The drive is used for storage and is accessed only few times a month. So is any way to test somehow what is the problem hdd, cable or mb sata connector (GA-EP43-DS3L). It's all...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:31.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App