Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Usb Issues

31 Dec 2009   #1

Windows 7 Ultimate x64 Build 7600
Usb Issues

Hi guys My first post.

I would do an introduction, but I feel that'd get off topic so I'll get to the point

Firstly, I'm not sure this is the correct forum. I saw a fair few that I thought this problem of mine would suit. But I THINK this is the most appropriate. Sorry if it isn't. Anyway, down to the problem.

I recently acquired Halo 2 for Windows Vista (CHRISTMAS PRESENT! ) but I ran into a problem that required me to perform this proceedure.
Run Command Prompt (run as Administrator):

Type: net stop cryptsvc and hit enter

You will receive a message stating that the service was stopped.

Navigate to your LocalDrive:/Windows/System32 and rename the "catroot2" folder to "cr2old"

Once it is renamed, go back to command prompt and run this command: net start cryptsvc which will restart the Cryptographic Services:

The above steps may work, however I have noticed that if it does when you exit to the desktop then try to relaunch or reboot the PC the error may come back. If this is true then the steps below have been so far successful.

1. Delete all the tmp*.cat files in the following folders (use the search option on the top right corner of the screen to find and delete the files):

%systemroot%\system32\CatRoot\{127D0A1D-4EF2-11D1-8608-00C04FC295EE} (there may be no files in this folder if that’s the case then only worry about the next folder)

%systemroot%\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE} (if no items are found then go to the next step)

2. Delete all the kb*.cat files in the following folders (use the search option on the top right corner of the screen to find and delete the files):

%systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE} ( A pop up will ask that you need admin rights to delete, accept and delete, you may notice that they were deleted however still appear, if you refresh the screen they will be gone)

%systemroot%\System32\CatRoot\{127D0A1D-4EF2-11D1-8608-00C04FC295EE} (again skip if there is no files in the folders)

3. Delete all the oem*.* files from the %systemroot%\inf folder. (again use the search option on the top right hand corner of the screen to find and delete the files)

4. At the command prompt (Run as Administrator), type the following commands. Press ENTER after each command.

A) net stop cryptsvc

B) Next, Navigate to your LocalDrive:/Windows/System32 and delete the renamed Catroot2 folder we made previously and keep the “Catroot2” file

C) ren %systemroot%\System32\Catroot2 oldcatroot2

D) net start cryptsvc

Exit Command Prompt

5. Run halo 2
Once I finished I was able to play my game. However, the next time I turned on the computer, I found that most of the usb devices i plugged in were unable to work. I suspected that the fix i performed above had something to do with it. When I had a look at the system32 folder, I noticed that the catroot2 folder hadn't been recreated (and yes, cryptographic services had been turned back on). Also the original files have been permanently deleted after a bit of research on the catroot2 folder, I discovered that it did have a bit to do with drivers.

So my question is, does anyone know a fix that will let me get my system back to normal, without me having to reinstall windows? (And yes I've tried reinstalling the drivers.)


PS: Sorry for the bubbly demeanor, but I just downed a large bag of sour skittles it's been ages since I'd had them last

My System SpecsSystem Spec
11 Jan 2010   #2

Windows 7 Professional x64


Have you considered a Repair Install? Repair Install
My System SpecsSystem Spec

 Usb Issues

Thread Tools

Similar help and support threads
Thread Forum
Recording issues with recorders (fraps hypercam etc) sound issues
Hey guys, ive lately been making lets play and walkthroughs on youtube and im having a couple of problems. With my headset, in the background while recording thats like a static noise and i cant seem to make it go away, ive tried multiple recording programs like fraps and hypercam but its still...
Win 7 Upgrade-MANY issues!! Search, screen flashing, Outlook issues..
I have recently upgraded from XP to Win 7 and I have encountered so my problems I've lost count... However, I work from home and I need to get these issues worked out NOW... So, I am DESPERATE for answers... 1. Main problem: I have done a full system index 273,852 files and 2 days later...
General Discussion
Removable Disk Issues - Work through issues
Hello Forum, I have two removable disks. One is write protected (D) - I want to know if you can alter that property. I have just put them into my laptop and discovered the presence of New Folder - with a zip folder in it and another folder called Found. Want to know how that got created. ...
Hardware & Devices
Dhcp issues and network connectivity issues since windows 7 x64 sp1
I reformatted my computer because after installing service pack 1 and other updates from Feb 14th my computer has been having issues getting a dhcp from my router. I have a windows 7 home premium 32 bit laptop that works just fine. I also have a ubuntu machine that pulls an address from this...
Network & Sharing
Windows 7 Ultimate 32bit issues with desktop freezing/ other issues
Hi all, Going to try and make this brief, "try" being the operative word here.. I have a Gateway PC running Windows 7 Ultimate 32 bit 4 gigs of ram but obviously not all useable (yet) Dual core processor Nvidia 9800GT graphics Card Corsair 650 watt PSU HT Omega Striker 7.1 Souncard..
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App