Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Dead USB port

04 Jan 2010   #1
GDMurf

Windows 7
 
 
Dead USB port

I have my two front ports that won't recognize an external Toshiba 320 gig hard drives. It will recognize other items, i.e. thumbdrive, cables, Blackberry, Ipod. The Toshiba works in a USB port on my old XP system. What was the fix?

Thanks,
Murf


My System SpecsSystem Spec
.
05 Jan 2010   #2
Orpheous

XP Pro/Vista Ultimate (64)/Windows 7 Ultimate Signature Edition(64)
 
 

Have you tried plugging it into the back?
Is the hard drive USB powered, or does it have a power pack? If it has a power pack, use it. If it's USB powered only, try using something like this:

Pretty sure it's called a USB Y Cable
My System SpecsSystem Spec
05 Jan 2010   #3
aem

Windows 7 Ultimate 64Bit
 
 

USB devices have their power requirements. It could mean that the Front USB ports are not configured to take up that much power consumptions. try other ports and see if it's infact the port and not your USB device.
My System SpecsSystem Spec
.

05 Jan 2010   #4
seekermeister

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Often, the front USB ports are limited to only USB 1.1, while the rear ports are 2.0, which could be a factor, except that you said that it worked on XP. Yet, I would recheck the USB settings in the BIOS for both 2.0 and that they are set to high speed, not full speed.
My System SpecsSystem Spec
06 Jan 2010   #5
GDMurf

Windows 7
 
 

I reset BIOS to Hi-speed, no joy. I have another external hard drive that uses the "Y" connector for power. I tried this and it worked. Thanks to all.
My System SpecsSystem Spec
06 Jan 2010   #6
Orpheous

XP Pro/Vista Ultimate (64)/Windows 7 Ultimate Signature Edition(64)
 
 

You're most welcome Glad to hear you managed to get it working!
My System SpecsSystem Spec
Reply

 Dead USB port




Thread Tools




Similar help and support threads
Thread Forum
router not passing port scan after opening port
1. Is this a wired or wireless connection issue? wireless 2. Who is your Internet Service Provider (ISP)? Charter 3. What type of Broadband connection are you using? Cable 4. What is the exact Make and Model of your Modem, Router or Modem/Router Combo Netgear WNDR3800, Cisco DPC3008
Network & Sharing
Port forwarding(redirecting), NOT(!) port opening
Hi. I was tired when 50th result in google named "port forwarding" was actually question how to open port. To be specific, I would like windows 7 to do the same what this program does. Which means forward port... NOT fowarding port on my router NOT opening port(allow connections) in...
Network & Sharing
Dead Island and Dead Island Riptide Lags
Hi, I was wondering my PC runs the Dead Island games with lag. It's really annoying, my friend's PC doesn't lag and his is less powerful. I run the games on Steam. My PC specs: Intel Core i7-2600 CPU @ 3.4GHz 16.0 GB of RAM My video card: AMD Radeon HD 6450
Gaming
DVI port on monitor is stuck res of 640x480 VGA port works fine
I have dual monitors......my primary display monitor is a Chimei CMV223D My secondary display monitor is an Acer AL1916W. My graphics card is an HD ATI Radeon 5800. PROBLEM: My primary display monitor which usually has a display resolution of 1680x1050 is currently stuck on 640x480 and...
General Discussion
ethernet port dead after full windows 7 install
On a Dell desktop with pre-installed W7, due to a bad HD, I bought and installed a full retail version of W7. Now the ethernet port is dead. Any advice on how to introduce the operating system and the ethernet port? Many thanks - Tim
Network & Sharing
Port 80 goes dead out of nowhere
Hi, I have a very bizarre problem. I'm on Windows 7 - 64. Router - DLink 6740U Network - 2 Sat receivers, HTPC, Desktop, Laptop. All but the last wired. Laptop on wireless. Lately, once in a day, I'm unable to browse the internet. Skype, IRC and all the other traffic still go, but for no...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:20.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App