Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Usb not recognized (flash drives and externals only)

06 Jan 2010   #1

Windows 7 Ultimate x64
Usb not recognized (flash drives and externals only)

I have done a few days worth of research and have tried multiple fixes and still cannot connect any flash drive or external drive to any usb port on my computer without the dreaded "Usb not recognized" error. My mouse and keyboard are both usb and have worked fine though.

I have unplugged the power cord from my psu for a few minutes. I have booted into safe mode. I have deleted the infcache.1 file. I have check my Bios settings (and have latest bios update). I have completely removed all the usb devices in device manager and rebooted which reinstalled everything. I have booted the computer up with a flash drive already in a usb port. I have gone into Drive Manager to see if anything is recognized without a drive letter. I have even applied the hotfix from here - Nothing seems to work, yet all of these devices work fine on my netbook running Windows XP.

When I originally installed Windows 7 everything was working fine. I would say it roughly stopped working a month or two ago. I don't constantly use flash drives or my externals so I could be a little off on the timeframe (why I didn't do a system restore). I first noticed the problem when I plugged in my Tmobile G1 phone to transfer files and it wasn't recognized. My phone would still charge off of the usb port, but I couldn't mount and browse the 4 gig sd card in my phone. It was working before because I have files on my phone that I transferred from my computer after the Windows 7 install. I started testing out my known, working flash drives as well as my usb powered 2.5" external drive and they too come up unrecognized on all usb ports (front and back).

My specs:
AMD X2 5000+ BE
Gigabyte GA-M55plus-S3G mobo
G.Skill PI Black 4GB ram (2x2 - DDR2 800)
2 Western Digital Sata drives
Nvidia 9800 GTX+ video card
450 Watt PSU (don't remember brand right now, but good amp rating on 12v for video card).
Windows 7 Ultimate x64

The only drivers I am using for the system that are not the default W7 drivers are for my video card and onboard audio. Onboard audio is the only W7 driver provided on the Gigabyte website for my motherboard.

So, anybody know anything I can do, check or double check or should I start considering formatting and a reinstall of W7 (which I have been trying to avoid)?

My System SpecsSystem Spec
06 Jan 2010   #2

Windows 7 Professional x64

A repair install is an idea before you do anything too drastic. It looks like you have covered the basics.

This 1st one could help, unplug your PSU! I hope it's that simple!

How to fix USB device not recognized in Windows

USB port may stop working after you remove or insert a USB device
My System SpecsSystem Spec
11 Jan 2011   #3
Just married

Windows 7 Pro 64 bit

I would like to add a twist to this question. I use Windows 7 Pro. I have several flash drives that I keep certain files on, the largest one is 16GB, the others run 1G to 6 G. I am part of a home network with several computers on the network, they are all wired not wireless. When I am the only one turned on and using the computer and plug in the 16GB flash drive it does not show up as a second drive it is read by clicking on the first computer shown as one of the computers on the network. All of the other drives show up as removable mass storage, the larger one takes on the name of that first computer on the network. This not a big problem just does not seeam right.
My System SpecsSystem Spec

11 Jan 2011   #4

windows 7 home premium x64 bit
same here

Have 4 usb flash drives/ jumpdrives what ever you like to call them, all used to work up until approx mid Dec 2010.
2 x EagleTec aren't reconised, but 2 x Lexar are reconised.
Tried all in every USB port on desktop but still the same.
Very strange. (Windows 7, Home Premium, AMD Athlon II x 2)
My System SpecsSystem Spec
11 Aug 2011   #5

Windows 7 Ultimate 64

Try changing the USB cable! I had the exact same problem on my phone and a printer. A cable change solved both problems.
My System SpecsSystem Spec

 Usb not recognized (flash drives and externals only)

Thread Tools

Similar help and support threads
Thread Forum
BSOD whenever a usb device gets plugged -flash drives, external drives
BSOD whenever a usb device gets plugged -flash drives, external drives - Thanks for having this forum
BSOD Help and Support
External Hard drives and flash drives security
I have a new computer plus a couple of other computers and I have some external hard drives and flash drives. what is the best way to check these devices to make sure they are clean, will just connecting them and viewing them or running AV and other security checks propose a risk to the computer...
System Security
Multiple drives, One Desktop, all drives recognized in network
Hi All, I have (4) hard drives that already have Windows 7 installed on each. My rig is a custom build, so as for Motherboard, I have: Motherboard: Gigabyte G1.Assassin (has two 6GB/s SATA ports, and four 3 GB/s SATA ports) if not mistaken. I would put eligible drives on the 6 GB/s ports,...
General Discussion
All Flash Drives & External Hard Drives NOT ACCESSIBLE?
I set up a new computer. Windows 7 Pro 64x Everything was fine but then I connected a flash drive to it and I get: Location Not Available H:\ is not accessible. Access is denied If I go into the properties to the “security” tab, it says “you do not have permission to view or edit this...
Hardware & Devices
Flash drives and external hard drives
I have windows 7 pro and recently I have not been able to open up a new folder on any external hard drive or flash drive that I use with my computer. When I use these same flash and external hard drives in another computer it works fine, my initial thought is, there is something disabled in my...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App