Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Hard disk not detected... Black screen after Win 7 logo

08 Jan 2010   #1
3TnT

Windows 7 64 bit
 
 
Hard disk not detected... Black screen after Win 7 logo

Hi,

I've got a big problem.

I bought a new computer in parts :

Quote:
WINDOWS 7 64 BIT FRENCH

ASUS P7P55D-E LGA1156 P55 DDR3 2PCI-E16 3PCI-E1 2PCI CrossFireX USB3.0 SATA 6GB Motherboard

Intel Core I5 750 Quad Core Processor Lynnfield LGA1156 2.66GHZ 8MB Cache Retail Box

2 X G.SKILL F3-12800CL9D-4GBRL Ripjaws PC3-12800 4GB 2X2GB DDR3-1600 CL9-9-9-24 Core I5 1.5V Memory Kit

Sapphire Radeon HD 4350 GDDR2 512 MB jusqu'à 1 GB avec la mémoire vive de l'ordi...

Seagate Barracuda 7200.12 1TB SATA2 3.5IN 8.5MS 7200RPM 32MB Hard Drive Oem *3YR Mfr Warranty*

LG GH24NS50 24X Super Multi SATA DVD Writer OEM Black

Thermaltake Wing RS 100 Piano Black ATX Mid Tower Case 4X5.25 1X3.5 5X3.5INT No PS Front USB & Sound

Antec Earthwatts 650W Power Supply ATX12V V2.2 EPS12V Active PFC
I installed it and try to run it.
First, a message always said : Hard disk not detected and this before trying to install anything.

I go in the bios and the HDD is detected, it said Seagates 1 TB on SATA port 1.

So, it see my DVD and my HDD in the bios.

I set the DVD first device boot to install Win 7 64 bit. Then, Windows setup start, I see my HDD with 1 TB free and I installed Win 7 64 bit. At the 3/4 of the installation, the computer reboot and after the Windows logo : black screen.

I can't do anything... I read it's maybe my DDR3 ram, so I remove 3 stick on 4. Nothing's better. Maybe it's my graphic card so I try to use the VGA alone, the S-Video output alone on my 1080P TV. Nothing's better.

I reset the CMOS without remove the batterie. Nothing.

I change my Sata and power cable with working and tested cable. Nothing.

The motherboard have a Memory button test for the RAM compatibility and no problem here.

I can't run my old XP 32 bit cd (don't know why ? he's working).

My mother board come with a cd with driver if I use RAID setup or ahci (or something like that) but I don't run this setup. I try to install it for fun but it asking a floppy and I don't have floppy drive.

I tried my HDD on another computer and he's working nice ! I formated it (NTFS) and I create partition and it's always writing Hard disk not detected.

I really need help !!!

Thanks guys !

Mathieu


My System SpecsSystem Spec
.
08 Jan 2010   #2
mckillwashere

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

Sounds like you have have A bad HD
My System SpecsSystem Spec
08 Jan 2010   #3
3TnT

Windows 7 64 bit
 
 

Quote   Quote: Originally Posted by mckillwashere View Post
Sounds like you have have A bad HD
Why he's working perfectly on another computer ???

I also tried my old 80 GB with XP on it and the computer said Reading error
My System SpecsSystem Spec
.

08 Jan 2010   #4
mckillwashere

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

Check your jumpers, and the sata port your using.... You may have it in the wrong port. Installs funny about that.
My System SpecsSystem Spec
08 Jan 2010   #5
3TnT

Windows 7 64 bit
 
 

The HDD don't have jumper. It configured in shop and we don't have to use jumper.

I'm in the first sata port (#1) and it's the good port too.
My System SpecsSystem Spec
08 Jan 2010   #6
mckillwashere

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

HDD's do have jumpers,
My System SpecsSystem Spec
08 Jan 2010   #7
Eugjr

Windows 7 x64
 
 

I've seen a problem just like yours... It may be caused by a missconfiguration between IDE and Sata controllers in Bios and Windows

You can try this, could work:
Try to change the Bios the options of HDD controller... Try to change from Sata to IDE... Your problem may be the lack of right Sata controller installed...

If the pc boots, you can make this trick to activate the AHCI:
How to enable AHCI in Windows 7 RC after installation | ithinkdifferent

Then just download the latest drivers and everything should be fine...
My System SpecsSystem Spec
09 Jan 2010   #8
3TnT

Windows 7 64 bit
 
 

Quote   Quote: Originally Posted by mckillwashere View Post
HDD's do have jumpers,
You was right ! Seagates said in the spec sheet that the drive doesn't need jumper and they didn't give one with the drive but in small letter in the pdf, they said in some case, we need to use a jumper
My System SpecsSystem Spec
09 Jan 2010   #9
mckillwashere

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

:),
I just got done dealing with all of that with my web server.
My System SpecsSystem Spec
Reply

 Hard disk not detected... Black screen after Win 7 logo




Thread Tools




Similar help and support threads
Thread Forum
External Hard Disk not detected, visible in Disk Manager
Hi, My Seagate 2TB external hard disk is not getting detected by my PC, doesn't show in 'Safely remove hardware' option. However, based on one old thread, I installed Partition Recovery Wizard and this is how the scan looks. Please help.
Hardware & Devices
black screen blue logo
can anyon help? I have a Toshiba laptop with windows 7 when I tried to open it I got a black background with a blue Windows logo on after a few seconds loading it goes to a black screen with no curser
General Discussion
Black screen after windows logo
Hello guys I have an Intel motherboard when I connect vga cable to interragded vga of pc there's no problem but when I install my graphic card and connect vga cable to it the screen turn to black after windows 7 logo So what should I do to fix this ? And thanks
Graphic Cards
Windows has detected a hard disk problem. Hard drive failing?
Hey there guys, about six months ago I started receiving an error every few days on my computer on boot, and it was something along the lines of: 'pxe-rom: Check cable connection!'. To fix it I just used my Windows 7 install CD and it was fine, until whenever it'd happen again. Now, just about...
Hardware & Devices
Black Screen after Win 7 Logo I can see the mouse
I can see the mouse after my windows logo shows up but nothing else. Ctrl alt del does not work nothing works. The only thing I can think of is randomly my computer shut down yesterday while it was plugged in. Its a laptop battery still in and still works. The computer is only 8 months old. I...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App