Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Intellimouse Optical buttons can't be changed

15 Jan 2010   #1

Windows 7 Home Premium
Intellimouse Optical buttons can't be changed

I have a totally new problem with my MS Intellimouse Optical. I have used this for some time (98, ME, XP) with no problems. I now have a new system - Windows 7 Home Premium 64 bit. I have downloaded and installed the latest Intellipoint software (7) from Microsoft, and installed the Mouse. But...
- The Mouse is recognised not as an Intellimouse Optical, but an Intellimouse Web
- I cannot therefore change the side button settings on the mouse (via Control Panel>Mouse) from the default "Forward" and "Back", or the centre button either.
This is annoying. I have uninstalled and reinstalled a number of times, to no avail.

Does anyone know...??
(a) How to get Windows 7 to recognise my mouse as the proper type (Device Manager etc)....or
(b) How to hack the settings (XML / Registry / whatever) to change the default option, so the mouse does what I want it to without trying to change the buttons via the Control Panel.

Many thanks

My System SpecsSystem Spec
15 Jan 2010   #2

Windows 8.1 Pro RTM x64

Hi Walrus1963 and welcome to Windows 7 Forums

When you installed the driver, did you correctly select your mouse model from the dropdown list during installation? If not, uninstall the driver and reboot your machine. Now, reinstall the driver being careful to select the correct model when prompted. What is the model of your mouse?
My System SpecsSystem Spec
15 Jan 2010   #3

Windows 7 Home Premium

Thanks for the quick reply. Yes, I did choose the right model under the software installation. Very carefully!

The trouble is that Windows 7 itself seems to recognise the mouse as an "Intellimouse Web", and installs the drivers it wants to. It does this whether I install the software before or after plugging the mouse in! Neither makes a difference. (And I have rebooted between each installation / uninstallation). I'm confused.

The Model type is simply 'Intellimouse Optical' - (Product ID 52195 - 576 -8429023 - 00000). I know I haven't made a mistake here, because in Control Panel>Mouse there are pictures of all the different types as you try to choose the button settings. I'm choosing the right mouse for my hardware - but not for what Win 7 recognises it as!
My System SpecsSystem Spec

10 Apr 2010   #4

Windows 7 x64 Ultimate

I have seem problem with Intellimouse Optical 1.0A USB. The install problem its no resolved!.
My System SpecsSystem Spec
10 Apr 2010   #5
not so gray matter

W7 Ult. x64 | OS X

If you can find a way to map the buttons manually, use this script as a basis... Untested on Win7, works in Linux:

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"	"/dev/input/mice"
	Option		"Protocol"	"ExplorerPS/2"
	Option		"ZAxisMapping"	"4 5"
	Option		"Emulate3Buttons"	"true"
	Option		"Buttons"	"7"
	Option		"ButtonMapping" "1 2 3 6 7"
If you can't / don't want to use that you can try to find a way to use this Intellipoint alternative software:
My System SpecsSystem Spec
11 Mar 2011   #6

Windows 7 Pro x64

I ran into this problem as well with my intellimouse optical being recognized as an intellimouse web. I was able to change to optical by updating the driver, select "browse my computer for driver software," selecting "let me pick from a list of device drivers on my computer," unchecking show compatible hardware, and selecting Microsoft and "Microsoft USB intellimouse optical (intellipoint)."

The buttons are working correctly for me now.

I noticed this was a problem for many people looking and wanted to make sure that this info was available for future use.

Hope it helps.
My System SpecsSystem Spec
22 Nov 2017   #7

Windows 7 64

dear Walrus1963,
Believe it or not, but your tip worked well for me as well.
Thank you for having taken the time to share your tip, more than 7 years ago.
Seems that Microsoft "Intelli" mice are long lasting animals!
all the best from France

My System SpecsSystem Spec

 Intellimouse Optical buttons can't be changed

Thread Tools

Similar help and support threads
Thread Forum
Appearance of "close", "minimize" ecc buttons changed
Hi, After reinstalling my Windows I've noticed it looks different. everything looks brighter and the windows buttons are different, instead of the normal left one I have the annoying appearance on the right. (images attached) I know it has something to do with the color setting but I can...
General Discussion
Intellimouse Explorer 3.0 Issues
Hey all, Long time listener, first time caller! I apologize if this is in the wrong subsection. I swapped out mice from a Logitech USB optical to a MS Intellimouse Explorer 3.0 (favorite mouse of all time). The mouse freezes after the pc has been asleep for a while. Disconnecting then...
Hardware & Devices
Change resolution of scroll wheel in MS Intellimouse?
My MS Intellimouse Explorer 3.0 has detents in the scroll wheel operation which cause the scroll to jump two or three lines with every use. However, my MS Comfort Optical Mouse 3000 has a smooth continuous scroll wheel operation which is much preferred. Both mice are wired USB devices. Is it...
Hardware & Devices
Wireless IntelliMouse Explorer 2.0 stopped working one morning
New computer a month ago running 64-bit Win7 Home Premium. Plugged in my existing Microsoft wireless combo (Wireless Natural Multimedia Keyboard, Wireless IntelliMouse Explorer 2.0) which both go through the same USB receiver connected to the computer, and all worked well. Installed latest drivers...
Hardware & Devices
weird intellimouse bug
i often leave my pc on a couple of hours and turn the monitor off. it has happened twice now that when i come back my intellimouse optical only operates when i put high pressure on it :sarc: its also very rogh, dodgy, laggy whatever. one of the more weird glitches ive seen :P anyone got an idea?...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:53.
Twitter Facebook Google+