Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Properties "Security Tab" disappeared on external drive

16 Jan 2010   #1

Properties "Security Tab" disappeared on external drive


It has been awhile since I have been here. I anticipate (or at least hope) that this visit won't be as chaotic.

I recently switched back to Windows 7 from Vista a few weeks ago. I am running 32-bit Ultimate on an HP Pavillion laptop that has an AMD X2 64-bit chipset. It is running from one of two partitions on the laptop hard drive (the other partition is used to boot into Linux).

Additionally, I have 2 external drives. Each of these drives has two partitions. One of these drives is a 1TB backup drive that was recently added (the two partitions on this drive are for purposes of allocating half for use by Linux and half for use by Windows). The other external drive (which happens to be the former 2.5" hard drive of the laptop in a case providing USB connection) has two partitions, both of these were/are for use by Windows, however, one partition has an NTFS filesystem, and the other, so as to avoid irritations like the one I discuss herein, was FAT32.

I did a clean re-install of WIN7 (and Linux) about 3 days ago since my MBR was a little complicated and the reinstall was done to reorder the partitions thereby (hopefully) cutting down on fragmentation/drive use.

Anyway, today, for no real explainable reason, the NTFS partition of the older 2.5" external drive became inaccessible to me. Since I have encountered this issue in all post-NT versions of Windows when doing re-installations (i.e., the new installation of Windows does not recognize the external drive's owner SID, and (I am speculating here) therefore makes it inaccessible to the current user), however this was always easily remedied by taking ownership of that drive.

I know when I installed Windows 3 days ago I had access to this drive. But I also know I tweak things (safely) and situations can arise unexpectedly. When I try to take ownership of this partition/drive, the security tab in the properties menu is not present. The other 3 drives (Win partition/int. HD, Win partition/new external HD, fat32 Win partition/old external hard drive) are all fine...the two that are NTFS show the security tab. Obviously the FAT32 partition does not.

EDIT: I thought perhaps restoring a previous version on this drive might be of some use. However, when I checked under this tab, it states "Previous versions are not available for offline files". Don't quite know what that means... though I do know that soon after install, I disabled the Offline Files service. Didn't re-enable it because whatever this problem is, it seems to be affecting only the one external drive in question.

I looked under HKCR\Drive\shellex\ trying to spot an anomaly but it was a bit difficult, especially since I didn't know what GUID was for a particular drive. I checked under the Device Manager hoping to get these GUIDs, but under Storage Volumes, WIN7 shows 16 generic volumes, 7 of which are hidden.

So before going any further and risking a broken system, I thought I would let wisdom prevail and throw this question out to this forum.

Anybody know how I can restore the securities tab for that drive/partition so I can take ownership of it?

Note: I also tried using ICACLS with no luck, but I am only in the Administrator group. Again, I though I would post before jumping forward and invoking the Administrator account.


My System SpecsSystem Spec
16 Jan 2010   #2


Just wanted to add something else I noticed just now. In the past (when Windows 7/Vista seems to be working correctly anyway), I could always create a shortcut on the desktop to the command prompt, and then in the compatibility tab, I would check "Run as Administrator". However, I just tried to create such a shortcut, but the compatibility tab is greyed-out. This is perplexing me as well.

This feels all too familiar.
My System SpecsSystem Spec

 Properties "Security Tab" disappeared on external drive

Thread Tools

Similar help and support threads
Thread Forum
External USB2 drives "disappeared" from the computer explorer window
I have four external usb drives. All seem to have disappeared at the same time. I checked one of them on another computer and it's fine. There's no error \ in the device manager, except it said that the device on one port had failed. I disabled that but left it plugged in because I don't know...
Hardware & Devices
Showing some numbers when doing "right click>properties>security" tab
Hello everyone, 2 week ago i was having trouble opening "my computer" and "network places" properties. Everytime i tried to do right click>properties, i got nothing. I thought my pc got infected so i reinstalled windows 7. Yesterday i did see something when i right clicked...
General Discussion
second hard drive icon "D" disappeared after reinstalling windows
"C" drive is showing in my computer but the "D" drive is not showing anymore after reinstalling windows
General Discussion
"unknown Users" are listed in Properties/Security of a folder.
PROBLEM: "unknown Users" are listed in Properties/Security of a folder. I have Windows 7, 64-bit. The Properties/Security box of my "C:\Users\" folder lists two Users called "Account Unknown (S-1-5-21-879640176-2077098734-2292519611-1001)" and, "Home Users", in addition to the legitimate...
General Discussion
2.5" External drive "falls asleep"?!?!
So I've been up for hours this morning, fighting with a brand new Seagate 500Gb Extension 2.5" portable hard drive. While transferring 120Gb of information from the drive to an internal drive, it often stops copying/moving halfway through. It seems to happen mostly on large (1Gb+ files), but has...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App