Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB mass storage device is slow to be ready for access

09 Feb 2010   #1

Win 7
USB mass storage device is slow to be ready for access

I have a USB mass storage device (a flash disc) which takes 5 minutes from connecting it to my PC before I can access the files on the disc.

When connecting the device to a PC running Windows XP or Vista the disc is ready for access within seconds.

In Device Manager the mass storage device appears without any warnings or errors. It does that as soon as the drive has been connected.

My System SpecsSystem Spec
09 Feb 2010   #2

Win 7 Ultimate 64-bit SP1 (desktop)

Something like this was happening to me with one of my mp3 players recently, when I had it set to operate in MSC mode. So out of curiosity, I switched the player's USB mode to MTP, and now it works like a champ.

I realize that won't help you with your flash device, but I'm hopeful any solution people come up with for you might also solve my mystery.
My System SpecsSystem Spec
12 Feb 2010   #3

Win 7

OK, I have some further information in this case:

I have logged the USB communication between both a Windows XP and Windows 7 PC and my Mass Storage Device by SnoopyPro. It turns out, that there is a difference in the SELECT_CONFIGURATION communication, within the setup of Interface->Pipe->MaxTransferSize:

Windows XP:
Host -> Device: MaxTransferSize = 0x00001000
Device -> Host: MaxTransferSize = 0x00001000

Windows 7:
Host -> Device: MaxTransferSize = 0xFFFFFFFF
Device -> Host: MaxTransferSize = 0x00400000

For me it seems like in Windows 7, the host (my PC) asks for a maximum buffersize of 0xFFFFFFFF bytes, and my Mass Storage Device says it can only deliver a buffersize of 0x00400000 bytes. But Windows XP only asks for a buffersize of 0x00001000 bytes and my Mass Storage Device delivers it.

Does anyone have a clue why Windows 7 wants such a big buffer?
My System SpecsSystem Spec

24 Dec 2010   #4


Did you ever find a solution to you problem. I have what appears to be the same problem.

Here is my situation. I have 2 Patriot Memory sticks(4gig and 16gig) and a sony 16gig stick. The Patriot 16gig takes for ever to mount. It is seen in Device Manager ASAP after being plugged in, but doesn't show up under portable devices for a long time. Now I can plug say the Sony and it mounts in seconds, i can then mount the 16gig patriot and have to wait and then load the 4gig and have to wait till the 16gig is mounted first before the 4gig will mount.

Now this is only on my laptop. It loads just fine on other systems. Why? It is not a hardware problem, some how it has to do with Win7 but not sure where to make changes. I wish i could just remove everything from the registry but not sure what to remove.
My System SpecsSystem Spec

 USB mass storage device is slow to be ready for access

Thread Tools

Similar help and support threads
Thread Forum
USB Mass Storage Device/Unknown Device
In Device Manager, there is a USB Mass Storage Device or an Unknown Device, even when there isn't anything plugged in. This is occurring on a Dell Dimension 5100. This is not the pc in my system specs. How do I fix this? Here are some Device Manager screenshots:
Hardware & Devices
Mass storage device usb driver
Hello. I do have a problem with Mass storage device usb driver and precisely with an iPod Classic 80Go.I tried everything but I always have the problem only on my computer;It detects the iPod as an amovible disk but iTunes doesn't detect it and its content is unreachable.
USB mass-storage slow to be ready for access
Hi! I've been through a very singular problem for the last few days. My Windows 7 suddenly become slow to make USB Mass storage devices ready to access, but this happens only the first time I connect them on my computer. If I start the computer and connect the USB Mass storage device (that ...
Hardware & Devices
USB Mass Storage Device
Hi All, Been using the new Windows 7 for a week or so now, everything is great! But i have one big issue. Every time i plug in a USB pen drive or my tomtom device, a window appears with a message saying that the device drivers can not be installed. When i click on the ballon message it just...
Mass Storage Device
i have a Gateway 7803u notebook WIndows 7 64-bit specs are i hook up my external HD and it will not show up Mass Storage Controller with the yellow ! driver properties say

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App