Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: U3 software won't start

26 Feb 2010   #1

windows 7
U3 software won't start

I purchased a new Sony VAIO laptop today with Windows 7 64bit. I am using a Sandisk Cruzer 32 gig USB stick that worked very well on any random pc and my old laptop with windows 7 32bit.

It has the latest U3 software version on it. I just had a long chat with Sandisk support and they had no clue what could cause this, while actively have tried to find a solution.

Does anyone have an idea what could cause this? I've already tried to shut down unknown processes. It still won't start.

It also won't start the U3 software on my old 8 gig cruzer.

Thanks in advance for your help!

Best Regards,
Jan Jaap

My System SpecsSystem Spec
26 Feb 2010   #2
Darryl Licht

Windows 7 Ultimate 64 bit Steve Ballmer Signature Edition

First thing I do with any SanDisk is get rid of the U3 stuff. It's value added bloatware and U dont need it!
My System SpecsSystem Spec
27 Feb 2010   #3

windows 7

Hi there!

I do need U3 for AES encrypted password access.

I may have found the reason. I believe the U3 stopped working after I installed Norton 360. I just found a topic where people describe having experienced simular problems.

u3 wont launch!!! - Norton Community

However, I can't find a way to kill the Norton 360 process. Do you know if uninstalling is the only way to test it?
My System SpecsSystem Spec

27 Feb 2010   #4

Windows XP

I have the Verbatim 4GB thumb drive that uses U3 as well and it works fine on Vista but doesn't work on Windows 7, and I have Norton installed on both computers. So I don't think it's Norton.
Try this:
Plug the U3 drive in and wait for windows to add the drives to the explorer. (There should be two drives added; in my case it was F: and G: )
Open explorer and navigate to the lowest drive added (F: in my example)
Double click on LaunchU3.exe .
Once the U3 'menu' is loaded, click on the U3 icon and in the menu click on Settings > U3 LaunchPad Settings
Go to Autorun and click on Install Launcher.
Click Close when install is done.
Click the U3 icon and select Eject.
Remove the U3 drive and wait for Windows to release the drives / USB devices.
Insert the U3 drive and check if the LaunchPad starts automatically now.

Let me know how this works for you.
My System SpecsSystem Spec
27 Feb 2010   #5
Darryl Licht

Windows 7 Ultimate 64 bit Steve Ballmer Signature Edition

Quote   Quote: Originally Posted by SEO View Post
I do need U3 for AES encrypted password access.
There are other solutions for AES encryption... one is included with upper end versions of Win7 Bit-Locker to go... another very respected encryption sw out there is TrueCrypt. <--FREE too!
My System SpecsSystem Spec

 U3 software won't start

Thread Tools

Similar help and support threads
Thread Forum
I'm getting this error message when I try to start certain software
The message says "The procedure entry point ucrtbase.terminal could not be located in the dynamic link library api-ms-win-crt-runtime-|1-1-0.dll" If I click the Ok button several times, the required software starts up
General Discussion
Looking to get free software for nonprofit, best way to start?
Hello, My friend and I have just started a club at our highschool, where we repair and donate computers to those in need. We have all of the hardware, but we were wondering where we would be able to get free copies of a Windows OS to use and install on all the the computers. Is there a program...
Software Won't Open on Start-up
Over the past month, my programs -- Office 2010, Quicken, etc. -- will no longer open on start-up. There are no error messages. Outlook, for example, will not open from the task bar or from within "programs" on the start menu. The Icon highlights and the "activity" circle shows, but then shuts...
system rebots when i start 3ds max software help!
Problem signature: Problem Event Name: BlueScreen OS Version: 6.1.7600. Locale ID: 1033 Additional information about the problem: BCCode: 116 BCP1: 8655B510 BCP2: 8E21B9B0 BCP3: 00000000 BCP4: 00000002
Software Protection Service will NOT start.
Windows 7 Professional (x64) - (Pre-installed by HP.) My automatic Microsoft Updates stopped working sometime after 2/9/2010, with a Error Code C0000022. My system still runs good, just can't get updates. After digging around, I found that it is because Software Protection Service is failing...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:04.
Twitter Facebook Google+