Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Installed memory(RAM): 4GB (2.94GB Usable)

08 Apr 2009   #1

Installed memory(RAM): 4GB (2.94GB Usable)


I have currently 4gb or ram (Im pretty sure that my pc used to detect or make use of it all), however i probably have messed up something and it uses only 3 now! It is win7 build 7068 x64 so technically it should make use of it all. Any suggestions?


Attached Images
Installed memory(RAM): 4GB (2.94GB Usable)-capture.png 
My System SpecsSystem Spec
08 Apr 2009   #2


it says to refresh the monitoring :P

besides, you maybe using your 1Gb on the internal video card for its memory
My System SpecsSystem Spec
08 Apr 2009   #3

Windows 7 x86 build 7077

^ yep, you either have an allocated amount of physical memory dedicated to something else or you don't have memory remapping enabled in your bios.
My System SpecsSystem Spec

08 Apr 2009   #4


Well yes, I do have GTX280 1GB gpu. But isn't x64 supposed to accommodate all of it ?
My System SpecsSystem Spec
08 Apr 2009   #5

Windows 7 Ultimate X64

i also have the same GPU, and RAM should show 4GB regardless, video ram is dedicated on it's own, and @ 1GB that's amazing, I
Refresh your WEI score, and you'll be ok.
My System SpecsSystem Spec
08 Apr 2009   #6

Windows 7 x64

Go to BIOS and enable "Memory Remap".
My System SpecsSystem Spec
12 May 2009   #7

Windows 7 RC 7100 64 bit

The "reserved for hardware" answer is the same one I got when running 32 bit Vista with 4GB a year ago. What is the advantage of using a 64 bit OS with 4Gb ram then? And why are there so many references to win32 when you generate a system health report in Windows 7 64 bit? It looks like this:

OS Checks
Operating System Info

root\cimv2:SELECT*FROM Win32_OperatingSystem
root\cimv2:SELECT*FROM Win32_ComputerSystem

--- or this further down the list ---

System Services

root\cimv2:SELECT __Relpath, Name, Caption, Description, DisplayName, PathName, Started, ExitCode, State, ServiceSpecificExitCode FROM Win32_Service

with every available/running windows service listed as a "Win32" service after it.

I upgraded to Windows 7 64 bit (which it reports as OS in other places) from Vista Home Premium 64 bit. Here are machine specs.

Gigabyte GA-P35-DS3L (latest bios)
Core 2 Duo E6600
4GB G-Skill RAM (2x2GB)
Intel Gigabit CT NIC
EVGA Nvidia 260 GTX 216 core Video

My System SpecsSystem Spec
23 May 2009   #8

Windows 7 Professional x64

If there is no option for memory remapping in your BIOS then you're pretty screwed - I'm in the same situation. 1Gb of my 4Gb RAM on Win7 x64 is 'hardware reserved' and the only way to get past this is having a BIOS that enables memory remapping. I'm taking the issue up with ASUS at the moment, hoping for updated firmware that support memory remapping, I suggest you do the same with your motherboard manufacturer.
My System SpecsSystem Spec
15 Jun 2009   #9

windows 7

enable bios REMAP MEMOR function may be can fix this issue.
My System SpecsSystem Spec
16 Jun 2009   #10

Windows 7 Professional 64Bit SP1

i have the same problem with my pc. Windows 7 64bit 4gb installed 3.87gb usable, could this problem be due to overclocking?
My System SpecsSystem Spec

 Installed memory(RAM): 4GB (2.94GB Usable)

Thread Tools

Similar help and support threads
Thread Forum
Installed Memory 6GB but 2GB usable.
My computer's memory was 2GB and i added 4GB more, but only 2GB is usable. I have tried many time take the Ram out and put it back but i still have the same problem. Can anyone help me? Sorry my bad English.
General Discussion
all the installed memory (RAM) not usable??
I have a Evga X58 MOBO w/ the i7 proc and 6 gb of ram and now that i have win 7 installed its saying Insatalled memory (RAM) 6.00 GB (2.49) usable. ???? now does that mean that its only registering 2.49 of RAM and if that is so how do i get it to read all my RAM??? when i had vista installed on...
Hardware & Devices
Installed memory (RAM): 4.00 GB (3.75 GB usable)
I have Windows 7 Ultimate 64 bit, and I was wondering why my computer tells me that 3.75 GB out of 4 GB of installed RAM is usable. I've tried unchecking "Maximum Memory" under boot using msconfig, but it didn't change anything. I know its a pretty small thing, but please help.
Hardware & Devices
1GB Installed memory, only 1gb usable.
I have looked in several forums, including this one. and every option i have found. dont help me so much ;( I have also checked the BIOS . but there is no place where i can dissble " Dram over 4Remapp" or something like that. everything i can think of i have checked. I know 32bit can't...
General Discussion
Installed/usable RAM memory?
When I check System Properties, it says Installed memory (RAM): 4GB (2.75GB usable). When I check Task Manager, it also shows me 2814MB Total physical memory. I am using Windows 7 RTM x86. How can I get all of my installed RAM working? I googled a bit, found out something about memory remaping...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:28.
Twitter Facebook Google+