Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Any Hard Drive is Write-Protected

22 Mar 2010   #11

Windows 7 Enterprise x64

What's the make & model of the HDD? Have you checked the manufacturer's website to see if it's a firmware problem? If there's a firmware update for it, chances are that's what's causing it.

My System SpecsSystem Spec
23 Mar 2010   #12


This started happening to me after I upgraded my motherboard and CPU to a Biostar Tpower I55 and a Core i5-750 a couple weeks ago. I did reinstall Windows 7 Ultimate x64 and I enabled AHCI on the new board. Aside from the drive that has the OS I have 2 more internal HDDs, a Maxtor Y160P0 and a Maxtor L200P0, and an external HDD via eSATA, they are all write-protected every time I turn my computer on, if I unplug the eSATA cable and plug it back in it will usually allow me to write to the drive.
My System SpecsSystem Spec
19 May 2010   #13

Windows 7 x64
Quick thing.

I was having the same problem with portions of my hard drive, I figured out it wasn't my external that was write protected but portions of my laptops internal rather. I figure that certain areas like, My documents and such are protected. To get around this I simply copied the files to the desktop, once there i was able to access them or copy them over to my external at ease. I haven't had a problem with this since, I also just delet the desktop copy once I transfer it over. Maybe this can help you all and maybe not, but it helped me.

Also, when moving files WITHIN its respected drive haven't been limited. If you can't even create a new folder on any of your drives your having trouble with, this won't help sorry.
My System SpecsSystem Spec

31 May 2010   #14

Vista & 7

here is the FIX for the Write Protected USB devices
Change this key if set to 1 back to 0
KEY= HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\StorageDevicePolicies\WriteProtect

Thumbscrew: Software USB Write Blocker

Hope this help's you all guy's :)
My System SpecsSystem Spec
20 Jul 2010   #15

Windows 7

I followed the instructions listed (Windows Write Protection ŧ T3CHWORKS) and everything seemed great, it listed 5 drives the last being the only "removable" one listed which is the one I'm having the write protected issue with. Now I did everything listed and it even said that the read only status was cleared successfully, yaaaay! But when I tried to put the files I want onto the drive it still says its write protected, and now when I go into CMD and follow the exact same instructions I followed not five minutes before, it only shows that I have two drives now... I don't understand. Any help?
My System SpecsSystem Spec
21 Jul 2010   #16

Windows 7 Home Premium 64-bit

Can you post the output of your diskpart commands? If you did not save it, just get into diskpart and do list disk and list volume for now. Not sure what could've happened...
My System SpecsSystem Spec
01 Aug 2010   #17


Hi... thatīs is happening to me too. If I apply the 'Diskpart' solution it works but when I restart the system the problem comes again. The hard drive is attached to the MoBo via a eSATA conection (so itīs not an USB drive)

I have dual boot (same OS, but one with problems and the other fresh) and with the old system I donīt have any problem.

Any definitive solution?

Thanks in advance!
My System SpecsSystem Spec
02 Aug 2010   #18

Win 7 x64 Ult

Quote   Quote: Originally Posted by Informativos View Post
Hi... thatīs is happening to me too. If I apply the 'Diskpart' solution it works but when I restart the system the problem comes again. The hard drive is attached to the MoBo via a eSATA conection (so itīs not an USB drive)

I have dual boot (same OS, but one with problems and the other fresh) and with the old system I donīt have any problem.

Any definitive solution?

Thanks in advance!
This is pretty much my exact situation.

SSD Drive for OS, and Raid 0 drives (obviously connected to Mobo) for storage. I can use the diskpart when I boot up to get it to work, but it is annoying to have to type every time. Not to mention my wife uses the computer from time to time and there is no way she would be comfortable typing that in every time to use the computer.
My System SpecsSystem Spec
17 Dec 2010   #19

Windows 7 Ultimate x32

Quote   Quote: Originally Posted by naydencho View Post
FYI, it seems the link changed, but the solution still works! Here is the update to the link Sintek posted (thanks!)

Windows Write Protection T3CHWORKS -

And here is an exerpt of it, in case it changes again:


Start > Run "cmd"
type--> diskpart
type--> list volume
type--> select volume #
type--> attributes disk clear readonly

Thanks to the owner of T3CHWORKS!
Man I cant thank you enough ... u saved the day .. thanks mate ... greetings from Pakistan !!
My System SpecsSystem Spec
22 Dec 2010   #20

Operating System: Windows 7 Professional 64-bit (6.1, Build 7600)
Media on disk?

I have had similar experience and found that due to having a large media library in the hard disk in question, my issue was not what i previously thought.

The Windows media player was set to re-organize and or rename files according to my Rip disk settings; This acts like a write protect function if any write-protected media is present. and crazy as it sounds that will cause you to get the "Remove Write Protection" error telling you that disk or volume is write protected.

what i found to fix this was to remove the settings in media player allowing it to re-organize and rename files, after which i went to the tools/advanced/restore media library and allowed it to dump my current library and reset it.

after doing that it is often accessible, if not then try a reboot to clear the settings, or use the DISKPART functions to clear the write protection.

I giggled to myself when i started doing google searches and found soooo many old posts that were also in vista forums about the same kind of thing, that were probably the same fix.

I would be interested to know how many find this to fix the issue for them btw:)
My System SpecsSystem Spec

 Any Hard Drive is Write-Protected

Thread Tools

Similar help and support threads
Thread Forum
Unable to run chkdsk hard drive write protected
Please help Unable to run windows on any mode normal or safe when running in prompt mode and ask it to run chkdsk it gives me the following the type of file is NTFS, Cannot lock current drive, Windows cannot run disk checking on this volume because it is write protected. Have tried hard drive on...
Performance & Maintenance
Flash Drive Write Protected
can anybody sand me a link where i can follow the steps on how to make my flashdrive remove the "write protect" error.
Hardware & Devices
USB drive is write protected.
Hello all. I need your help. I have a USB drive and it is write protected. I cannot format it with windows advanced boot option, I am not able to change the registry value for storage policies even. I have tried multiple PCs to format it. No luck Please help is imp. Thanks.
Hardware & Devices
write protected pen drive
i have a 4gb pen drive which is not formatted it shows that "this disk is write protected " can anyone help me to format this disk.
General Discussion
Why are my hard drives write protected
Hi, everybody i have aproblem with windows 7 ultimate X64, at first everything worked fine but now when i boot up some of my hard drives ( not all ) are write protected and i can only remove the write protection with diskpart.When i boot up again the drives are write protected again,it is very...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 12:48.
Twitter Facebook Google+