Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Loss of NVIDIA Raid 1

12 Apr 2010   #1

Loss of NVIDIA Raid 1


This forum has been a remarkable resource in the past, so I thought I would again reach out for help for an extremely perplexing issue (before I cause damage by trying to fix it myself).

My AMD machine utilizes an ASUS M2N-SLI Deluxe motherboard, which includes an NVIDIA nForce 570 raid controller. When I installed Windows 7, the install was a fresh copy of Windows 7 Professional, and I properly installed the Raid controller. Specifically, I had two Western Digital 640 GB HDD in a RAID 1 configuration, and all was well until yesterday, when I logged in and saw double the number of disks that I should have. Of course, the double number was due to the fact that for some reason, my RAID 1 configuration broke down. Windows 7 was now recognizing the other drive as a brand new piece of hardware. Furthermore, when I start up the machine, the RAID controller screen that was typically part of the start up sequence has disappeared entirely.

My questions are:

1. How is it that my RAID controller has broken? I mean, how is it that the driver was somehow removed? Is this an act of some strange malware? I have Avast running, and it's never complained. But, I also have not made any significant system changes that may have lead to this issue.

2. What is the safest way to fix this? I would like to realign the disks into RAID 1.

As always, thank you for your help.

My System SpecsSystem Spec
12 Apr 2010   #2
not so gray matter

W7 Ult. x64 | OS X

Well I'd suggest that you reinstall the drivers for your raid. Go to this website and enter your model number in the search box on the top left. It should also be noted that when prompted, I didn't see an option for Windows 7. You may have to install your raid drivers in Vista compatibility mode.

ASUSTeK Computer Inc.-Support-

However, I don't know whether or not your first HDD's new information from booting after broken raid will hamper them rejoining into RAID 1. I'd wait for a more expert opinion.
My System SpecsSystem Spec
12 Apr 2010   #3

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE

I have no idea of what went wrong, except the possibility that one of the drives is defective in some fashion, even though it still appears in Windows. You need to determine which drive does appear in the raid configuration utility during the BIOS run and which doesn't. Obviously, the one that doesn't appear is the problem. I've not worked with your type of raid controller, but if it is like most, when you replace that drive with a working one, the raid utility should offer to rebuild the array or possibly do it automatically.

EDIT: Vaguely, it seems to me that Nvidia has a raid configuration utility called Media Shield in the Nvidia Control Panel. If so, perhaps you can figure out what is going on there.
My System SpecsSystem Spec

13 Apr 2010   #4


I will execute the ideas listed above and reply with the results. Thank you for your suggestions.

Also, I realize that this may require a different thread, but something else is happening with my system. I thought I would list it, as perhaps it is a related symptom:

For a few weeks now, my computer will 'lock up' sporadically for 30 - 60s. When I say 'lock up', I see the mouse cursor change to the circular ring, and I cannot change windows or perform any operations. If I remain patient, after 30-60s the circular ring disappears and the system becomes operational again. If seems to happen randomly without any discernable pattern.

Very bizarre. And I do not know if this is related to the above problem or if it is entirely different.

Anyway, I will look closer at the recommendations made above. If anyone has any ideas about what may be causing the frozen system, please let me know!

Thanks again.
My System SpecsSystem Spec
13 Apr 2010   #5

Windows 8.1 Pro RTM x64

Check the settings in your BIOS. By default, the system will run in non-RAID mode. This needs to be enabled in the BIOS.
My System SpecsSystem Spec
15 Apr 2010   #6


I followed your suggestions above and checked my bios settings.
Strangely enough, it appeared as if the bios settings were placed back into their default state. Again, very bizarre.

So I changed the settings back to a RAID configuration and performed a restart. Although the RAID screen again appeared during the start up sequence (and described the array as being healthy), the system did not start.

A start up error appeared, directing me to restart the system with the Windows 7 disk. I followed instructions hoping that I would be able to sucessfully perform a repair function, but I had no such luck. Essentially, the system is telling me that it is 'unrepairable'.

I even tried pulling out every peripheral and HDD, so that only the primary master was left plugged in, and the results are similar: it will not start.

A little more info about my configuration: it was a dual boot with XP. But now it won't even boot the XP partition.

From the boot menu, I can get to the start-up options page when I select the 'recovered' windows 7 partition, and I can select from safe-mode, safe-mode with networking, etc...

But whatever I select results in the BSOD, which describes some kind of error. If it would be helpful, I could take a camera shot of the BSOD and post it here. But it will likely look terrible.

Anyway, I would love to hear more suggestions. I am starting to think that I will need to do a reinstall, which I am seriously reluctant to do. To be honest, I am sick and tired of the bologna. I realize that this may be sacrilage, but I am very close to moving towards a Mac. I am tired of losing my money and time to microsoft.

Please save me. Don't make me turn to the dark side!
My System SpecsSystem Spec
15 Apr 2010   #7

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE

I get the feeling that you installed the systems while both sets of drives were connected (or on the same drive), thus creating a boot menu. This is something that I never do, so that if something goes awry in one OS, it doesn't effect the other.

As far as repairing the boot, I will have to defer to someone else with a better understanding of it.
My System SpecsSystem Spec
15 Apr 2010   #8


Indeed I did.
In fact, stupid as it may sound, Windows 7 was installed in a new partition of the same drive. Hence there were two drives in a RAID 1 configuration. One partition was XP. One partition was Seven. And the remainder was data.

The idea was that if one drive failed, I would obviously have an exact duplicate that would immediately step up. I have had drive failures in the past, so it sounded like a good idea to me.

But no worries gents...I also have all my data backed up on-line. Whew...

But still, I would prefer to avoid a re-install. It just takes too long to personalize the system and software.
My System SpecsSystem Spec
15 Apr 2010   #9

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE

Your reasoning has some merit, but when it comes to computers, I believe in Murphy's Law. Don't you have backup images...or did you feel that wouldn't be necessary either? In any case, someone here may be able to help you repair the boot.
My System SpecsSystem Spec
15 Apr 2010   #10


No images, but I did have system restores.
For some reason, the restore function is not working.

Perhaps in the future, I will need to look closer at performing backup images. But I really thought in terms of redundancy, that I was already being ridiculous. I guess not.
My System SpecsSystem Spec

 Loss of NVIDIA Raid 1

Thread Tools

Similar help and support threads
Thread Forum
Evening Internet Connection Loss -- Unable To Identify Source Of Loss?
I need your help!!! I got a real challenge for you! I am confused! I cannot locate the Internet connection loss source. Every night for the past 5 late evenings my Windows 7 Pro 64-bit has been losing my Internet connection on my desktop computer anywhere between 8 PM-12 AM (Last 3 nights: 11:05...
Network & Sharing
Power Loss To Notebook Shows Loss of Windows Activation (!!??)
I had a power loss while running on battery (it still showed power left, but suddenly shut down anyway) and when I restart, it reports that the Windows is not activated and Window is not genuine and system might be a victim of "counterfeiting." Is this a virus (I have MSE on continuously and...
Windows Updates & Activation
RAID - deleted RAID array, Windows 7 ok but I have questions
Hi all, My RAID 1 (I think? I have two equal drives that are mirrored) array was causing me a lot of pain. It kept freezing up my system and having me to had to rebuild the RAID too often. After a number of tests and browsing info online, I've decided that the RAID was the culprit of the freezing...
Hardware & Devices
Win 7 raid 0 setup / missing raid controller driver
Installed a new M4 ssd today and loaded windows on it. Previously i was using 2 raptors in raid 0 for the os and programs. I re raided the 2 raptors and connected them to the jmicron ports and set them up for raid in bios, then created the raid 0 array no prob. Windows doesnt see the array when...
RAID 5 switched from single storage to raid 5, lost drive letter
I am running 7 pro 64bit on a ASUS p8p67 deluxe mobo and I copied all data from my 1tb storage D: drive to a backup external and proceded to install raid 5 with 3 single 1tb drives and the raid is up an running. However using Intel Rapid Storage Technology to setup the raid inside windows I had to...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:47.
Twitter Facebook Google+