Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: My computers only detects one Processor.

14 Apr 2010   #1
MichaelMarr

Windows 7
 
 
My computers only detects one Processor.

The problem is that my computer is only detecting one processor when i have two I have a HP Pavillion s5306uk desktop computer and I am running windows seven x64.

I changed settings in MSConfig under the advanced boot menu to 2 processors at startup and now after a restart It is only detecting one.

I went into Device manager and there it is showing two installed CPU's but in task manager only one is shown again.

If anyone could help me fix it so it shows two again I would be appreciate it very much.

Thanks.


My System SpecsSystem Spec
.
14 Apr 2010   #2
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Changing the setting in advanced boot is in vain. That setting is for H/W testing purposes only. How did you determine that only 1 core is being used ??
My System SpecsSystem Spec
14 Apr 2010   #3
MichaelMarr

Windows 7
 
 

I know i shouldn't have done that I wanted to make the boot time faster so i googled ways to improve windows 7 performance and i read that doing it improves the loading time. I found it out that it is only showing one because I have a desktop gadget that shows the CPU usage and usually it has two displays and now it has only one, also in task manager under the performance tab before there was two sections to it where the screen was split in half showing each CPU and now it only shows one.
My System SpecsSystem Spec
.

14 Apr 2010   #4
CommonTater

XP Pro SP3 X86 / Win7 Pro X86
 
 

Quote   Quote: Originally Posted by MichaelMarr View Post
The problem is that my computer is only detecting one processor when i have two I have a HP Pavillion s5306uk desktop computer and I am running windows seven x64.

I changed settings in MSConfig under the advanced boot menu to 2 processors at startup and now after a restart It is only detecting one.

I went into Device manager and there it is showing two installed CPU's but in task manager only one is shown again.

If anyone could help me fix it so it shows two again I would be appreciate it very much.

Thanks.
Been in your BIOS lately?
I'm guessing that you have hyperthreading support disabled.
My System SpecsSystem Spec
14 Apr 2010   #5
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Have a look at this. Maybe changing the BIOS setting will help: How to Activate a Dual Core Processor | eHow.com
My System SpecsSystem Spec
15 Apr 2010   #6
MichaelMarr

Windows 7
 
 

Quote   Quote: Originally Posted by CommonTater View Post

Been in your BIOS lately?
I'm guessing that you have hyperthreading support disabled.
I am not a very advanced computer user and I have never modified/used any BIOS settings before so i apologize if i am coming across as annoying with my lack of knowledge on this.




Quote   Quote: Originally Posted by whs View Post
Have a look at this. Maybe changing the BIOS setting will help: How to Activate a Dual Core Processor | eHow.com
Thanks for getting this for me whs but I don't have an installation CD, I bought the PC from PC World and I didn't recieve one. And as for the BIOS as i mention above I am not familiar with any of it and don't want to go into it incase i cause any further unwanted damage, Sorry again if I am annoying you at all.
My System SpecsSystem Spec
15 Apr 2010   #7
squall leonhart

Windows 7
 
 

Check the Computer item in device manager and post whether it says uniprocessor compatible acpi system or multiprocessor...etc
My System SpecsSystem Spec
15 Apr 2010   #8
Bill2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Try forcing windows to redetect your dual core. See the tutorial below (its for vista but should work for win7 also). Its very simple.

Force Windows Vista to redetect your dual core CPU

Edit: Doesnt work with Win7 RTM
My System SpecsSystem Spec
15 Apr 2010   #9
squall leonhart

Windows 7
 
 

is that a setting that only appears if you change the core count? because its not present on windows 7 for me :|
My System SpecsSystem Spec
15 Apr 2010   #10
Bill2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

leonhart is right. Detect HAL was there in the earlier builds but its gone from win7 RTM.
My System SpecsSystem Spec
Reply

 My computers only detects one Processor.




Thread Tools




Similar help and support threads
Thread Forum
Win7 Detects i7 instead of i5
hi guys, i have just noticed that on my DELL work PC, win7 detects that i have an i7 3540M but i am pretty sure that it's an i5, always had... i had a look in the BIOS and it detects i7 at the moment, even just upgraded BIOS to the latest from Dell's website, really weird.. i am just worried...
Hardware & Devices
Window 7 detects too many monitors?
This is weird. I have 2 monitors & 2 graphic cards. Recently I changed the 2nd monitor to a DVI connector. I have Display Fusion installed & noticed when I sent a window to the other monitor it disappeared! I checked Control Panel/Appearance & Personalize/Screen Resolution & Windows 7 now detects 3...
Hardware & Devices
HELP!! x64 bit OS detects only 3.25G ram out of 8G
HELP! I don't know what the heck happened! Just a few days ago my win7 HP was working PERFECTLY and it was detecting all of my 8Gb of DDR3 @ 1333 Mhz and now... it says ONLY 3.25Gb Usable! WHAT THE HECK!! Please help me resolve this problem all my ram bars are working perfectly, my...
Hardware & Devices
Installed CCC 11.1, detects as 10.5
After I installed CCC 11.1, CCC and gpu z detects it as 10.5. I uninstalled 10.12 before I installed 11.1
Graphic Cards
Is a computers processor important for running multiple games at once?
Hey Seven Forums. I'm not that great with computers so I thought I would ask you guys for help. I am currently thinking about purchasing this computer: Newegg.com - iBUYPOWER Gamer Extreme 556D3 Phenom II X2 555(3.2GHz) 4GB DDR3 1TB NVIDIA GeForce GTX 465 Windows 7 Home Premium 64-bit The...
General Discussion
Adobe detects W7 as Windows NT
If you go to www.adobe.com and click on the button Download Adobe Reader, instead of taking you to Adobe 9 Download page, Adobe will take you to Adobe 7 download page for Windows NT! It appears adobe is unaware yet that a new OS has been released, or it's not that dynamic as expected to detect...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:30.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App