Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Strange error with Buffalo USB Adapter

19 Apr 2010   #1

Windows 7 Ultimate 64-Bit
Strange error with Buffalo USB Adapter

Hello all,

I've recently started using Windows 7 (Ultimate 64-Bit) and am having problems with my Buffalo WLI-U2-KG54-AI wireless LAN adapter that I use to access my router (and thus the internet).

The adapter has the software & drivers built into it so you are supposed to be able to plug it in any computer and it sets itself up. The installation does not complete under Windows 7 and I had given up hope of using it believing it simply was not compatible.

However, here's the strange part...
The adapter is recognised as a CD-ROM drive under Windows 7 (I'm guessing due to the files stored on the adapter).
When I connected to the internet (via ethernet link) the initial Windows Updates installed support for the adapter and it was then detected perfectly as a Network adapter and allowed me to connect wirelessly.

I switched the router off to move it back away from the computer (so I could use it wirelessly), but then Windows could not find the network again! Thinking there was a problem with the adapter, I safely removed it and plugged it back in.
Windows then recognised it as the CD Rom drive again and I can't get it to find it as a network adapter!

In the list of updates installed I can see the following;
Ralink - Network - BUFFALO WLI-U2-KG54-AI
Which says it is an 'Important' update and that it is installed successfully.

Thinking that maybe I could try reinstalling the update, I went to the uninstall updates screen but it is not actually listed there!

Can anyone suggest a way to get the adapter working?
It's very frustrating that it worked perfectly for a little while so I'm thinking it should be able to work on Windows 7.

My System SpecsSystem Spec
19 Apr 2010   #2
not so gray matter

W7 Ult. x64 | OS X

I take it you've attempted to uninstall the update through both methods mentioned in this tutorial?

Windows Update - Uninstall an Update

From all of the data I can find on the web, this device isn't supported in Windows 7. That's probably part of the reason that it's acting so oddly. Someone around must know of a method for uninstalling updates that aren't listed, but I can't seem to find a method for you.
My System SpecsSystem Spec
19 Apr 2010   #3

Windows 7 Ultimate 64-Bit

Thanks for the quick reply.
I'm away from my PC at the moment so I will make sure it is not possible by both methods later.

It might be that the device is not fully supported and as such, very temperamental anyway.

It does seem odd that you cannot uninstall some updates!

* EDIT > Both methods actually bring you to the exact same screen and the network adapter update is not listed for uninstallation.
My System SpecsSystem Spec

06 Aug 2010   #4

Windows 7 64-bit

I had the same problem. There's a little switch on the side of the device and when you flick this the device no longer acts as a CD-ROM device and is recognised as a WiFi adaptor. I am running Windows 7 Ultimate 64-bit with this adaptor no problems now.
My System SpecsSystem Spec

 Strange error with Buffalo USB Adapter

Thread Tools

Similar help and support threads
Thread Forum
x64 WLAN-adapter drivers (Buffalo)
Hi! I succesfully installed Win 7 x64 today to my new computer, but the problem is that I don't find or have drivers for my USB WLAN-adapter Buffalo WLI-U2-SG54HG. I tried to find Vista x64 drivers, but without success. Do I have to change my OS to x86 or buy a new adapter?
Buffalo CD/DVD drive
I purchased one of these to replace a non-working internal one on my Acer Laptop. Does anyone know where I can get a Manual. In Particular I want to know how to play a CD which already contains normal photographs. The Buffalo has lots of menu options connected with burning a CD/DVD but...
Hardware & Devices
Strange PC behavior with network adapter
Hi all, I've had windows 7 for about a year now on my PC and it has been running reasonably smooth. For the first time a few days ago, I connected to a LAN with someone running win xp which worked wonderfully. I disabled my network adapter in Network and sharing center, and since then I...
Network & Sharing
WiFi Miniport Adapter/Adapter #2 Error
I just bought a brand new Asus K52F and when the laptop goes into sleep mode the "Microsoft Virtual WiFi Miniport Adapter & WiFi Miniport Adapter #2" fail. When i turn the computer back on i have trouble connecting to the internet, and the devices have error (code 43). I can still connect to the...
Drivers for Buffalo adapter
Hi, I am searching drivers for Buffalo AirStation Wireless-G usb adapter. Model is WLI-U2-KG54L. I'd really appreciate it if someone would help me to find it for Windows 7 32bit :cry:

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:45.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App