Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: AHCI SATA disk E: suddenly DISAPPEARS (auto-ejects..?!)

25 Apr 2010   #1

Windows 7 Home Premium x64 OEM EN GRMCHPXFREO_EN
AHCI SATA disk E: suddenly DISAPPEARS (auto-ejects..?!)

I have been using XP for many years, now I'm building a pc for the son of a friend of mine, with Windows 7 x64.

I decided to go for a Corsair P64 SSD for (C:), and a 1 TB WD Caviar Black for (E:).
I connected first the SSD and installed Windows 7,
then after I had installed drivers through auto-update and a few other programs,
I connected the WD E: drive also, and moved the
C:\Users\username\Downloads\ folder into

The issue is that once in a while, I suddenly notices that the E: drive has disappeared.
The first time I noticed it was after I had uninstalled Java JRE6 u19 and tried to download u20.
Then I noticed that the file was instead downloaded to the desktop.

I clicked the
Favorites > Downloads (which is mapped to E:\Downloads)
to check why it wasn't downloaded there, and then I got the error

This file does not have a program associated with it for performing this action.
Please install a program or, if one is already installed, create an association in the
Default Programs control Panel."

I checked the both Device Manager and Disk Management
- no 1TB WD disk, no (E:) volume

So I clicked Start -> Shut Down -> Restart,
and when into BIOS, and the E: drive was visible there.
Then I exited BIOS and loaded into Windows 7 again,
and the E: drive was back again.

This has happened 3 times after this, over the last 4 days.
If I just restart Windows, it comes back, with no signs of it ever being gone.

I have tried looking at the Event Viewer logs...
..I believe the Windows Logs are OK.
But about those Applications and Services Logs.. wow.. there are a lot of services..
..I have checked the 3 DiskDiagnostic* at least, those are empty.

When the drive has disappeared, the icon for the Favorites > Downloads folder becomes all white.
I examined the C:\Users\username\Links\Downloads.lnk shortcut,
the "Target:" field was all blank.
Then I copied the Downloads.lnk to C:\temp, renamed it to Downloads.txt
and when I opened it, I saw that it was still pointing to the original
C:\Users\username\Downloads\ folder.
Also, the C:\Users\username\Links\Downloads.lnk shortcut file still has the
time created / modified / accessed from the original Windows 7 installation.
So I assume the moved of the
C:\Users\username\Downloads\ folder into
does not affect the actual shortcut - instead a registry value, I'd guess?

Another thing - since I have two computers side by side now,
the new one that I build have once and again gone into "sleep mode" since
I am busy using the old (my own).
I was thinking maybe there is a kind of "power saving" thing,
that Windows 7 turns off the power to the E: drive since it has been so long since
it has been in use.. and for some strange reason, it doesn't manage to get it back on-line
without a restart of the OS itself.

Hmm.. what's more:

The Corsair SSD disk has two volumes, first is a 100 MB hidden boot volume it seems,
then the rest is the C: volume.

When I look at the registry, I see


\REGISTRY\MACHINE\BCD00000000 = \Device\HarddiskVolume1\Boot\BCD
\REGISTRY\MACHINE\SAM = \Device\HarddiskVolume2\Windows\System32\config\SAM

So I would guess that there existed a HarddiskVolume3 that was the (E:) volume on the WD disk,
but when I search for this in the registry, there are no results.

When the WD disk is online, and I go to the Disk Management,
Disk 0 = Corsair P64 SSD, with 100 MB boot volume and 59.93 GB (C:) volume
Disk 1 = WD 1 TB, with 931,51 GB (E:) volume


I remember when I had connected the WD disk and started Windows,
I got a message telling that I had to initialize it, and if I would do that now.
I chose no, because.. hmm.. I don't recall..
..but a few minutes later, I went to Disk Management,
and then - either
- before I initialized the WD disk, or
- after I initialized it but before I formatted it, or
- after I initialized it and after I formatted it,
- I noticed that it was the opposite:

Disk 0 = the WD disk, maybe initialized / formatted or not
Disk 1 = Corsair P64 SSD, with 100 MB boot volume and 59.93 GB (C:) volume

I remembered I was thinking
"Oh no.. how could this happen? I hope it won't cause any troubles..
..Hmm I wonder if this is because I had that USB drive inserted while I installed Windows 7.."

I had to update the ASUS P7P55D-E's BIOS because of the Core i5 660 was so new,
and I did this using the USB drive, and then I forgot to remove it before I started installing Windows 7.

I don't know if this has any relevance at all - I just thought I'd mention it.

I guess the "obvious" solution to try would be to reinstall Windows 7 and all the other programs..
..however, since I'm not getting very much payment from this, I'd like to not having to do that..! :cry:
In fact, I have already told my friend she could get the pc very soon now,
so I'm thinking I should just leave it as it is, and tell him (her son)
to just restart Windows if he sees that the (E:) is gone.

But - then I thought -
"Maybe some other people in the Windows 7 Forums have experienced / heard of something similar..?
I'd guess it's worth a try.."

BTW: I have built 10+ pc's with XP and installed XP at least twice as many times,
but this is my very first experience with Windows 7
(and Vista, I have only used for a few hours on a friends laptop)

I noticed the "Safely Remove Hardware AND Eject Media",
which (usually) lists both the Corsair SSD and the WD disks.
So, could it be possible that the WD disk is somehow suddenly auto-ejected?

When I open "Devices and Printers" I see there are a difference between them:

The WD disk has an additional "AutoPlay" > "Local Disk (E:)"
while the Corsair does not have any AutoPlay at all.

I know there exists a programs that can hide disks from the tray menu;
"USB Safely Remove" made by a company called... "Safely Remove" (lol!)
- I was wondering if I should try installing that and hide both disks
since the user in question will have no need for ejecting them anyway.

So - if any of you have bothered reading all this - do you have any ideas about
the reason for the disappearing disk - or any tricks that I may try out..?

My System SpecsSystem Spec
25 Apr 2010   #2

Windows 7 Home Premium x64 SP1

Hello and welcome to SevenForums. I will throw a few ideas in, however, I'm pretty sure a better guru will come to your help in more details.

The first thing you said that I really don't like, is, that you installed the drivers that were in Windows Update. I wouldn't do that. I would download all needed drivers from the manufacturer's website. I'm pretty sure what drivers you know what drivers you need (especially re-install the chipset driver).

If I missed something, tell me, your post was hard to follow.

Second thing, I would try another mode instead of AHCI in the BIOS just to see if the problem occurs or not.

Third, for your "Sleep" problem, that feature is really buggy. In Power Management options in the Control Panel, I would simply modify the current settings and put Sleep to "Never".
My System SpecsSystem Spec
25 Apr 2010   #3

Windows 7 64bit RTM

I've had a similar problem recently with a Western Digital drive .. a Blue 500GB .. which actually ended up dying after 5 days of use! .. It dissapeared from the BIOS and stopped spinning up whatever I tried , nothing got it going again! I ended up sending it back and getting a replacement which is behaving so far ..

Also I believe you must use the 'Initialise' feature you mention before you format the drive .. maybe this is your problem.

Have a look here too ..

[Solved] Windows 7: Hard Drives Disappear after Sleep Resume - general-discussion - windows-7 ..
My System SpecsSystem Spec

25 Apr 2010   #4

Windows 7 Home Premium x64 OEM EN GRMCHPXFREO_EN

Thank you for your answer!

Of the 3 different possible fiixes you provided,
I chose to start with the "sleep" tweaking, since that is what I considered the most unobtrusive one..

Regarding the drivers - yes, I always used to download drivers onto a CD-R before I installed XP.
Started with the Intel Chipset drivers, then network adapter, audio card, graphic card..
Since I never paid for any of those XP's, I also always turned Automatic Updates
completely off.
But since all the anti-ware had become so widespread, it seems the malware writers
now instead tries to use 0-day exploits more and more.
So last autumn I downloaded the fixed WGA from DS9 and started using Windows Updates..
BTW, I used anti-virus, Norton, back in 2003. But then I turned it off.
Since I used IE, I got a lot of malware through ActiveX.
Then I restarted in Safe Mode, and examined the files and saw what other files they were
linked to, and what registry keys / values they were using.
Then I could manually remove all the traces of the malware.
I got a new malware attack - usually at least 3 different in the same round - ca once every 14 days.
So I used those attacks to learn more about malware.
Then after 6 months or so, I became bored with it, since I saw they almost all used the
same techniques;
some files in system32, a new string value in either of the 2 HKLM/HKCU "Run" keys..
So I changed my browser to Firefox.
After this, I have only got two attacks.
The first one came through JavaScript, while the other, I know it came from a certain webpage, but I didn't find out what actually happened.
The last one was more hard to get out, it created a service that would also start in Safe Mode,
so I had to use a Linux Live CD to delete the files, then I could go into Safe Mode and fix the registry too.

OMG this was way off topic..
The point was that - while in XP, I stopped using anti-virus many years ago,
and I didn't start using Windows Updates until very recently.
When I started using WU, I was surprised over how well they worked this time,
since I tried using it many years ago, on a laptop of a friends friend that I should fix,
and then it completely broke - I just had to reinstall Windows.

Since my "client" this time said she wanted a Windows that her son could use without any worries,
she gave me also the cash for buying the Windows 7 HP OEM.
(The first Windows I have paid for since the 13 floppys for Windows 95 that I bought Sep-95)
So since this was a legal Windows and everything, I thought "Ok, this time I'll see what the 'OOBE' is like",
and therefore I plugged in the network cable even before I inserted the Windows 7 DVD..!
Also I had read that the Windows 7 DVD itself included a lot of drivers,
so I figured that the WU would only have to download maybe a couple extra.

And this seems to be true:
By looking at the Windows Update > View update history,
it is only NVIDIA Geforce driver and "ATK - system - ATK0110 ACPI Utility"
that was installed through WIndows Update at first.
That is, both failed the first time, after a restart,
the "ATK" was successful, but the Nvidia driver "failed" again,
and then when I started WIndows Update the 3rd time, I exmined it,
and saw that the driver date was September 2009... I instead sat that update to be hidden, and manually downloaded and installed 197.45.
Then, when all the "Important" updates were done, I switched to "Optional"
and then an update for the Realtek PCIe Gigabit Ethernet controller was downloaded and installed,
and then a driver for the BenQ LCD monitor.

After this, I looked at Device Manager, and there was one thing left;
the NEC USB 3.0 controller - for that one, I downloaded the driver from ASUS and installed it.

So apparently, the Windows 7 DVDs must include:
driver for the Intel P55 Express Chipset
driver for the Realtek 8112L GBE LAN controller,
driver for the VIA VT1828S High Definition Audio codec chip
driver for the VIA VT6308P IEEE 1394a chip
driver for the Nvidia Geforce cards (190.38 dated 07/14/2009, same as Windows 7 itself)

Therefore, if I should have done it "the XP way", I would have had to
slipstream drivers downloaded from ASUS and NVIDIA into the Windows 7 DVD image..
..or maybe it is possible to tell the installer to not use any drivers included on the DVD at all..

Then - about the AHCI -> IDE, I remember reading that doing a switch between these on XP could possibly render the disk unreadable.
It seems it is possible to do on Windows 7, at least going from IDE > AHCI
is mentioned somewhere (KB from MS?)..
- that you had to set the registry so the AHCI drivers was installed / loaded,
since you were in IDE, they were not installed / loaded,
then reboot, still in IDE, so the AHCI drivers were installed / loaded,
and then finally you could go to BIOS and change into AHCI.

So - if the "stop sleep" technique doesn't work, the AHCI > IDE will be the next thing I try..!

Back to the "stop sleep":

I made a new Power Plan setting, based on the "High Performance" plan.

I edited these settings:

Hard disk > Turn off hard disk after > Setting: Never (by entering "0")
Sleep > Allow hybrid sleep > Setting: Off
USB Settings > USB Selective suspend setting > Setting: Disabled
Display > Turn off display after > Setting: Never

Also, I remembered that after I had connected that WD drive,
I hadn't yet done a hard shut down - by using the PSU's switch to cut the power completely,
so I also did that.

Now I just cross my fingers and hope that this will fix the issue. :)

I have installed Lavalys Everest, and using that I can see all of the entries from all the different Event Logs windows at once.
It makes it easier to see every event that was logged in a certain time-frame.
Then I'll set up an alarm that goes off every 60 minutes to remind me to check if the WD drive has gone offline.
So if it does, I can just look at the Event Logs for the last 60 minutes.

@Pikey: I did an initialize, then a quick format. The drive is usually 100% ok,
I have used it a lot already, for downloading files and pasting in files / folders from my own pc which is connected in the LAN.
I hope the drive isn't as bad as yours - though - if the problems still continues,
it would be an idea to connect it to my own pc, and see if the issue continued there..
..if it does continue, then it must be something bad with the drive itself.
I'd do a full format, then try it some more, and eventually RMA it if the issue continued.

But I have a "feeling" that the issue is related to the "sleep" feature.

The disk is an ATA8-ACS which means it has 4 power modes.
The default Windows 7 power scheme is set to "Turn off hard disk after: 20 minutes".
I'm not exactly sure what this means..

It suppose it could mean either

a) "Turn off all harddisks - at once - after 20 minutes of user inactivity"
b) "Turn off only the system harddisk after 20 minutes of user inactivity"
c) "Turn off any harddisk that has not had any reads/writes for the last 20 minutes"

In the case of c) - I would guess that this situation would never happen,
since there always seems to be at least some disk activity
- at least on XP, according to monitoring software like Process Monitor and Disk Monitor (from Sysinternals).

In the case of a) - which I believe is the correct one - maybe Windows 7 goes like this
"Ah.. 20 minutes have passed, no user activity, I'll have to turn off the disks to save power."
Then - since my C: volume is on an SSD disk - maybe it does react somewhat different to the power state change than the WD disk.
And then when I press a mouse button to get it out of sleep mode,
maybe Windows sees that the C: drive is not powered down, and then it goes like this
"Hmm.. didn't I tell that drive to power down? Oh well.. I'll just forget about the change back to power state S0 / D0, then.."
And so the poor WD disk, which actually did follow the order of giong into S3 / D3 power save mode,
never gets the "wake up" command since Windows doesn't think it's needed..!

I guess - this is probably not the way it actually works, though..
I know very little about power saving because I have never owned a laptop,
and I always turned that Power Save feature off whenever I installed XP.


Ah - I see!
A Hotfix! I'll try that one and set it back to the default "Balanced" power plan
so I can verify if it works - it would be the best if he could choose for himself whether to use sleep or not..!

Thank you very much!! I hope it works!
My System SpecsSystem Spec
26 Apr 2010   #5

Windows 7 Home Premium x64 SP1

I'm happy to see that you are on the road to your solution. That's good!
Give us news if it works and if it solved the problem!

My System SpecsSystem Spec
26 Apr 2010   #6

Windows 7 64bit RTM

This is my first experience of using a SATA drive , so I was a bit disappointed when the first drive went down .. especially after using 2 IDE's from Western Digital in the same PC (80G and 250G) which have been motoring along quite happily for several years now!!

So much for plug-n-play .. I forgot to mention by the way that the dead drive didn't spin-up even with a USB to IDE/SATA convertor which I bought especially for the job ..

I also posted my problem over at the WD support forum .. but nobody answered sadly ..

Western Digital Community - Western Digital Community ..

Good luck with it ..
My System SpecsSystem Spec

 AHCI SATA disk E: suddenly DISAPPEARS (auto-ejects..?!)

Thread Tools

Similar help and support threads
Thread Forum
External Hard Disk Self Ejects
Hi, I have Windows 7 Professional 64Bit installed on a 250GB internal hard drive. I also have a 750 GB secondary drive installed in the system. When I connect an external hard drive to the computer and try to transfer some files (in this case a Windows 7 SDK DVD iso), the external hard drive self...
Hardware & Devices
plugging old SATA hard disk in AHCI system
My current system is running Win7 with SATA configured as AHCI. I have an old desktop running WinXP but with SATA configured as IDE. May I ask : Is it safe (in terms of data reliability) to plug the old WinVista HD in the current system for retrieving data files ?
General Discussion
Changing from SATA RAID to SATA AHCI - Help needed!
I could really use some help with this. I have a HD that I'm moving from one Windows 7 machine to another. The new system is a Gateway DX4860. The old was was also a Gateway DX4820. When I put the old drive in the new computer, I get the Windows Splash screen, the stars begin to appear...
Hardware & Devices
sata ide or ahci
Hi guys I was told by a friend that changing the sata settings in the bios from ide to ahci can help improve performance so i did.Windows loaded installed the drivers and asked for a reboot which i did all fine. Stupidly it was only then that i decided to look into it and apparently your...
Performance & Maintenance
Intel Sata controler ICH10R AHCI + Jmicron AHCI error
Hi. I have the GA-EX58-Extreme Board and have just installed the pre release of Win7 7600 64 bit. Normally i have experience to get the BSOD when in staling with AHCI active in bios so i change to IDE mode. Installation went flawless and also the change to AHCI mode on Intel ICH10R controler...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App