Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Usb flash drive or pendrive problem

19 Sep 2009   #11

Windows 7 Ultimate

Hi all.

I've signed up just for this topic and to try to help as I've been having the same USB drive problems as described in many of your posts..

My 2GB Freecom USB flash drive has always worked, never had an issue and never needed to format etc. I've recently installed Windows 7 and my stick was starting to give me the stick .

I could read, run and delete files from the drive.. but when it came to writing to it it nearly always failed. It would last about 2-3 seconds and then freeze up. Around a minute later, my computer would tell me that the drive is either no longer connected, or that there was an error copying etc.

If I looked into 'my computer', the stick would still be shown.. even after I pulled the stick out of the machine's front panel.

I went through my bios to see if there was any USB options and there was only one.. "USB Legacy Support" or something along them lines.

With my old setup, I had to disable this in my bios as it was causing problems with my external drives.. but I thought 'what the hell' and enabled it again.. just in case it was causing problems.

Since then, my stick has worked fine.

I'm on Windows 7 Ultimate 64-bit, you can check my full spec on my profile or where ever it shows it (i entered it at registration).

Just thought i'd post incase this helps.

Maybe play with this setting? Look in your bios for options to do with USB legacy and either disable, enable.. edit the settings.. anything. Just try it out.

I just wanted to post because small things like this can really annoy you, I spent just over 1200 on my current setup and it's horrid to think something isn't working regardless the same thing works on my 200 machine standing next to it.

Hope this helps.

My System SpecsSystem Spec
19 Sep 2009   #12


First, Welcome to the forums. Thanks for posting this information, I'm sure you will end up helping many users with the same issue.
My System SpecsSystem Spec
19 Sep 2009   #13

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)

Welcome acer0169,

Many thanks for your post. Yes sometimes the least expected little things solve the problem. Thanks for posting your specs. Very nice setup for your rig

Hope you enjoy learning & helping here at SF

" Doc "
My System SpecsSystem Spec

19 Sep 2009   #14

Windows 7 Ultimate

Thanks both for the welcome :).

Just to burst the bubble (and probably make a horrid name for myself ) this fix isn't really.. well.. a fix. It seems more stable now, but on files over 50-odd meg is still has the same problem.

The computer freezes, music playback etc stops. I need to restart to have things working again.

Even with my rather good setup, once the flash drive error occours, I get a slugish response from pretty much everything I do.. making a restart almost indefinite.

I'm still working on this issue, and will post when I solve it (Y).

Sorry to cause problems :$.
My System SpecsSystem Spec
19 Sep 2009   #15

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)

We do a lot of Trial & Error Testing here at SF

Please do report back any findings.

" Doc "
My System SpecsSystem Spec
19 Sep 2009   #16


Pen drives, USB FLash drives, are all voltage - ma sensitive.
This I have found that many manufactures of cases are really cheap.
the major are using plastic coated to look like metal. Well its not.
many times the front ports are rather cheap. (check the wires.) many are simply too small, small wires carry smaller then required volt/amps.
Also many of the Front Ports are not grounded. poor or not grounds also sap the volts/amps. I have found that on some systems I can fix by simply using a double alligator clip copper wire addon.
1. clip one end of the wire to the chassis.
2. feed the other end to the other end which should have a small metal clip to attach to the plastic case. normally on a good USB PORT the small metal clip actually attaches to the ground wire or shield for the USB Port.
attach your 2nd end to that metal clip.
3. Restart you system, and insert the flash drive... see if this does not correct the problem...(to write to any device, it takes more volt/amps to do, like on your DVD Rewriter, the lazer takes more power to erase and write than simply to read.
4. If you check the back ports they are metal to metal. and will work when the front ports will not.
5. Many newer (devices) items have a Y cable - shame that Pen Drives and USB Flash drives do not have that ability. You might also buy a Extension Y-Cable .

My System SpecsSystem Spec
19 Sep 2009   #17

Windows 7 Ultimate

Thank you Snuffy for your reply!

I tried my drive in all of the front ports, and in all of the ports in my USB hub but never actually tried directly in the back of the computer (motherboard USBs).

It seems to work just fine in the back ports, but I'm rather annoyed that I've bought a Cosmos S, 150 case.. and the front ports aren't good enough to send a 5MB file to a USB stick.

I'll try and do your modding suggestion tomorrow sometime and see if it helps.

Many thanks again, for me at least.. this is solved .

Appreciated (Y) :)
My System SpecsSystem Spec
19 Sep 2009   #18


Make sure the wire is copper. many places sell the aligator jumps, and not all of them use copper wire... copper is more expensive. but worth the added expense.
My System SpecsSystem Spec
19 Sep 2009   #19

Windows 7

Just wanted to popup and say that I got the same problem. My Kingston 8GB pendrive doesn't work in Win7 RTM 32-bit. And yes, I'm having AMD chipset (AMD 770 + SB710 Chipsets).

I've been doing lot of investigating and the issue is with USB 2.0 and large (>2GB) pendrives. If you use USB 1.X (USB 2.0 disabled from bios) it will work or if you have a smaller USB pendrive.
My System SpecsSystem Spec
21 Sep 2009   #20

Windows 7

Yeah, I am having the same problem, when I put in my pen-drive the system makes that "connected" sound that windows makes, but I cannot see the pen-drive anywhere on my system.
LEXAR 16GB JumpDrive Firefly-Red
Win 7 Ultimate 64 Bit

My System SpecsSystem Spec

 Usb flash drive or pendrive problem

Thread Tools

Similar help and support threads
Thread Forum
Problem with Kingston 8GB Usb pendrive
I Have Kingston 8Gb Usb 2.0 pendrive,for which actual capacity is 7.45 Gb. I used my pendrive to record videocon D2H HD Recorder.STB formatted pendrive before used.Also no recordings are done. But after inserting it in my laptop,windows is showing its capacity as 145Mb after initial...
General Discussion
Flash drive problem
I have probably about fifteen folders on my USB flash drive, each of which contains valuable information (all text files). On one particular folder, when I click it, the contents of that particular folder (the files) appear - only they all have messed up titles and won't open. On all the other...
Hardware & Devices
Flash Drive Problem
Here's the problem, whenever I pop in my 1GB Cruzer Micro flash drive, autoplay opens up and shows me this There is no CD on the flash drive at all, I have tried formatting the flash drive and it still comes up whenever I plug in the flash drive, and it shows up as...
Hardware & Devices
PENDRIVE Hard Drive?
I just formated my computer and the next day I check my hard drives and I get a PENDRIVE folder? Any ideas to fix it? Only thing i can think of that I might of caused it was, trying to remove dual boot from xp on my seprate hard drive and I might of removed something that wasnt suppose to be...
System Security
kingston pendrive problem
I`ve got a problem with Kingston 8Gb pendrive. I plug it in at home (Windows 7) and it works fine. When I plug it in at work (W7 as well), I cannot copy some files. From what I see it stucks at 1.5Gb and when I try to copy more files (regardless of file size) it says that the device is full. Any...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:21.
Twitter Facebook Google+