Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: ATI TV 650 PCI - Win 7 chokes

05 May 2009   #1

Vista 64
ATI TV 650 PCI - Win 7 chokes

I'm running an intel DP35DP mobo, w/ 4gig 800mhz mem, a Geforce 8600, and have Vista64 on one drive and have loaded Win7 RC on another. Win 7 will not complete loading the OS when the PCI TV Tuner is installed. I hear the sound driver kick in through the speakers, and then the system hangs. Remove the TV card and all is fine.
I've taken out the card and tried updating the Intel drivers... still no go. I've tried installing the latest ATI Catalyst 64 drivers and then replacing the TV go.
I notice other folk have no problem with this card... and am totally baffled, as it works very well on my Vista64 drive.

Any suggestions will be greatly appreciated.

My System SpecsSystem Spec
05 May 2009   #2

7600.20510 x86

See my post here:

RC1 as main OS

The info may or may not help you. You could also try installing in safe mode because of your booting problems. Good luck.

Note: Mine is not the 650. It is the standard PCI TV Wonder. The most basic one there was.
My System SpecsSystem Spec
27 May 2009   #3

Windows 7 (RC)

I have the same card in my machine, and Win7 boots fine. You might want to boot into sage mode, and uninstall the TV Wonder drivers, and see if you can get the system to boot. I driver I am using is this one: 9-4_vista32-64_t550-600-650_wdm So try downloading that one and installing it. It should install properly with express install, however, it won't actually load the driver properly. I have to manually point to the driver in the device manager to the ATI\Support directory. It should work fine after that, and you should see the ATI unified AV driver after this.

The driver *does* work in Win7 RC x64.
My System SpecsSystem Spec

25 Jun 2009   #4

Windows 7


I'm having the same exact issue that njbill has been having.

Kittyburgers, I actually tried doing what you said before I came across this thread. I would point the driver search to the folder where the ATI stuff installed and then the driver would install fine. When I would restart the computer, Win7 would hang on boot up.

At one point I somehow managed to boot in (not safemode, but regular) and I noticed that in the Device Manager the ATI Unified Driver line had an exclamation point, and it basically said the device could not be started (error 10). When I uninstall the driver (but leave the card in) then it has no problems booting up.

So basically when I install the driver Win7 tries to start the device on bootup, or at least initialize it?, and it can't and so the booting process hangs.

Kittyburgers, are you telling me you've been able to view live TV and record and everything without issue? I'm not at my computer right now but when I get back to my apartment I'll check what driver version I have. I downloaded whatever was available on AMD's website last night.
My System SpecsSystem Spec
25 Jun 2009   #5

Windows 7 (RC)

Yes, I am able to boot up, watch and record TV (at the moment, just a plain analog feed via cable, not OTA ATSC) without any problems. I can't imagine why your machine is hanging on boot. I've not had that problem before. There might be an issue with another driver in your system or something like that. I wish it didn't have to be so complicated, and ATI should really providing Win7 drivers the card.
My System SpecsSystem Spec
25 Jun 2009   #6

Windows 7

You know I just got to my computer and I see that my driver is of the 9-6 variety. I don't know if that makes a difference. Also I should probably have my configuration posted, but I'm inclined to agree with your assessment, that there must be another driver that's screwing things up. I'm using an NVidia video card (8800GT) so that's a possibility. In the mean time I'm going to try and see if I can find a 9-4 ATI catalyst driver and go from there.

Thanks for the reply!
My System SpecsSystem Spec
25 Jun 2009   #7

Windows 7

Ok UPDATE, it's working now .. even with 9-6, this is what I did differently:

as Kittyburgers has said, and I did, I installed the device over and pointed Windows to the directy w/ the ATI Catalyst drivers. Except this time instead of pointing it to C:\ATI\Support\9-6_vista32-64_t550-600-650_wdm

I was a bit more specific because even though I downloaded the 64-bit drivers I noticed the folder had 32-bit drivers too (or so I assume, because it says "vista32-64" right there). So this time I had it pointed to:

under "RIO" there are 2 folders, LH and LH64A, and I guess perhaps Win7 was picking up the wrong folder? I don't know why, and I don't know why it didn't do that to Kittyburgers when he setup his tuner. Perhaps there's a difference in the packaging in 9-4 and 9-6 where Win7 can no longer automatically see which is the 64-bit driver? I don't know but if njbill is still following this thread you can give this a try.
My System SpecsSystem Spec
25 Jun 2009   #8

Windows 7 (RC)

I'm glad to hear you got it working. I'm using the 8800 GT with the latest Nvidia drivers as well, so mostly likey had nothing to do with it. I guess it just comes down to what you said about Win7 not being able to find the properly directory for the driver. Hopefully ATI will fix this soon.
My System SpecsSystem Spec

 ATI TV 650 PCI - Win 7 chokes

Thread Tools

Similar help and support threads
Thread Forum
TF2: The Game Runs me with "Chokes"
Hello , Sorry if my english is bad. This happens. Everytime i run the game (only TF2). The game starts to "freezing" everytime , every second. And i don't know why. The Configs in the game are just normal, things to set in low. Etc, etc. My pc recently was formatted and i have to install all...
re-image your computer dialog chokes on .vhd file
I've had a problem with the c drive on a dual drive asus gh73 lap top and have in hand a disk image backup that was created with ms backup on a separate HDD connected to the asus with a usb cable. There is a .vhd file there which I am trying to get the "re-image your computer" to use, but when I...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:57.
Twitter Facebook Google+