Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Could this be a HDD failing, your take is needed.

08 Jun 2010   #1
24fps

7 Ultimate x64
 
 
Could this be a HDD failing, your take is needed.

Hi all,

For some time now I would have the following issue. My computer would shutdown/freeze without any apparent reason. When it did it would not reboot. I could power it on but it would hang there, not going through POST.

Did a little research and find out that maybe something may not have been connected properly. So I unplugged all the external stuff and plugged it again. Ditto for all internal components (except for the CPU).

It was fine for a while but then it started again two days ago. I redid all the unplugging and plugging thing and it was fine. The problem would come back again and again at a faster pace.

Through all my unplugging and plugging I found out that when one particular drive was unplugged the computer would become stable again. I found that yesterday and no crash since then.

Basically I have three internal drive, my 5 year old IDE drive that is still hanging on after all this time. Two SATA drives, one 80gb as my system drive and another 320gb as a data drive.

Now the problem could be anything and before I experiment with a it bit I just thought I would ask here to see that if any of you has gone through the same type of problem what was the outcome.

Was it a faulty cable (power or SATA), the Mobo, the PSU or the drive itself?

Thanks,

Phil

ps, Don't mind my specs, they are for my laptop.


My System SpecsSystem Spec
.
08 Jun 2010   #2
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Welcome,

The fact that you are posting and asking if it could be your hard drive, inidicates that you know it very well may be. I agree, although I have never experienced the problem, myself. Ofcourse, you should back up everything on a separate hard drive, before it is too late. You can, also tes the hard drive
Hard Drive Diagnostics Tools and Utilities (Storage) - TACKtech Corp.
Wish you luck.
My System SpecsSystem Spec
08 Jun 2010   #3
Dwarf

Windows 8.1 Pro RTM x64
 
 

What sort of SATA data cables are you using? If you are using standard non-latching types, then it is very easy for them to work loose in their sockets. For best results, I use and recommend the latching type.
My System SpecsSystem Spec
.

08 Jun 2010   #4
24fps

7 Ultimate x64
 
 

Hi Richc,

Actually no I am not sure. I've had HDD failure and I would discover that it is so because of I/O errors while writing to the drive or the drive simply won't boot or (one time only) it was the port on the Mobo that was faulty.

I've never had/seen/heard of a drive that slow goes away like this.

Thanks for your time though and I will check the diagnostic tool, maybe it will be of some help.

Phil
My System SpecsSystem Spec
08 Jun 2010   #5
24fps

7 Ultimate x64
 
 

Hi Dwarf,

No there is no latch on the cable but they do fit snuggly in. I remember once I had a port on the Mobo that if I so much as looked at it the cable would come loose, but that is not the case here. Heck, didn't even know that SATA cables with latches existed. Learn everyday I guess...

Thanks,

Phil
My System SpecsSystem Spec
08 Jun 2010   #6
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Hope it is not too expensive to fix
My System SpecsSystem Spec
08 Jun 2010   #7
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Quote   Quote: Originally Posted by 24fps View Post
I found out that when one particular drive was unplugged the computer would become stable again.

Basically I have three internal drive, my 5 year old IDE drive that is still hanging on after all this time. Two SATA drives, one 80gb as my system drive and another 320gb as a data drive.
Since you have isolated the bad hard drive, a good diagnostic would be to first test the drive, as Richc46 suggested.

But you can do some at-home diagnostics too. You don't say which drive that is (the SATA or the IDE?) If it is one of the SATA drives you can install it on the cable the known good drive is on and see if you can POST. (If you disconnect the system drive the computer will not boot into the OS, of course, but it will POST). If the problem occurs then you can be pretty sure it is the HDD that is bad.

If the HDD is good then you would test the cable. Take the cable from the known "bad" drive and connect the known good drive with it. If the problem occurs then you can be pretty sure it is the cable that is bad.

If the cables are good then you test the SATA connectors. Simply plug the known "bad" drive into a different SATA plug and test.

If the IDE drive is the one that is bad, then you need to either try it in another computer, or try a new cable.

As for the power supply, you can try a different power supply connector to the drive to see if it is just a bad connection/circuit. Otherwise, if the power supply is failing or just getting old it may not have enough power to run all 3 hard drives. Power supplies typically only start to fail under a load and it is difficult for the lay person to test a PS under load without some pretty hefty lab equipment, so if you can borrow a supply you could test to try and eliminate the PS as a cause.

If all that passes then you are down to the motherboard.

Hope that helps.
My System SpecsSystem Spec
08 Jun 2010   #8
Dwarf

Windows 8.1 Pro RTM x64
 
 

Quote   Quote: Originally Posted by 24fps View Post
Hi Dwarf,

No there is no latch on the cable but they do fit snuggly in. I remember once I had a port on the Mobo that if I so much as looked at it the cable would come loose, but that is not the case here. Heck, didn't even know that SATA cables with latches existed. Learn everyday I guess...

Thanks,

Phil
Here you go.

Could this be a HDD failing, your take is needed.-sata-cable.jpg


My System SpecsSystem Spec
08 Jun 2010   #9
24fps

7 Ultimate x64
 
 

@TVEblen

Thanks, these are very good pointers. Indeed it is the 320gb SATA drive, the IDE is fine, almost seems like it will run forever.

I doubt the problem is with the PSU though because your typical doesn't apply in this case. Most often the freeze/shutdown will happen when I am doing nothing in particular with my computer.

@Dwarf

Well these cables sure don't come standard because I have never seen them before.

Thanks
My System SpecsSystem Spec
Reply

 Could this be a HDD failing, your take is needed.




Thread Tools




Similar help and support threads
Thread Forum
PSU failing or something else?
Hi, first of all excuse me if i did not post on the right section, please move it if there is a more suitable one. My system specs are: - Asus Maximus VI Formula - Corsair AX 1200 - Corsair Vengeance 4x4 (16gb) -Msi gtx 970 -Noctua u14s -2 SSD // 3 HDD
Hardware & Devices
Is my HD failing, and if is, what should I do?
Hello I keep the computer I am having the problem with turned On all the time during the week, turning it Off on Sunday night's, and restart's on Monday's. Last Thur., Dec. 3, when I went to wake it from Sleep mode, I found it was Off. I have it plugged into a battery backup system along with...
Hardware & Devices
HDD failing, need to clone for replacement HDD - Tips needed
Hello, HDD - WD 7500BPKX model. My 6 month WD - Black Drive all of a sudden started to fail. Got Win-7 error dialog box that an error has occurred and I need to back up data before HDD fails (something like that, not exact words). Intel SMART also fails. Now I get only SMART failure...
Backup and Restore
PSU Failing?
Hey guys, I got a new graphics card the other day, went from a HD 5850 to a GTX 560ti OC'ed edition. My PSU was quiet as quiet can be when gaming with the old GPU but now the PSU is making a whining noise, not mega loud but loud enough that you can hear it. Only happens with gaming. ...
Hardware & Devices
Failing SSD ?
Hi guys is there any way to tell if my SSD is failing? I have had so many problems recently with it I have had to re-install Windows at least 8 times as it has some how got corrupted it randomly reboots and then the memory dump fails and I try to reboot only to get the message that Windows can not...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:10.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App