Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Memtest86+ V4.10 And 2 Kits Of Corsair Ram (tw3x4g1333c9)

06 Jul 2010   #1

Windows 7 Professional 64bit
Memtest86+ V4.10 And 2 Kits Of Corsair Ram (tw3x4g1333c9)


I recently upgraded my systems (Intel DP45SG) RAM capacity to 8GB from 4 GB. Once installed, I booted up to my systems BIOS and verified the RAM modules have been detected and restored all BIOS settings to default to make sure all new changes have been updated properly. All RAM has been detected and everything looks good in the BIOS. Next, I decided to run Memtest86+ v4.10 to fully test the new modules. Around Test #6 Pass 36% & Test 69% I received four errors (I've attached a screenshot of Memtest86+). After receiving the errors I turned off the system, reseated the RAM modules retested and got the same error. I went ahead and turned off the system, and removed my original 4GB modules and only left the new 4GB modules. This time Memtest86+ passed. I decided to test the other RAM slots to make sure it's not the MB. Memtest86+ passed again. At this point I thought my original RAM modules might have gone bad. I removed the new modules and reinstalled the original modules, ran Memtest86+ and the original 4GB modules passed as well. Now it seems Memtest86+ pass with only 4GB installed but once I get to 8GB it fails.

At this point, I decided to go a few steps further. I left the 8GB RAM installed in the system and booted up to Windows 7. I decided to run Prime95 for 24hrs to see if any errors occur. After 24hrs Prime95 had no errors. I decided to use my computer normally for a few days to see if any issues occurred. After 4 days of playing games for a few hours, watching and editing videos, and normal web surfing, no issues have occurred in the OS.

I am not sure where to go from here. I am not experiencing any issues with my newly installed RAM modules however I am not passing Memtest86+ with all modules installed. Also the BIOS is up to date, my system is not over clocked and is running on factory stock settings (except the Geforce GTX 470 which is over clocked by the factory). Any help will be appreciated for this issue and thank you for your time.

My System Specs:

Motherboard: Intel Desktop Board DP45SG
Processor: Intel Core 2 Quad Q9650 @ 3.00GHz
Memory: Four 2GB Corsair - tw3x4g1333c9
Video Card: Nvidia GeForce GTX 470 SC+
Hard Drive # 1: Hitachi Deskstar 7K1000.B 1 TB (HDT721010SLA360)
Hard Drive # 2: SAMSUNG Spinpoint F1 1TB (HD103UJ)
Hard Drive # 3: Western Digital Caviar SE 160GB (WD1600JS)
Optical Drive: LG Super Multi DVD Rewriter (GH22NS40)
Power Supply: Ultra X3 1000W ATX Power Supply
Case: ThermalTake Tsunami Dream (Silver)
Sound Card: Creative Sound Blaster Audigy 2 ZS
Monitor: NEC Multisync LCD1765
Operating System: Windows 7 Professional 64bit

Attached Thumbnails
Memtest86+ V4.10 And 2 Kits Of Corsair Ram (tw3x4g1333c9)-memtest86-error.jpg  
My System SpecsSystem Spec
06 Jul 2010   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Do a web search for "memtest86+ 8GB". Lots of info on this condition.

Most refer to the need to up the ram voltage when adding 4 sticks to get them to run stable, but it can get more complicated than that.

This thread is typical:
Memtest86+ : ERRORs only at test #6 & only if 4 DIMMs are set - Memory - Motherboards-Memory

OTOH, if you have no symptoms, are you really sick? You might want to apply the "If it ain't broke, don't fix it" rule here.
My System SpecsSystem Spec
07 Jul 2010   #3

Windows 7 Professional 64bit


Thank you for your response. I've always liked that saying, "If it ain't broke, don't fix it". Trust me, I thought about it a few times before posting anything in the forums. However, I've always had excellent luck with Memtest86+ testing good and bad RAM. I just don't want this to be a dormant issue and the day I need my computer to be on its best performance, have it mess up on me.

Let me explain what I've attempted so far.

Yesterday I was working on the computer and updated a few applications. After the update, I restarted Win 7 and encountered a BIOS error. After the restart the system did not post and provided 3 Beeps. According to the MB manual 3 beeps indicate the memory was not detected. I decided to turn off the power completely, wait a few secs. and turn on the system again. This time the system posted and booted up to the OS. I attempted to recreate this error again, I restarted the OS and the system successfully restarted and posted with no errors or beep codes.

I attempted your suggestion and bumped up the memory voltage to 1.6v from 1.5v. However, Memtest86+ gave the same errors like the last time but with errors in different test #s.

I was looking through some other threads and found discussions about different revision numbers on the memory modules. Is it a possibility that this time around I got a different revision number? I bought the first 4GB kit last year and bought this other 4GB kit about a week ago.

What is the next step? For the first time I got BIOS beep code errors. Can this indicate a faulty memory module(s)? Thank you again for your time in this matter. Any further help will be appreciated.
My System SpecsSystem Spec

07 Jul 2010   #4

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Beep codes. Well, those are definitely symptoms!

From what you say it certainly sounds like one or more of those modules are not performing to spec. If you just bought them you may want to avoid all the work and just do a RMA. I agree with you, there have been a number of times that Memtest passes RAM but it turns out to be bad in the end regardless. Yours doesn't pass. It may be just bad RAM.

If you want to play with the RAM to see if you can get it to pass Memtest a couple of things to try is:

Go into the BIOS and turn the DRAM Frequency down to 1066 or even 800 and test (Leave the voltages back at default). RAM modules are made in batches and are only designated at a frequency by a test/pass basis. Yours may be incorrectly rated for 1333 (bounced out of the 1066 bin into the 1333 bin). But if you find your 1333 only works at 1066 you'd want to RMA anyway, wouldn't you?

Also, try resetting the BIOS defaults and then only make the changes you need for the correct SATA configuration -0 leave everything else at default values. Also, check @ Intel to see if they have a newer BIOS for your board that lists memory issues as a fix.

You can also play with a combination of reduced timings, voltages, and multipliers to see if you can get the new RAM to run stable.
My System SpecsSystem Spec
08 Jul 2010   #5

Windows 7 Professional 64bit


Again, thank you for your response. Running voltage at 1.6v, DRAM Frequency at 1066, and CAS at 9-9-9-24.
Memtest86+ Passed! With no reported errors!

The test ran for 11hours and 45mins (please see screen shot below). You were right. It seems one or some of the modules are not running at the right specifications. I also currently have the latest BIOS for this MB. I am currently working with Corsair on getting an RMA for these modules. I'll keep you posted on any further developments. Again, thank you for all your help.

Attached Thumbnails
Memtest86+ V4.10 And 2 Kits Of Corsair Ram (tw3x4g1333c9)-memtest86noerror.jpg  
My System SpecsSystem Spec
08 Jul 2010   #6

Windows 7 ultimate 64 bit / XP Home sp3

I just wanted to say this for those budgeting for a new build I always try and keep in mind the max amount of ram I'm going to want to use in my budget when purchasing it. This way it has a higher probability of being tested , paired and binned under the same circumstances and are more likely to be manufactured and handled under the same quality control, thus the less likely hood of something through the manufacturing process becoming an issue.
As most of us know it's never a good idea to mix ram but even purchasing the exact brand and model # at a later date can make a difference, but then again sometimes it's just a bad stick here or their JMO. Hoepe it works out for you. Fabe
My System SpecsSystem Spec
08 Jul 2010   #7

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Glad to see you got it sorted.
Sorry that you're dealing with bad RAM.

This can sometimes be a hard problem for folks to track down. Good work!
My System SpecsSystem Spec
14 Jul 2010   #8

Windows 7 Professional 64bit

TVeblen & thefabe,

Thank you for your responses. I found the exact cause of the issue. The first kit of 4GB RAM modules were 1.5v RAM Modules. The second kit of 4GB RAM Modules I just purchased were 1.6v RAM Modules. Also both kits had different revision numbers.

The RMA has been requested and processed. Corsair will be replacing both kits. I'll be sending the defective modules sometime this week. Again, thank you all for your assistance.
My System SpecsSystem Spec

 Memtest86+ V4.10 And 2 Kits Of Corsair Ram (tw3x4g1333c9)

Thread Tools

Similar help and support threads
Thread Forum
HDD too small, can't mount without additional kits.
I recently bought a new computer, it came with a 1TB hdd which was mounted. I had a new 1TB HDD already, and when i tried mounting it, it was to small, the HDD that the pc came with had some plastics on it's sides that held it properly. I mounted the HDD and put it on the Case floor, it's...
Hardware & Devices
Three 4gb x 2 kits on my 6 DIMM motherboard a good idea?
would it be a good idea to buy Three (3) 4gb x 2 kits (24gb total) to save money instead of buying Two (2) 4gb x 3 kits (24gb total)? what are the risks if there are any? :p
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:31.
Twitter Facebook