Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can anyone explain the following symptoms

18 Jul 2010   #1
glennc

Windows 7 Ultimate
 
 
Can anyone explain the following symptoms

Hello to all,
This situation has been discussed in other threads that were started on a different subject. So I though I would ask it here on it's on, with the limited experience and knowledge to answer myself.
The situation is a follows:
When first installing windows 7 I got it running and for my preference I put Zonealarm Free Firewall. On reviewing devices and printers it showed a yellow triangle on the, then only, hardrive (SATA WD Caviar) I had and on the USB device. I checked the driver details on both devices and found that the options to update driver, rollback driver and uninstall driver were grayed out and unavailbale for use. Only view Installed Driver was functioning.
I learned that Zonealarm blocks some port to the web that W7 requires. I uninstalled Zonealarm and the above devices immediately lost their error yellow triangle and worked properly.
Why is this and what exactly is causing it? It is apparently part of the OS and my last computer ran XP Pro so I never encountered this type of problem before. Why and what are blocking the other options.
Can any learned person explain in moderate or simple detail what is occurring or point me to a Tutorial.
Thanks
glennc


My System SpecsSystem Spec
.
18 Jul 2010   #2
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

My System SpecsSystem Spec
18 Jul 2010   #3
glennc

Windows 7 Ultimate
 
 

Howdy theog,
How ya been? I am afraid that I am such a beginner with this OS that what you hyperlinked (BTW thanks), I couldn't find any what in my limited capacity was relevant information.
I am more interested in understanding how these drives operate and the reason for the grayed out option. What part of Windows is doing this, it is apparently a standard, I am just completely unaware of.
What is the operating system difference that makes the symptoms happen. What program in W7 requires access to the web, why, how often. I haven't a clue about what is going on and that is what I really need clarified.
I hope I explained my problem sufficiently for you and anyone else that wishes to assist to understand what it is I need.
Please post questions if you don't understand what I'm talking about.
Thanks as usual to all that choose to participate and to you theog for your quick response and knowledge.
glennc
My System SpecsSystem Spec
.

18 Jul 2010   #4
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Have a read here:

ZoneAlarm Security News
My System SpecsSystem Spec
18 Jul 2010   #5
glennc

Windows 7 Ultimate
 
 

Howdy again theog,
Search through the list ZA provided at the link you gave me. I didn't find anything that fit my situation. Got online with their chat service and the only option he could suggest was to reinstall ZA and try to troubleshoot it. I've waited too long to get the system running so I told him I was not prepared to follow his troubleshooting examination. So I'm still where I am.
Again it is not about Zonealarm, it is about what Windows 7 Ultimate 64 bit is doing with the affected drive. What W7 program or startup parameter or procedure or service stopped the devices from working, and removed all the options in the Driver Window on those devices.
Thanks
glennc
My System SpecsSystem Spec
18 Jul 2010   #6
merkat106

Windows 7 Enterprise x64 SP1
 
 

If the devices worked after uninstalling ZA, then the problem is with ZoneAlarm. I assume the version you are using is the latest. It does sound like a setting with ZA. I'm researching this now.

What anti-virus are you using with ZA? I have come across conflicts with certain AVs and ZoneAlarm. Microsoft Security Essentials seems to work well with it as I have been reading.

Have you tried troubleshooting ZA?
My System SpecsSystem Spec
18 Jul 2010   #7
merkat106

Windows 7 Enterprise x64 SP1
 
 

No luck thus far...

I am going to recreate your issue by installing ZA free.

BTW: I also have Norton installed...

UPDATE: Unable to recreate problem. No conflicts between Norton IS and ZA Free Firewall. Everything in device manager is normal & I have internet access.
Your problem may be a result of a compatiblity problem between ZA and your antivirus and 7.

Try removing your anti-virus and see what happens. Do consider using MSE for your anti-virus (or Norton).
OR
Try switching to another firewall such as Comodo. That has gotten some good kudos from people.
My System SpecsSystem Spec
18 Jul 2010   #8
glennc

Windows 7 Ultimate
 
 

Howdy merkat106,
Thank you for joining the thread. I can use all the help I can get. For antivirus I was at the time using Avira. When I loaded ZA the troubles started and I switched to Comodo, both products I have used previously and have never been successfully hacked (fingers crossed). Unfortunately when I installed Comodo, I started dropping Internet connections. I would disable and reenable it and after miscellaneous attempts it would connect. When it wouldn't connect it stated that it was attempting to contact the incorrrect IP and on looking at the address, I knew it wasn't mine.
So I dumped Comodo and went with AVG firewall. It connected and seemed to work fine. I had an opportunity to acquire McAfee which has the AV and firewall and I haven't had a problem since.
I did not look into any of the incompatibilities.
My real interest is not about any of the programs specifically, but about why the SATA drive and USB hub failed. I don't know the protocol or how SATA works and that is the real question. I read that Zonealarm blocked a port that Windows 7 needed to initialize the SATA devices and the USB, which I have no way of knowing if that is true or make believe. I do know that this is why I removed Zonealarm and got running again. Why is the Update, Rollback and Uninstall options unavailable on these devices. Never saw that before. Would like some incite into the workings of Windows 7 and Sata drives that caused this change from the pata drive workings, where you had access to change and rollback device drivers.
That is what I really am concerned with.
I appreciate your assistance and time.
glennc
My System SpecsSystem Spec
18 Jul 2010   #9
merkat106

Windows 7 Enterprise x64 SP1
 
 

Oh,

Guess I was a little confused. Disregard what I said earlier.

Don't quote me on this, but I do think ZoneAlarm disabled driver options.

SATA devices work natively with Windows 7 since most new computers use SATA connectors over the Parellel ATA connectors to connect devices such as hard drives and optical drives to the motheroard.

Windows 7 normally allows for those driver options on SATA devices.

The rollback device drivers option only is available when more than one version of a device driver is available. Typically this happens when you update the device drivers.

I hope you know how the other options work with Windows in general. There seems to be little change there from previous versions of Windows.

Where are you from? Not many on this forum use the greeting howdy. I don't on the forum, but I do use it in person. I am originally from Fort Worth, Texas.
My System SpecsSystem Spec
18 Jul 2010   #10
glennc

Windows 7 Ultimate
 
 

Hey merkat106,
I'm from the armpit of the world, with a 6 months of the year Hurricane Season. Yes the beautiful, sweaty, hurricane prone South Florida. Spent some time in Charlotte, NC and maybe picked it up there.
Thanks for focusing on my intended inadequacies. If I understand you correctly, the Update Driver and Rollback Driver and Uninstall Driver options are not available because there is no new driver to update to, and since I have update automatically, Windows 7 will update the drivers without my intervention if and when they become available?
Also if you are not connected to the internet then Windows 7 cannot update the drivers if available, and if you install a new Sata device, if you do not have internet connection then Windows 7 will not be able to install the driver for the new device and it will fail, until internet connection is again attained?
Am I beginning to understand the workings of Sata. I have checked and I have automatic updates turned on, but they were scheduled for when the computer was shut off. I changed it to a time that I'm pretty sure that I will be online.
Any further explanation or corrections of my possible misconceptions is direly needed.
Take it easy
glennc
My System SpecsSystem Spec
Reply

 Can anyone explain the following symptoms




Thread Tools




Similar help and support threads
Thread Forum
Is my motherboard showing near-to-death symptoms?
I've noticed this yesterday. My PC will not boot past the BIOS splash screen (My motherboard is MSI MS-7525 and therefore is OEM and not supported by MSI.) Is the motherboard going to die? I'm thinking of getting any G31 Motherboards (Too lazy to install drivers) and I need an upgrade to Core 2...
Hardware & Devices
Strange symptoms of Win 7. Possible infection or hacker???
I hope somebody might be able to help in any way before I set about doing a complete reinstall of Win 7. I am trying to resolve some issues on my fathers Pc as follows: 1, Initially he was getting a constant pop up on each boot saying that windows was not genuine and required activation. The...
General Discussion
GTX 550 Ti Overheating Symptoms at 50
Hello. I'm having an issue with my Zotac AMP! GeForce GTX 550 Ti where it seems to be overheating at a low temperature. While playing Skyrim (low or high settings), at some point my sound will become very tinny and the game will drop to under 2 FPS about every 30 seconds. Most recently, Windows...
Graphic Cards
BSOD occurred with no initial symptoms.
Hello everyone. First i have to say i hate how my first post is a cry for help. Generally i am able to solve my own issues just reading other posts, but i am a bit baffled with this recent bsod. To start, there was no initial symptoms. One second i was browsing the internet fine, i was not...
BSOD Help and Support
BSOD - Same symptoms, different codes
Hey guys! I'm getting artifacting (I'm guessing that's the correct term, see pic) followed by a BSOD when I am playing a game. The BSOD codes are always different, as are the minidumps. Sometimes I don't get a BSOD, the computer screen goes black and I get an error about being unable to recover...
BSOD Help and Support
C'mon peeps -- I'm getting Withdrawl symptoms
Hi everybody I can't believe this -- I've got build 7077 X-64 installed on all my machines and it's been running fine for a few days. I'm getting BORED -- I NEED a NEW BUILD. PLEEEEEEEEEEEEEEEEEEEEEEESE Peeps Leak a new build before I suffer any more withdrawl symptoms
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:20.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App