Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 does not recognize my Creative Live! Value

19 May 2009   #11
johngalt

 

*mine* was a rant. And, actually, there are *lots* of people all over the net that try to lay the blame for lack of device support squarely at the feet of M$.

it is one of my personal pet peeves, but if that was a joke, then I apologize for going overboard with my response.


My System SpecsSystem Spec
.
19 May 2009   #12
Irish

XP Main
 
 
True

Yeah very true about the ranting by alot of people. Haters the lot of them. I will not have time tonight to boot W7 but will get to it tomorrow night and see what the deal is.
My System SpecsSystem Spec
20 May 2009   #13
brucemoose2

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Irish View Post
As for the boot to W7, I will try it a bit later to see what the cards shows as if anything at all.
Let me clarify again. I'm not asking if the sound card shows up with a problem code or as an unknown device. You've already said that it does not. I'd like to know if there are any other devices (of ANY type) that have a problem code. I'll need to know the PNP ID and problem code for each device with a problem, if there are any. It's possible that there's a connection between the missing sound card and another device with a problem code on your system. Please post back as soon as you have this info. Thanks!
My System SpecsSystem Spec
.

01 Jun 2009   #14
brucemoose2

Windows 7 Ultimate x64
 
 

I was able to reproduce the "problem" that some of your are reporting. It turns out that at least some of the cards are actually showing up as "HD Audio" devices in the latest builds instead of unknown devices. They are not described as "Sound Blaster" devices in device manager, either. Look at the hardware ID and compare it to the device you see in XP or Vista and you'll understand. I hope that this clears up the misunderstanding for you all. This device is definitely not "missing" in Win7.
My System SpecsSystem Spec
02 Jul 2009   #15
PeeGee77

Windows 7 RC
 
 

I have 2 drives, one with XP and just installed Windows 7 RC on the other. Exact same issue with Creative X-Fi Extreme Gamer - fine in XP but not even detected in 7.

Here's what I had to do to fix it:
go to Creative Worldwide Support > X-Fi XtremeGamer
and download Creative Sound Blaster X-Fi series driver 2.18.0013

Run the install. This doesn't fix the issue, but after a reboot it makes the card visible in Device Manager. Right click the device > update driver > browse my computer > pick from list > Creative X-Fi Audio Processor (WDM). In my case this caused Device Manager to stop responding, but don't worry, just pretend it is all OK.

I was now able to go to Control Panel > Sound and Creative X-Fi was visible. Set as default and jobs a good'un.

Hope this helps someobody - be interested to hear other peoples experiences with it.
My System SpecsSystem Spec
02 Jul 2009   #16
brucemoose2

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by PeeGee77 View Post
I have 2 drives, one with XP and just installed Windows 7 RC on the other. Exact same issue with Creative X-Fi Extreme Gamer - fine in XP but not even detected in 7.

Here's what I had to do to fix it:
go to Creative Worldwide Support > X-Fi XtremeGamer
and download Creative Sound Blaster X-Fi series driver 2.18.0013

Run the install. This doesn't fix the issue, but after a reboot it makes the card visible in Device Manager. Right click the device > update driver > browse my computer > pick from list > Creative X-Fi Audio Processor (WDM). In my case this caused Device Manager to stop responding, but don't worry, just pretend it is all OK.

I was now able to go to Control Panel > Sound and Creative X-Fi was visible. Set as default and jobs a good'un.

Hope this helps someobody - be interested to hear other peoples experiences with it.
If you were able to install the driver package then the device was already visible in device manager. It just wasn't called "Sound Blaster blah blah blah..." It was called "HD Audio device" because that's what the "best match" driver inf said that it should be called. When you installed the driver from Creative Labs, the best match inf became the new driver package, so the device was renamed according to the new inf.
My System SpecsSystem Spec
03 Jul 2009   #17
PeeGee77

Windows 7 RC
 
 

Quote:
the device was already visible in device manager. It just wasn't called "Sound Blaster blah blah blah..." It was called "HD Audio device" because that's what the "best match" driver inf said that it should be called.
No it wasn't. As I said, it wasn't visible. And also it fixed it. If you have a better fix posted above I missed it.
My System SpecsSystem Spec
04 Jul 2009   #18
brucemoose2

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by PeeGee77 View Post
No it wasn't. As I said, it wasn't visible. And also it fixed it. If you have a better fix posted above I missed it.

Yes, the fix is to look more carefully for the hd audio device before deciding that it's not there. Sorry you missed it.
My System SpecsSystem Spec
Reply

 Windows 7 does not recognize my Creative Live! Value




Thread Tools




Similar help and support threads
Thread Forum
no sound with Creative SB Live (WDM)
after a power out today i got no sound afterwards :cry: and i tried msconfig device manager and all that i could find on internet please help
Sound & Audio
The Windows media center(Live TV) doesn't recognize the new location.
Hi everyone! I wish that someone could help me with stuff. Although I moved all folders (hidden and unhidden) of the public user account from its default location 'Drivesystem\users\public' to another one via registry, I noticed Whenever I run the windows Media center. Then, I click on...
Media Center
Webcam Creative Live!No drivers for windows 7
I have a webcam creative live VF-0050! But I can't find drivers for windows 7! I found for vista, but they are no good. I don't have access to properties, so I can't move the bars with contrast etc. I see in creative's site but they say, that no support my cam anymore. I bye another cam .. I pay...
Drivers
Windows Live Movie Maker Does Not Recognize My Camera
Windows Live Movie Maker Does Not Recognize My Camera to Import Video into the Windows Live Movie Maker Program. A Corel Movie Maker program does recognize my camera and allows for importing of video. Can someone please help me. Thank You, George Jurak
Music, Pictures & Video
Creative Soundblaster Live 5.1
Good Afternoon, I've recently installed the above card (SB Live 5.1) on my system which is running Win 7 ultimate 32-bit. Prior to installation, I checked with the Microsoft Windows7 compatability website and it states completely compatable. Unfortunately, I get the red "x" in the taskbar...
Sound & Audio
need Creative SB Live driver
need Creative SB Live driver. I was trying almost all of driver by search this forum & net. But i m fail to get my actual driver. also i can't understand actually which is my sound card. On XP my driver name on DirectX is Creative SB Live! but in the same name huge of sound driver & way i get &...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App