Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Installation stops "expanding files" - Help please !!

16 May 2009   #11

Vista x64 Home Premium

More news.

I open with EasyBCD file BCD on partition M: and this is what it looks:
Windows Boot Manager
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=M:
description Windows Boot Manager
locale es-ES
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {77b45595-4213-11de-8f38-c8aa6bb696b6}
resumeobject {77b45594-4213-11de-8f38-c8aa6bb696b6}
displayorder {77b45595-4213-11de-8f38-c8aa6bb696b6}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 3
Windows Boot Loader
identifier {77b45595-4213-11de-8f38-c8aa6bb696b6}
device partition=I:
path \Windows\system32\winload.exe
description Windows 7
locale es-ES
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice partition=I:
systemroot \Windows
resumeobject {77b45594-4213-11de-8f38-c8aa6bb696b6}
nx OptIn
detecthal Yes
Windows 7 installation doesn't added itself to Vista BCD instead of create a new BCD on partition M:

I did a new test. Changed Vista BCD with BCDEDIT to point Boot Manager to partition M: and added manually Windows 7 entry for dual boot (copying Vista and modify device and os device to point to J:)

Reboot, choose Windows 7 and installation continues Registring Services and the change screen resolution and then hangs again !!!

But now it's different because I have setuperr.log who tells:
2009-05-16 13:06:31, Error [0x06053c] IBS CallBack_InstallDriversOnline:Failed to get the driver package path in the driver store for driver [J:\Windows_V-RAID_V580C\VRAIDDrv\drvdisk\VISTA\x64\viamrx64.inf]. API return code is [0x80070003].
2009-05-16 13:06:31, Error [0x0602a3] IBS CallBack_InstallDriversOnline:An error occurred while installing the driver package [VIA RAID Controller - 3249 (J:\Windows_V-RAID_V580C\VRAIDDrv\drvdisk\VISTA\x64\viamrx64.inf‪)] GLE is [0x3]
2009-05-16 13:06:31, Error [0x0a01ac] UI Install driver failed.
This kind of error seems to be more easy to solve.
It didn't find VIA RAID Driver on J: (don't know what partition is). I'm gonna try again from start not using this driver and I'll tell you.

My System SpecsSystem Spec
16 May 2009   #12

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

You don't want it to point at M - try removing that entry.

You could try adding 7 partition to Vista bcd manually.

In Vista, open an elevated command prompt navigate to partition I at the prompt I:> type the following (press enter after each command)

I:\>bcdedit -create /d "WIN 7" /application OSLOADER

IT will return a {GUID} - like the one below - use the one you get (not this one ) in the following commands:

The entry {fccd47c8-2285-11de-a747-e02d8e6d652f} was successfully created.

bcdedit /set {fccd47c8-2285-11de-a747-e02d8e6d652f} device partition=I:

bcdedit /set {fccd47c8-2285-11de-a747-e02d8e6d652f} osdevice partition=I:

bcdedit /set {fccd47c8-2285-11de-a747-e02d8e6d652f} path Windowssystem32winload.exe

bcdedit /set {fccd47c8-2285-11de-a747-e02d8e6d652f} systemroot Windows

bcdedit /displayorder {fccd47c8-2285-11de-a747-e02d8e6d652f} /addlast

bcdedit /set {fccd47c8-2285-11de-a747-e02d8e6d652f} nx OptIn

bcdedit /set {fccd47c8-2285-11de-a747-e02d8e6d652f} locale en-US

I see you are going to reinstall - good luck
My System SpecsSystem Spec
18 May 2009   #13

Vista x64 Home Premium

Try to reinstall and no luck.

Finally i did this attempt:

- Monitor connected with CRT plug.
- 2x1GB RAM in single channel
- Unplugged Creative sound card
- Unplugged SCSI PCI Card
- Unplugged 1 DVD combo

Install from DVD on primary partition on second RAID 0 array.
Loaded Intel SATA RAID drivers Vista x64

Everything was fine, first reboot, Windows 7 BCD added succesfully in Vista boot loader. Press F8 and continue installation in VGA Mode 640x480.
Then began Registry actualization, installing Services, Completing Installation and then hangs again.

I see this in file "":
dvi: {Select Best Driver}
dvi: Selected driver installs from section [Generic.Install] in 'c:\windows\system32\driverstore\filerepository\1394.inf_amd64_neutral_037298662c4991fb\1394.inf'.
dvi: Class GUID of device remains: {6bdd1fc1-810f-11d0-bec7-08002be2092f}.
dvi: Set selected driver complete.
dvi: Selected:
dvi: Description - [Controladora de host VIA compatible con OHCI 1394]
dvi: InfFile - [c:\windows\system32\driverstore\filerepository\1394.inf_amd64_neutral_037298662c4991fb\1394.inf]
dvi: Section - [Generic.Install]
dvi: Signer - [Microsoft Windows]
dvi: Rank - [0x00ff2001]
dvi: {Select Best Driver - exit(0x00000000)}
dvi: Default installer: Exit
dvi: {DIF_SELECTBESTCOMPATDRV - exit(0x00000000)} 10:53:25.296
inf: {SetupCopyOEMInf: C:\Windows\INF\1394.inf} 10:53:25.296
inf: Driver Store location: C:\Windows\System32\DriverStore\FileRepository\1394.inf_amd64_neutral_037298662c4991fb\1394.inf
inf: Published Inf Path: C:\Windows\INF\1394.inf
inf: {SetupCopyOEMInf exit (0x00000050)} 10:53:25.296
dvi: Searching for hardware ID(s):
dvi: pci\ven_1106&dev_3044&subsys_100615bd&rev_80
dvi: pci\ven_1106&dev_3044&subsys_100615bd
dvi: pci\ven_1106&dev_3044&cc_0c0010
dvi: pci\ven_1106&dev_3044&cc_0c00
dvi: Searching for compatible ID(s):
dvi: pci\ven_1106&dev_3044&rev_80
dvi: pci\ven_1106&dev_3044
dvi: pci\ven_1106&cc_0c0010
dvi: pci\ven_1106&cc_0c00
dvi: pci\ven_1106
dvi: pci\cc_0c0010
dvi: pci\cc_0c00
inf: Opened PNF: 'C:\Windows\System32\DriverStore\FileRepository\1394.inf_amd64_neutral_037298662c4991fb\1394.inf' ([strings.0c0a])
dvi: Selected driver installs from section [Generic.Install] in 'c:\windows\system32\driverstore\filerepository\1394.inf_amd64_neutral_037298662c4991fb\1394.inf'.
dvi: Class GUID of device remains: {6bdd1fc1-810f-11d0-bec7-08002be2092f}.
dvi: Set selected driver complete.
ndv: Driver selected, now performing install...
ndv: Waiting for previous device install to complete. 10:53:25.359
|h I  7+ \E
It seems installation fails when trying to install IEEE 1394 (motherboard integrated). In Vista x64, driver is OK (VIA generic HOST controller IEEE 1394, publisher Microsoft).

I was looking in BIOS and no way to disconnect IEEE 1394.
Motherboard es DFI Infinity 975 x/G. Any way to turn off Firewie IEEE 1394?
My System SpecsSystem Spec

23 May 2009   #14

Vista x64 Home Premium

Ok, finally I did it but not a clean install instead and upgrade from Vista.

- Installed Vista x64 on primary partition on second RAID 0 array (loaded Intel Sata Raid and VIA SCSI Raid drivers on install).
- No activation. Now I have a dual boot with 2 Vista x64 systems.
- Installed Intel Matrix Storage, nVidia drivers and Realtek Ethernet drivers (all of them latest versions)
- Installed Vista SP1
- Through Windows Update installed all (critical and recomended) updates and fixes (except IE8)

At the end I have a clean Vista x64 installation except sound (didn't install Creative Audigy 2 drivers because Windows 7 Upgrade Advisor said is better to install card within Windows 7 Windows Update).

- Downloaded again Windows 7 ISO to compare hash with the older one. Mounted with Daemon Tools and extracted all files (xcopy on command prompt) from the ISO to other partition.
- Boot on new Vista x64 system and run "setup.exe" from ISO's extracted files with administrator privileges.
- Choose UPGRADE instead of clean install and 40 minutes later it's done. (Press F8 on first and second reboot and choose low-res graphic mode).
- No problem with SATA drivers, Intel Matrix Storage or VIA SCSI Raid drivers. Nvidia drivers also installed fine.
- Through Windows Update downloaded updates and Creative Audigy 2 drivers (sound is somewhat low but at least it's sound)

I think I must wait until some better drivers for SATA Raid appears until I'll try a new attempt for a CLEAN install.

Thanks everybody.
My System SpecsSystem Spec
02 Jun 2009   #15

Windows 7

I got good news and bad news. The good news is, I know why it won't install for you. The bad news is, it's your motherboard.

I'm using the DFI 975x/g as well, and have been trying to install Windows 7 for months to no avail until about an hour ago. My solution was to take out one of the sticks of ram (I had two) turn the disable the pmw thing in the bios, and turn the cpu, system and nb fan on full, disable the memory mapping and the other two options above and below it.

It installed perfectly, but when I tried switching everything back to normal after it installed. It freezes every two minutes. So now it's like I have a friggin vaccum cleaner turned on right next to my legs.
My System SpecsSystem Spec
02 Jun 2009   #16

Windows 7

Quick update- Turned the fan down and it's not freezing.

So try this. Go to your bios, and go to the genie mode where you configure the ram and CPU speed.

PMM function: Disable

go to the bottom of the page

auto dectect something: Disable
Spread Spectrum: Disable
Memory hole mapping: Disable

I have a feeling it's just the PPM thing that's screwing it up, but gotta go to work, will test it out later on. Good luck.
My System SpecsSystem Spec

 Installation stops "expanding files" - Help please !!

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 Installation frozen at "Expanding Windows Files (0%)"
Hello. This is my first post here; so I hope I am not breaking the rules by posting a help thread immediately after registration. I'll basically describe what has happened today with my PC. I was originally running Vista, but then I decided to upgrade to Windows 7 with a new hard drive. My issue...
Installation & Setup
Windows 7 x86 and x64 installation stuck at "Expanding Windows Files"
Hello, cheers to all of you who are trying to help! Like the title says, I'm trying to install Windows 7 on Toshiba Equium and every time setup stops on the "Expanding Windows files (0%)". I've tried to google the solution but not a thing I tried helped. Been there, done that list: Memtest...
Installation & Setup
Windows 7 install stuck at 0% on "expanding files" but works off USB
I torrented a windows 7 install disc iso. I burned it to a disc but when i tried to install windows 7 it gets to "expanding files" and freezes at 0% . After that i tried using the exact same iso but from a thumb drive, and it worked. I tried the disc on multiple computers and it always sticks at 0%...
Installation & Setup
Please help: Installation stops at "Expanding Windows Files 0%"
Hello, this is driving me crazy so if you happen to know something or someone who knows something about this, please help: this aftertnoon I tried to re-install some games on my desktop computer (a recently assembled computer with intel i3 cpu, kingston ddr 3 2gb memroy chip*2, western digital 1...
Installation & Setup
Windows 7 Installation Stops at Expanding Files
HELP!!!!!!!!!!!!!!!!!!!!! Alright, here is my issue. I have a Legit copy of W7, and all my hardware is new. The setup works fairly smoothely until the "Expanding Files" comes up. At which point, it doesn't proceed further than 0%, then after about 15 minutes, its pops up "required files...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:33.
Twitter Facebook Google+