Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 64bit installed on D but now shows on C

29 May 2009   #1

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
64bit installed on D but now shows on C

For 2 weeks I've had Vista on C drive and Win7(x86) on D drive. I've just formatted D and installed Win7(x64) and now, whether I boot with Vista or Win7, the OS I'm actually using is shown as being on C drive. So, when I boot Win7, all the files relating to Vista - plus all the other files which I stored on C - are magically transferred to the D drive. When I boot with Vista, all is back to normal.

It seems strange that this happens only with the 64 bit Win7. The 32 bit version was installed on D and stayed there! Can someone explain this phenomenon?

Also, should I concern myself with the 2 'Program Files' folders, one of which has '(x86)' after it? Am I right in thinking that if a program is 32 bit (but still usable with a 64 bit OS) Win7 will direct it to the correct Program File folder meaning I don't need to 'browse' to the other one if given a choice when installing?

Many thanks.

My System SpecsSystem Spec
29 May 2009   #2
Captain Zero

Windows 7 Home Premium x64

I had a similar problem, what I did was to use the Computer Management console (Start>Run>msconfig then tools tab, Computer Management, Disk Management) and it allowed me to view and mount the drive for Windows. That *may* work for you.
My System SpecsSystem Spec
29 May 2009   #3


Driver letters are dependent on the OS you're currently in. Don't worry about it.

About having two program files, that's due to 64 bit os. Your 64 bit programs will go in program files and your 32 bit programs will go in program files (x86)
My System SpecsSystem Spec

29 May 2009   #4


That has me puzzled, as to why your Drives changed letters.
Did you install x64 exactly the same way you installed x86.
my msconfig shows my boot as:

Attached Thumbnails
64bit installed on D but now shows on C-msconfig-win7.gif  
My System SpecsSystem Spec
30 May 2009   #5

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

Yeah, same install method (created a DVD and selected the drive which had "29.2 of 29.2 Gb free" - i.e. my D drive). It's not a problem but I just prefer the 'neatness' of having each OS stay in their own backyard.

I found Disk Management easily enough (didn't have to go through msconfig). I've not been able to work out what to actually DO in there mind. If there is a way to safely and permanently assign D to Win 7 I'd be glad to hear it.

My System SpecsSystem Spec

 64bit installed on D but now shows on C

Thread Tools

Similar help and support threads
Thread Forum
Win7(64bit) shows 3gb RAM usable but Vista (32bit) shows full 4gb Ram
I own an old Packard Bell Easynote MX37 laptop which was running Windows Vista Basic (32bit !!). I only use it now and then and decided to get a few more years life out of it and do some upgrades. It has an Intel T2390 Pentium 1.86ghz CPU (its a dual core). It used to have 3gb RAM (1x 1gb and...
Hardware & Devices
Ie 10 installed manually, still shows up in WU and wont go away
So a couple of weeks ago or so I installed ie10 manually. All fine and good and works well. Today ofc ie 10 comes in windows update so I figure its an update or something and install it. When I reboot its again in windows update even though I installed it already. Also in 'Installed updates' 2...
Windows Updates & Activation
Windows 7 64bit shows 3.73GB usable memory with 8GB installed
I have two sticks of 4gb PNY RAM (8gb total) installed in an Asrock A75M motherboard, which supports 16GB of RAM. I've already flashed my BIOS, thinking that may be it, but it didn't work. Windows 7 as well as my BIOS show that 8GB of RAM is installed, but only 3.73 is usable. I have an...
Performance & Maintenance
neo basic 2165 - 4gb installed but only shows 3gb installed
hey guys got an issue her thats been like a stubbed toe - just cant let go of it - im using a dual core neo basic 2165 - i just recently upgraded my ram to 4gb 2x - 2gb -ddr2 800 but it just shows 2.75 usable - and only 3gb installed - ive tried every thing so far- still same result-...
Hardware & Devices
Win7 RC 64bit only shows 1280x1024 max resolution?
Win7 RC 64bit only shows 1280x1024 max resolution? I have latest nvidia drivers My monitor shows as NEC LCD 1765 but driver is generic this what is limiting me from going to higher resolution? I know my GeForce 8600GT supports higher resolution than 1280x1024
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:36.
Twitter Facebook