Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Format and re-install - now I can't access my mp3's

23 Nov 2010   #11

Windows 7 - x64 Professional

Thanks gregrocker! I found a workaround now also... What I did was to open each folder and select all the MP files as a group and right click and select Share With - Homegroup (read/write). Now I can play the files and Win Media Player has imported them into the Media Player Library too.

Should I still do the Take Ownership thing as per your link then, or will this be OK?

My System SpecsSystem Spec
23 Nov 2010   #12
Microsoft MVP


Hi Greg -

You should not have to access files on the same computer by the same User by sharing them with Homegroup.

I'd take ownership of the folders starting with E itself, then if necessary the folder group or individual files. Use the shortcut placed on rightclick context menu to save time.

You should be able to Select All or highlight them in groups with the mouse to Take Ownership as a group if that's necessary.
My System SpecsSystem Spec
23 Nov 2010   #13

Windows 7 - x64 Professional

OK, I have installed the right click Take Ownership menu. Seems to do the trick. Now I have gone back and changed the share option ion each folder (album) to Dont Share and I have a little padlock icon on each folder. Seems to be working fine though and Media Player is playing the MP3's. I never had the lock icon on the folders before though - it this an issue I need to be concerned about or can I ignore it?
My System SpecsSystem Spec

23 Nov 2010   #14


Add the "Everyone" group with full control to the disk that hosts the .mp3
My System SpecsSystem Spec
23 Nov 2010   #15
Microsoft MVP


The lock simply means they are not shared with homegroup. If you don't have a Homegroup then it's not a concern.
My System SpecsSystem Spec
23 Nov 2010   #16

Windows 7 - x64 Professional

Great - thanks guys - appreciate the help!

Cheers for now
My System SpecsSystem Spec
23 Nov 2010   #17


so it works now? ^^
My System SpecsSystem Spec
23 Nov 2010   #18

Windows 7 - x64 Professional

Yup - all seems OK - I can access all MP3's and Windows Media Player can import them into the database OK too. At least I did not need to copy everything again - that would have been FUN...

I still have the padlock folder on all folders in my music main folder but I don't care too much about that as long as I can have full access. The PC is not networked to others.
My System SpecsSystem Spec
29 Mar 2011   #19

VistaHomePremiumSP2, recently switch to 7Ultimate64. And 1 old 2002 PC Win98,to XP SP3,now 7ultim32

I've always had this problem since owning ext HDD.

To be safe (and not knowing better still), whenever I do a re-install or even a system-restore, I'd always disconnect them from the machine, even the second internal HHD.
In my stumbling around with this, I found out that all my previous "full ownership and full-admin-user permissions" had remained in every single files. No torrents could ever finish writing (I always have some new "linux" downloading/seeding), otherwise, I would have never known.
Taking ownership back did not work until I had booted from a liveCD (UBCD for windows, Ubuntu liveCD, openSUSE live, or any) With this kind of boot, I can see every hidden folder. Useless trash bin; I delete that. Useless recovery folder; I delete that too. All I keep is MY FILES in those HDDs.
After this clean-up, I re-boot in SAFE MODE. I go down in system32 folder and look for cmd.exe (NO SHORT-CUT for me I then enter this command and wait for cmd to give me back ownership of those few 3TBs (an hour sometimes more) (you don't wanna know how long it takes to do this on a few 100GBs, files by files, in my first noobee ways, and I won't tell you either

The command;

takeown /f G:\,H:\,J:\,K:\ /r /d y && icacls G:\,H:\,J:\,K:\ /grant username:F /t

or one HDD at atime;

takeown /f G:\ /r /d y && icacls G:\ /grant username:F /t

It also helps dumping old-prefetch data when booting back, or simply let time and a few cold boot do it. (cold boot means shut-off, and then start-up. Not re-start or re-boot)

You can google the command to verify (yes google takes it to 100s of pages That's how I found it so....:)

Problem if be, is always related to the trash bin, but at least my files are free.

Also, I did the error of moving all my files from the older smaller HDD to the newer bigger once. That had moved also the trash bin. Never again. Folder option > show all system files. That way, I move only my files. The old trash bin and other stuff are reformated.

(moving files like this save me a defrag also, and almost better)

It's my PC. But most people have forgotten what that means: "Personal Computer", not a "Paralysis Chooser" or a "Persistent Chaperone" )

"Peace Cheers" )
My System SpecsSystem Spec

 Format and re-install - now I can't access my mp3's

Thread Tools

Similar help and support threads
Thread Forum
Access is denied. Trying to format a flash drive (in cmd)
Hello everyone! :) I've been trying to format a 32GB flash drive. I'm using DiskPart to format it, but still have no success. I've been trying and trying, but I always encounter the same error. "DiskPart has encountered an error: Access is denied. See the System Event Log for more information"....
Hardware & Devices
Can't access the encrypted files after the format
Hello This problem with my friend PC, he was using winXP, there was plenty of encrypted files in his D drive, now he formatted his PC to win7 ultimate, all the encrypted files are unaccessible, he don't don't know whether he backup the certificate or not, he know nothing about this, is there a way...
General Discussion
Unable to access or format external hard drives
I have 2 ADATA 500 GB external hard drives. I plugged them into the USB port and the computer recognized them by name and installed the driver files. It assigned both of them a drive letter but then gave me a message saying that they needed to be formatted. I clicked ok since they are brand new...
Hardware & Devices
Ext HDD Problem. Cant Access or format. Not responding. Filesystem RAW
Hello! I bought a WD My Passport 1TB awhile back, now i got problems. It worked fine until recently and i have tried different compuiters with no luck, and that tells me something is wrong with the drive. When i plug it in, Windows recognizes it and i hear the sound. The LED on the drive...
Hardware & Devices
Cannot access/format external hard drive, please help
I recently bought an SSD for my netbook, and took out the HDD and put it in an enclosure. When I connect it to either of my computers, it does not show up in my computer. I can see it in disk management and device manager, but I am not given the option to format or even partition it. I can change...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:43.
Twitter Facebook Google+