Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sysprep problems on WES 7

06 Jan 2011   #11
Kari

 

Would be nice to read you've succeeded! Keep us posted.


My System SpecsSystem Spec
.
06 Jan 2011   #12
cluberti

Windows 10 Pro x64
 
 

That error code in the context of IIS service starting actually means "Access Denied". I'm thinking at this point the sysprep is already partially done, and the machinekeys goo no longer matches the security of the user starting the service, so it fails.

I hate to ask as I know you're working hard on the image and probably have done a lot of pre-req work, but do you really absolutely need to have IIS installed before creating the image? If you're just installing it so that it's there for after the sysprep it would be better to use dism /onlinen to add it post-sysprep. If you absolutely positively MUST have it installed pre-sysprep, we'll have to dig into this. You might be SOL on that image right now though, unfortunately.
My System SpecsSystem Spec
06 Jan 2011   #13
kmfraley

Windows Embedded Standard 7
 
 

Yeah, we are thinking along the same lines. We would like to include MSMQ in the image, but it has a required dependency on IIS 7.0. So, as a test, in order to eliminate IIS 7.0, I also have to eliminate MSMQ. I wonder what's up with that??? I'll go ahead and create a new unattend minus MSMQ (and IIS 7.0) and see what happens.
My System SpecsSystem Spec
.

06 Jan 2011   #14
cluberti

Windows 10 Pro x64
 
 

MSMQ probably requires IIS because it (as of v3.x) uses HTTP and SOAP messaging on both ends to do messaging, and these components come out of IIS binaries natively. I suppose they could re-write MSMQ to also have that functionality, but that doesn't make much sense.

If you do not have to configure MSMQ or IIS before sysprep'ing (hopefully you can do that unattended afterwards), that is always a better way to do imaging - less is more when it comes to sysprep, at least with inbox services like IIS.
My System SpecsSystem Spec
07 Jan 2011   #15
kmfraley

Windows Embedded Standard 7
 
 

Well, after removing MSMQ from FeaturePack-->Application Support and removing IIS 7.0 from FeaturePack-->Internet Information Services - IIS from my answer file in ICE, I installed the image on my target hardware. Immediately after installing, I ran "sysprep /audit /generalize /shutdown" per Creating a Build-to-Order (BTO) Windows Image at What Is Sysprep?
It looks like sysprep ran properly and no errors were reported in setuperr.log. I checked the Windows Setup State at HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\State and verified the state was set to IMAGE_STATE_SPECIALIZE_RESEAL_TO_AUDIT. So, what appears to be a bug has been worked around.

Cluberti, I have another question related to your statement, "...it would be better to use dism /onlinen to add it post-sysprep." In order to get MSMQ back (as well as IIS 7.0), my understanding is that I'll have to run "dism /online ..." after ...
  1. loading additional applications
  2. applying various group policies
  3. running "sysprep /oobe /generalize /shutdown" on the reference machine
  4. duplicate my CF as needed for mass deployment
  5. boot duplicated CF on target hardware
  6. run something like "dism /online /Add-Package /PackagePath:<package-path>" on each target before shipment. It seems this is the kind of thing the overall process was meant to avoid?!?!?
Does that sound about right?
My System SpecsSystem Spec
07 Jan 2011   #16
cluberti

Windows 10 Pro x64
 
 

I never ever add applications to my base WIM, so I personally disagree with step 1 - however, there could be good reasons to lock an app into an image, so I won't knock it. I would just say that adding things into an image means you're going to have to recreate it if you need to go and update or change those apps in the future, meaning you have to redo your imaging entirely. I much prefer the MDT or SCCM way of doing things, where you put down an unchanged WIM with your unattend.xml desired changes, inject drivers during WinPE, reboot and then add apps, make settings changes, etc. However, like I said, there are always multiple ways to do imaging with Win7, and there could be a valid reason to do it another way - those ways can be quicker to plunk down an image, but with the tradeoff that they need ongoing maintenance attention.

As to step 2, technically you don't need to do this at all - any deviation from default settings (as would be configured in group policy) are removed and reset via sysprep, so whatever you do here is whacked anyway.

As to step 6, to add features via dism.exe like MSMQ or IIS to Windows Embedded, you should read this blog post on MSDN - basically you're creating an unattend file and config set with ICE, and then Apply-Unattend is run against it with dism later to apply it and install the packages you specified with ICE.


I believe you can install WE7 using MDT 2010, so it is something to look into. It might help you be more flexible and repeatable in your installs, as well as providing a lot of built-in logic for things like patches, drivers, hardware detection, etc., and avoid some of the things you're likely to run into doing it the "prescribed" ways on technet.
My System SpecsSystem Spec
18 Feb 2011   #17
kmfraley

Windows Embedded Standard 7
 
 

It looks like WES 7 SP1 CTP has addressed the problem. To test, I replaced MSMQ and resolved IIS 7 dependencies, rebuilt the image, and installed it on my reference machine. Eventually, when I get to the point where I need to run "sysprep /oobe /generalize /shutdown /unattend:my-Sysprep-Unattend-File.xml", it runs to completion and shuts down the reference machine per the shutdown switch. After duplication, I brought the image up on my target hardware and verified ...
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\State\ImageState = IMAGE_STATE_COMPLETE
So, looks like its fixed.


See ...
http://social.msdn.microsoft.com/Forums/en-US/quebecservicingdeployment/thread/8c71a9e8-3e9c-4880-84bc-fcae16f85bda?prof=required ... for details.


Thanks for your help.



Kris
My System SpecsSystem Spec
21 Feb 2011   #18
cluberti

Windows 10 Pro x64
 
 

Good to hear!
My System SpecsSystem Spec
Reply

 Sysprep problems on WES 7




Thread Tools




Similar help and support threads
Thread Forum
Sysprep - Windows 7 - unable to sysprep image that joins domain
Good morning all: Below is my unattend.xml. I am using the sysprep + win7 for creating virtual machines in Red Hat Enterprise Virtualization 3.0 but having difficulty getting them to auto-join the domain. My sysprep progression proceeds normally and completes. The initial boot of the image...
Virtualization
Sysprep problems - New Hardware
Here's the deal: I built a new system completely from the bottom up, but wanted to keep my old hard drive with Windows 7 on it. I started out using sysprep with some problems (windows media network was still on, and such things) I straightened all that out, and fully completed the sysprep. After I...
Hardware & Devices
win7 after sysprep reboot always with sysprep box
hello, 1st sorry for my english (i'm french guy). I made a sysprep and all parameters are corrects. but after the reboot I have always the sysprep preparation tools box. for me the sysprep is correct but I don't know what's happended. in attachment my unattend.xml
Installation & Setup
Having problems using USMT for vhd sysprep!
Hey there. I sysprep'ed my VHD, it booted fine BUT it FORCED me to make a new account, which I do not want to do. I had a custom named administrator as the only admin/user on the box before I made the image etc.. It's fine for it to boot with that custom named administrator, it's what I...
Virtualization
Sysprep Problems
Hi All, I work in an IT department and have developed a sysprepped Windows 7 Professional image using WAIK. It works well, however there are 2 things that I have been unsuccessful in figuring out at this point: 1. At the time of the creation of this image, WAIK was unable to correctly...
Installation & Setup
Sysprep
Can you do Sysprep on Windows 7 like on XP? OK so you do a clean install of W7. Then install all of your software. Now you want to set it up to clear all of the information. That way when you sell it or give it away, the person turns it on is goes through the initial walk-through process...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App