Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: start menu - no progs show up

23 Jun 2009   #1
commons

win 7 rc
 
 
start menu - no progs show up

hi there :-)

i _upgraded_ win 7 beta to win 7 rc. according to hack to edit ini to build7000 instead of release buld7100.

i did a manual backup. i did an easy-transfer.

upgrade took its time --- but as far as i can see by now, after 1 day, most of even tiny personal settings are present.

BUT --- no progs show up in start menu. if i look in

... users / [...] / app data / roaming / microsoft / windows / start menu

well, yes ... there's "programs" folder. & in it i find all shortcuts to sub-folders & apps ---

nonetheless: in start menu / all programs ... _nothing_ shows up. a very white empty space.

yes, i can access apps by doing search or creating new shortcuts in different locations. yes.


nonetheless... if anybody heard of this b4 & knows a fix --- i'd be glad.


no, if i can avoid it... i don't wanna to do a clean install. i wanna wait 'til october, get a license then & do a complete format, re-partitioning, data-structure etc _THEN_.


btw --- thx for this forum na :-)

wish u well


My System SpecsSystem Spec
.
23 Jun 2009   #2
greenlink23

Vista & Win 7
 
 

i just had this happen to me yesterday. the way i fixed it (and i know sounds stupid but it works) was i went to users / [...] / app data / roaming / microsoft / windows / start menu and right clicked on the programs folder, then properties. then i checked the 'hidden' check box to make the folder (and all subfolders) hidden. then click 'ok'.

i don't know what happened to make the programs disappear in the start menu. i don't know why making that folder hidden makes them reappear. all i know is that it worked for me.

and im running a clean install of the RC.

hope this helps as it bugged the hell out of me all day.
My System SpecsSystem Spec
23 Jun 2009   #3
commons

win 7 rc
 
 

wow. that was fast. &: _it works_ !!!

nonetheless... now that i'm working (as in: really working) w setup for a day... i encounter some really weird slow-downs now & then. so i guess... i'll do a clean install on weekend.

anyhow: lot of thx from thailand to canada :-)
My System SpecsSystem Spec
.

25 Jun 2009   #4
commons

win 7 rc
 
 

i'm sorry... but after another day... i'm back to square one ;-)

there seem to be some problems with

a) old/previous entries in "start menu" - be that authentic installation routines, manual add-ons. subfolders as well as app-entries. some show up, others don't.

*

b) i don't get that obviously there are _2_ managing paths:

b.1) C:\ProgramData\Microsoft\Windows\Start Menu\Programs

b.2) C:\Users\[...]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs


it seems authentic new software installation _tends_ to go for b.2. but there are exceptions.

even copying or short-cutting files/folders from one location to another doesn't help.

also, greenlink23's hack "to hide" "C:\Users\[...]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs" does not _reveal_ folders/apps... that are registered in b.1 &/or b.2 --- but nonetheless don't show up in "start menu"

*

c) after a day now... "start menu" is blank again.

d) also, "recent items" don't show any entries.

*

i _upgraded_ from an oem-vista to sp1 to win7 beta. & it all worked out fine.

by _now_ i'd say... i'll try a clean win7rc install next days.
My System SpecsSystem Spec
29 Jun 2009   #5
polycue

Windows 7 Professional x64 x86 VISTA XP 98SE 95 3.x
 
 

When this problem occured to me during a beta install I simply created another administrator account. The new user account worked flawlessly.
My System SpecsSystem Spec
30 Jun 2009   #6
commons

win 7 rc
 
 

Quote   Quote: Originally Posted by polycue View Post
When this problem occured to me during a beta install I simply created another administrator account. The new user account worked flawlessly.

thank you poly cue. that sounds like a reasonable approach :-)

i took the opportunity now to... complete re-organize hard disk & data structure, did a clean win7rc install, slowly added app & by app... like renovating an old house ;-)

& by now it's running fast & sweet :-)

though problem occured again after i installed some 9year old app ;-(
My System SpecsSystem Spec
30 Jun 2009   #7
polycue

Windows 7 Professional x64 x86 VISTA XP 98SE 95 3.x
 
 

Quote   Quote: Originally Posted by commons View Post
though problem occured again after i installed some 9year old app ;-(
Which "9year old app"?
My System SpecsSystem Spec
10 Jul 2009   #8
commons

win 7 rc
 
 

Quote   Quote: Originally Posted by polycue View Post
Which "9year old app"?
some special astrology stuff na :-)

anyhow... i've encountered same problem again & again last weeks w up-to-date apps. [eg, i haven't found any cd/dvd-burning app. i worked w nero for years & i encouraged many ppl na. by now: no way. pls hv a look @ nero web-site/forum to learn ab "customer support". ashampoo install left start menu "blank"]

as i'm not paid for testing & i need system running... by now... i'm creating sys-restore points b/4 _any_ install.

*

it was _way_ different while migrating from vista to 7b.

i'm not "complaining". win7 is first ms os in decades i really appreciate
My System SpecsSystem Spec
15 Dec 2009   #9
chatchai29

Windows 7
 
 

Quote   Quote: Originally Posted by greenlink23 View Post
i just had this happen to me yesterday. the way i fixed it (and i know sounds stupid but it works) was i went to users / [...] / app data / roaming / microsoft / windows / start menu and right clicked on the programs folder, then properties. then i checked the 'hidden' check box to make the folder (and all subfolders) hidden. then click 'ok'.

i don't know what happened to make the programs disappear in the start menu. i don't know why making that folder hidden makes them reappear. all i know is that it worked for me.

and im running a clean install of the RC.

hope this helps as it bugged the hell out of me all day.
Thanks
its working 1000%
My System SpecsSystem Spec
Reply

 start menu - no progs show up




Thread Tools




Similar help and support threads
Thread Forum
Applications no longer show in the Start Menu
edit: well, that was a quick fix. After I looked in the Start Menu properties to see if there were any settings there I could change, applications now show up fine. Yesterday I was upgrading a friend's laptop from Vista to 7. Before installing 7, I wanted to take a backup of their user folder....
Performance & Maintenance
Start Menu - Show All Programs automatically
Hi I would like to know if is possible to show All Programs in the start menu automatically when you click the orb. Because clicking every time to show the list of All Programs is not very nice since I don't use the recently programs open function.
Customization
Only show restart in start menu
Is there a way to only display restart in the Windows 7 start menu without any other options? I work in a domain environment and I recently deployed 30 machines with a generic username that logs on automatically. We need these particular machines to be up and ready for a user when they walk up to...
General Discussion
My Music link won't show up in Start Menu
Hi, for some reason when I go to start menu properties, and customize, the Music shortcut is ticked to be displayed as link but it's not showing up. Anyone have any ideas what could be causing this?
General Discussion
How to get recently used programs to show up in start menu again
A while back I used a few different programs to tweak Windows 7. One of the programs I used caused the recently used programs to stop showing up in the star menu. Under properties now I can't even set the number of programs to show because it is grayed out and unselectable. Any body know how to get...
General Discussion
Start Menu doesn't show after upgrade to 7068
Untill now Windows 7 has been my system of choice, but since i've upgraded from 7057 to 7068 (i've always made upgrades and always went superb) my start menu doesn't show up, the shortcuts are all intact in All users and current user ( "%programdata%\Microsoft\Windows\Start Menu" and...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App