Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: MSI installer "could not open key: \UNKNOWN\component..."

02 Feb 2011   #1

Windows 7 Ultimate x64
MSI installer "could not open key: \UNKNOWN\component..."

signed up @ 7-forums to get pointers on this - a lot of googling over the past two days have lead to different threads here - seems like a great community.

so, i'm migrating a 32 bit software environment to 64 bit, and have not grown any more fond of bill OR steve than i used to be. the combo of the two is the pits - MSI-installers for quicktime / iTunes.

anyway - here's the current thing i'm trying to resolve: while installing yet another app, i the installer throws an error message: "could not open key: \UNKNOWN\component\xxxxxxxxxxxxxx214835\

now - this is a new feature in 7, never saw it in XP. ok, so the registry key has permissions that are not allowing access for the installer to alter it. i ran into this a few times already and was able to resolve by taking ownership / altering the permissions.

but on this round - THERE IS NO SUCH KEY! so what permission is being denied? how to get past this?

cheers in advance!

My System SpecsSystem Spec
02 Feb 2011   #2
Microsoft MVP


It seems this occurs when the software is not completely uninstalled. Can you still use Revo Uninstaller to uninstall all of it's components?

I understand you cannot find the key shown, however there is a successful fix given here which access the Installer key. Set a restore point first:

Open “RegEdit” and browse to the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components
  1. Right Click on Components select permissions
  2. Click Advanced
  3. Select the “Owner” Tab
  4. Select Administrators (Group) as owner and Click Apply.
  5. Then Select Checkbox that says “Replace owner on sub containers and objects” and Click apply.
  6. Browse back to the Permissions tab, select the Check box that says “Replace all child objects with inheritable permissions from this object” and Click apply
You should see couple of Warnings similar to below image, but those are fine. Its just complaining about some restricted windows components.

Source: How to resolve “Unable to open Sub key” Error when installing an MSI package? | Ctrl+F5 and repeated in several other sources.
My System SpecsSystem Spec
02 Feb 2011   #3

Windows 7 Ultimate x64

many thanks, gregrocker.

revo - will give it a go. though i have already used win 7 manager uninstaller component in an attempt to remove the dregs. on a cursory glance revo appears similar, though if you think it does a better job managing the mess msi leaves behind i'll be happy to $hell out for it.

you guessed right - i know how i'd do it for a key that's there, but i can't take ownership/gain access to a key that does NOT exist.

continuing - the way i got quicktime/iTunes installed was by breaking their EXE installation packages into pieces. but this one doesn't break - it says it's packed with MS visual C 6.0 & i don't have the tools to split it.

continuing2 - is there a way to recursively alter permissions on the whole registry the way icacl does for files? this would come in handy dealing with problems like these... (yes, i'm currently blissfully unconcerned about security - just would like to get to doing actual work on the 7 system and worry about security later).
My System SpecsSystem Spec

02 Feb 2011   #4
Microsoft MVP


Another idea is to post also in the Itunes install forum: Apple - Support - Discussions - iTunes

There may be others who know about this who can help you.

I've been fortunate so far with my Itunes installs but that's where I'd go if the error googled to a dead end.
My System SpecsSystem Spec
02 Feb 2011   #5

Windows 7 Ultimate x64

revo looks very promising - running the trial now.

i DID finally get iTunes on, though the current problems is for something a bit related - codecs for quicktime.

how about recursive altering of registry permissions?
My System SpecsSystem Spec

 MSI installer "could not open key: \UNKNOWN\component..."

Thread Tools

Similar help and support threads
Thread Forum
SP1 won't install - "Unknown error" / "Service does not exist"
Hello - I've repeatedly tried and failed to install Service Pack 1. I have run the update readiness tool, and have run chkdsk and sfc. I've tried installing through Windows Update, as well as downloading the standalone installer from Microsoft. The former results in an "unknown error"; the...
Windows Updates & Activation
changing an ".ost"file to open with "unknown" application
I changed my outlook email .ost file to open with auto cad by mistake. Initially it was opening with an Unknown application. How can I enable it to open with an unknown application again? please help
register for a "windows explorer context menu component"!
After running a program downloaded from the internet to verify file associations, I now have this problem :- Each time I right-click on a shortcut on the desktop and then click on "Open", a window opens, asking me to register for a "windows explorer context menu component"! I can't close the...
General Discussion
sfc: "Cannot verify component files for" ... "manifest is damaged"
Thanks to other helpful threads on these forums, I have worked through some maintenance that seems to have resolved the constant BSODs I was having, in large part via sfc /scannow. I believe I only have one issue remaining as far as sfc is concerned: Cannot verify component files for...
Performance & Maintenance
Component "COMDLG32.OCX" or one of its dependancies
Component "COMDLG32.OCX" or one of its dependencies not correctly registered: a file is missing or invalid. This is the error message I got when trying to open a program used at my place of work. Is there either a way around this or a way to fix this so that this error message no longer pops up...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:29.
Twitter Facebook Google+